1. Download our Official Android App: Forums for Android!

Root [MetroPCS] Metro PCS GS4 ROOT (SGH-M919N)

Discussion in 'Android Devices' started by jrvasey, Jul 15, 2013.

  1. Shabbypenguin

    Shabbypenguin Extreme Android User
    Rank:
     #28
    Points:
    723
    Posts:
    5,385
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    5,385
    5,071
    723
    Male
    most roms/kernels should be using exfat just fine. i know ktweakers kernel has exfat support at least. as far as hotspot goes youll have to refer to tmobile/metro folks on that one. as a word of warning though my recovery doesnt support exfat so youll be left out should you try to use it in recovery.

    what branch were ya in?
     

    Advertisement

    noirelion likes this.
  2. nuttmeg

    nuttmeg Extreme Android User
    Rank:
    None
    Points:
    313
    Posts:
    7,330
    Joined:
    Feb 9, 2011

    Feb 9, 2011
    7,330
    2,525
    313
    Making you wonder?
    Lone Star State
    http://forum.xda-developers.com/showthread.php?t=2264932 or http://forum.xda-developers.com/showthread.php?t=2292054 and use the tmobile USA in the aroma installer and there is a kernal that support 64gb cards.
     
  3. noirelion

    noirelion Newbie
    Rank:
    None
    Points:
    16
    Posts:
    34
    Joined:
    Nov 6, 2010

    Nov 6, 2010
    34
    5
    16
    Male
    blue collar slob.
    Philadelphia PA (gtown)
    US Army- Airborne Infantry Scouts for the 109th Military Intelligence Battalion and 1st 505th Parachute Infantry Regiment 82nd Airborne Division. Fit to fight born to kill... we be proud and nasty....

    Thank you so much for that kernel info...shabbypenguin and nuttmeg. (Without you guys so many of us would be totally lost..thanks)


    Edit: most roms now support exfat 64gb microsd...guess my squeaky wheeling got the grease.
     
  4. Shabbypenguin

    Shabbypenguin Extreme Android User
    Rank:
     #28
    Points:
    723
    Posts:
    5,385
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    5,385
    5,071
    723
    Male
    ooooohhh, im sorry :p
     
  5. noirelion

    noirelion Newbie
    Rank:
    None
    Points:
    16
    Posts:
    34
    Joined:
    Nov 6, 2010

    Nov 6, 2010
    34
    5
    16
    Male
    blue collar slob.
    Philadelphia PA (gtown)
    let me guess you are one of those marines? My gramps used to tell me- "you wanna take over a beach- join the Marines, but if you want to take over a nation join the 82nd Airborne".
    In 18 hours the DRF-1 (Division Ready Force 1 of the 82nd Airborne -is anywhere on planet Earth dropping from the sky -and we come down swinging-fighting the enemies' entire forces alone- til the rest of the US military gets off its ass. No other unit in our military or in the world has this known capability. Other units have specialty troops for specific missions...but bar none- the 82nd Airborne is the finest frontline combat unit in this worlds' history- and still bears that title proudly.
     
  6. Shabbypenguin

    Shabbypenguin Extreme Android User
    Rank:
     #28
    Points:
    723
    Posts:
    5,385
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    5,385
    5,071
    723
    Male
    Nah was a combat engineer, 10th mountain div. just always had the airborne guys who came from bragg think anyone who didnt jump out of a perfectly good airplane was crazy :p
     
  7. noirelion

    noirelion Newbie
    Rank:
    None
    Points:
    16
    Posts:
    34
    Joined:
    Nov 6, 2010

    Nov 6, 2010
    34
    5
    16
    Male
    blue collar slob.
    Philadelphia PA (gtown)
    If I wasnt an airborne infantryman the only unit I would rather be in would be the combat engineers. The heavy weapons and attitude required to bear them appeals to me.
     
  8. william1964

    william1964 Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    210
    Joined:
    Sep 30, 2012

    Sep 30, 2012
    210
    60
    53
    Male
    Banker
    Puerto rico / Tampa, fl
    Help I just move from s3 to metropcs s4, I having problem with root access. I try odin did everything as instructed everything went smooth I got the green light PASS but went I try root checker I have no root access, then I try motochopper same thing everything went smooth I have superuser install, once again no root access. What am I doing wrong???
     
  9. nuttmeg

    nuttmeg Extreme Android User
    Rank:
    None
    Points:
    313
    Posts:
    7,330
    Joined:
    Feb 9, 2011

    Feb 9, 2011
    7,330
    2,525
    313
    Making you wonder?
    Lone Star State
    Source: http://www.android.gs/root-t-mobile-samsung-galaxy-s4-m919-on-android-4-2-2-using-cf-auto-root/

    Root Android 4.2.2 Jelly Bean for Samsung Galaxy S4 T-mobile using CF Auto-Root tool:
    1. Download the CF Auto Root zip for TMO Galaxy S4 from here. Save the file on your PC.
    2. Extract its contents and save them to a folder that’s placed on your computer’s desktop for easy access. You should get a file with the .tar.md5 extension, don’t extract any further than that.
    3. Download Odin 3.07 from here. Extract its contents.
    4. Power off the Galaxy S4 TMO completely by removing its battery. Re-insert the battery after 5 seconds have passed.
    5. Now, boot your device into Download Mode.
    6. Launch ODIN exe on your PC.
    7. Connect the phone to your computer via USB cable. ODIN should display a confirmation message that says ‘Added!!’. Continue to the next step.
    8. > if Odin doesn’t recognize the phone, then you will need to change USB ports or re-install the Samsung USB drivers, a download link is listed above in the preparation guide.
    9. Next, click the PDA button in Odin and find the ‘CF-Auto-Root-jfltetmo-jfltetmo-sghm919.tar.md5′. Load it into ODIN.
    10. > don’t change any default settings of ODIN, just make sure that the Re-Partition one is disabled.
    11. Click the START button when you’re ready for the installation to begin.
    12. After the flash is complete and the CF Auto Root tar.md5 file is installed, ODIN will say PASS and the device will restart to normal mode.
    13. Unplug the phone from PC and wait for the first boot process to complete.
    14. Check the App drawer for the SuperSU icon, which confirms that the root has been completed.
     
    qandres12, ARocker and william1964 like this.
  10. danyvw

    danyvw Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    685
    Joined:
    Dec 1, 2010

    Dec 1, 2010
    685
    208
    93
    USA
    Then after doing all steps nuttmeg already post you can flash thru Odin the Custom Recovery you like the most.
     
  11. william1964

    william1964 Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    210
    Joined:
    Sep 30, 2012

    Sep 30, 2012
    210
    60
    53
    Male
    Banker
    Puerto rico / Tampa, fl
  12. ReViZeD

    ReViZeD Newbie
    Rank:
    None
    Points:
    36
    Posts:
    25
    Joined:
    Feb 27, 2012

    Feb 27, 2012
    25
    2
    36
    hello all, i know its been about a month although i wanted to ask if anyone has advice for a n00b,

    followed everything and i always get `started with errors` the log shows failed in the 1st , 3rd and 4th fields counting down from the top.

    i tried changing a bunch of different settings in the free wifi tehter app settings although even when the logs shows no fields failed, i have yet to be able to see my ssid on any deivice i can never see the signal being brodcasted form my s4 to even try and connect to it.

    i got the metropcs s4 , sgh-m919n (thought it was same as t-mobile (tim-lee-moble) i got the unlimited $60 plan.

    i was reading an article on xda [KERNEL] Stock Touchwiz MDB - SetUID Restriction Removed

    being said basically something about the stock kernel`s setuid preventing it from working , has anyone tried this on the metro branded (t-mobile) s4? i was concerned about messing up the phone. the tutorial is for the t-mobile branded version of the s4 - so subtract the metropcs part.lol

    ps. "whats the difference between them now!?!?!?!?!?"
     
  13. Shabbypenguin

    Shabbypenguin Extreme Android User
    Rank:
     #28
    Points:
    723
    Posts:
    5,385
    Joined:
    Mar 28, 2011

    Mar 28, 2011
    5,385
    5,071
    723
    Male
    be careful with regarding flashing kernels, a lot of times those "rooted" kernels sometimes dont get updated so you flash it and now have an incompatible kernel.

    i would suggest flashing recovery, flashing root from there and then a custom kernel that is current from a kernel dev from tmobile :)
     
    ARocker and mike28 like this.
  14. ARocker

    ARocker Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,274
    Joined:
    Aug 17, 2011

    Aug 17, 2011
    1,274
    764
    233
    Male
    Jersey City, NJ
    If wifi tethering is your goal then i would follow Shabbypenguins advice and first flash a recovery and root your device. The instructions for this is two posts back from yours :)

    Once done you may want to check this thread. Some have written that they had success with this method.

    http://androidforums.com/metropcs-galaxy-s4-all-things-root/779830-wifi-tether.html

    Good luck!
     
  15. ReViZeD

    ReViZeD Newbie
    Rank:
    None
    Points:
    36
    Posts:
    25
    Joined:
    Feb 27, 2012

    Feb 27, 2012
    25
    2
    36
    than ks guys i just bought the app and says waiting forever lets see if the sev helps out , i read like 10 reviews and they all said dint wpork right or at all at first and the dev responded quick and got it going.


    the dev fabio said when that happens means you have problems with root access. super user needs to be updated or
    although i sent him photos of titianum backup ,root browser and his app in the allowed list in super user. then i actually read his message that said to install superSU so i had to say i was sorry i wasnt listening and being foolish , i just did a cwm back up
    did what you said to do and installed suoerSU and it said the binaries needed to be updated
    and asked to try and reboot using cwm, upon boot up i clicked yes then
    completed and booted up then i see an icon
    super user open up and said kinda the same thing superSU did it needed
    to update binaries , didn't know if it would conflict with superSU or
    what to do so i clicked cancel and then opened superSU and it said
    another app installed could cause conflicts with it and asked if i
    wanted to uninstall them/it , again i clicked cancel. and tried to un
    wifi router with same results,
    He said you can not hold 2 app for super user you have to leave ony installed superSU you update the binary super SU then please try app.
    so i went to applications and could only chose disable for super user so i did and rebooted and still same results.
    then he said to uninstall his app and reinstall , tried again and still hangs on (wait...)
    he said it is a problem with my device and said to try and find a solution.lol



    ps. my device has always been rooted, only down side i have seen so far is on my deivce i cant always send mms for some reason.

    and i my girls s4 her 64gb sd card stopped being able to be read , so i found out that i needs to format it like fat or fat32 n stuffs to get it working again. weird huh

    got a samsung microsd card and everything is good , awesome work !! i was all tripping when the wifi tether app finally worked , that was unitil i running to my pc i was redirected to t-mobile (tim lee ) upgrade (upsell upsell ..felt like i was a car salesman for a sec.lol)

    so i did some reading about all this junk a while back and remember peeps talking about using something to circumvent tim-lee sniffing the packets or whatever it was , one way was using a vpn , although from what i seen the vpn`s out there were kinda like having a nice virus in order to get it working.lol.

    sure enough tether worked with full speedz on my girls s4 and not on my pc , do i need a vpn if the tehter is working on another s4?
    can i please hear a bit of advice on where to go from here?

    forgot to mention a huge thanks!! to arocker now me stock wifi works, it didnt with the stock kernel
     
  16. ReViZeD

    ReViZeD Newbie
    Rank:
    None
    Points:
    36
    Posts:
    25
    Joined:
    Feb 27, 2012

    Feb 27, 2012
    25
    2
    36
  17. dcap0187

    dcap0187 Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    239
    Joined:
    Jan 22, 2013

    Jan 22, 2013
    239
    83
    53
    indentured servant
    miami
    Wifi tether router has to be the easiest way.
     
  18. bsquirrell

    bsquirrell Member
    Rank:
    None
    Points:
    35
    Posts:
    71
    Joined:
    Jan 23, 2012

    Jan 23, 2012
    71
    0
    35
    Clermont Florida
    HI, I just cannot root my Samsung m919n, I have followed all the steps, (I think)Have downloaded the samsung drivers, Odin 3.07 installed twrp recovery, then when I boot into download mode, I get, in very small writing, odin mode,
    product name sgh m919n,
    current binary custom,
    system status custom,
    csb-config lsb 8x30,
    write protection enable,

    Now I haven't got a clue what all this means, can anyone help please.
    I finally got Metro pcs to unlock this phone for me
     
  19. ARocker

    ARocker Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,274
    Joined:
    Aug 17, 2011

    Aug 17, 2011
    1,274
    764
    233
    Male
    Jersey City, NJ
    If you've already installed TWRP recovery, all you need to do is flash this
    http://download.chainfire.eu/339/SuperSU/UPDATE-SuperSU-v1.41.zip?retrieve_file=1
    from within TWRP.

    Download it to your SD card, reboot to TWRP, click install, find the SuperSU-v1.41.zip and flash it. Then you'll be rooted.
     
  20. bsquirrell

    bsquirrell Member
    Rank:
    None
    Points:
    35
    Posts:
    71
    Joined:
    Jan 23, 2012

    Jan 23, 2012
    71
    0
    35
    Clermont Florida
    Thanks for the info, but it wont boot into TWRP it only boots into the info I gave above, I must be doing something wrong, but I haven't a clue what it is. Could there be a file blocking it. I bought the phone in September it is running .4.2.2 kernel version 3.4.0 795095? On looking at everything on my phone, I have to admit I cant find twrp,but it passed when I did the process on odin 3.07 so could that be my problem.
     
  21. new optimus

    new optimus Android Expert
    Rank:
    None
    Points:
    413
    Posts:
    4,205
    Joined:
    Mar 10, 2011

    Mar 10, 2011
    4,205
    1,459
    413
    Jax Fl
    your booting into download mode, you need to boot into recovery.

    I dont know how that phone does it, but most samsung its hold volume up button then press power.

    While phone is off. when the phone starts let go of power but continue to hold volume up.
     
    bsquirrell likes this.
  22. bsquirrell

    bsquirrell Member
    Rank:
    None
    Points:
    35
    Posts:
    71
    Joined:
    Jan 23, 2012

    Jan 23, 2012
    71
    0
    35
    Clermont Florida
    now in recovery backing up phone
     
  23. ARocker

    ARocker Android Expert
    Rank:
    None
    Points:
    233
    Posts:
    1,274
    Joined:
    Aug 17, 2011

    Aug 17, 2011
    1,274
    764
    233
    Male
    Jersey City, NJ
    Good :)
     
    bsquirrell likes this.
  24. bsquirrell

    bsquirrell Member
    Rank:
    None
    Points:
    35
    Posts:
    71
    Joined:
    Jan 23, 2012

    Jan 23, 2012
    71
    0
    35
    Clermont Florida
    :)The phone is rooted, it is so easy,when you do it right, Thanks guys
     
  25. Digital Controller

    Digital Controller The Real Bass Creator
    Rank:
    None
    Points:
    953
    Posts:
    12,643
    Joined:
    Sep 5, 2012

    Sep 5, 2012
    12,643
    3,557
    953
    Male
    Civil Engineer
    Cincinnati, Ohio
    Glad you got rooted and everything is all good!

    Feel free to stop by here again if you have any kind of issues :)
     

Share This Page

Loading...