1. Check out our companion app, Forums for Android! Download from Google Play

Root [MetroPCS] Not registered on network

Discussion in 'Android Devices' started by Rooqy, Oct 21, 2013.

  1. Rooqy

    Rooqy Well-Known Member
    Thread Starter

    Jul 6, 2013
    Hey guys so I just got the metro s4 about a week ago not from the metro store. I activated it and it was working great. Its stock rooted. I have 2 different backups with the efs backed up.

    Today I went to a location where I didn't have signal the E came up im guessing thats roaming. Then when I left that location I couldn't connect to data send texts or make calls. When I try to make a call it says not registered on network. Ive tried restoring from backup but the problem is still there. It was working fine and the only thing ive really done is install xposed framework some modules and the note 3 filemanager so Idk what the problem is x(

    Anybody have an idea?? Also the imei number is still there in the status of the phone :/

    EDIT: So I returned to complete stock and still no luck :/ im guessing its something with metro I have to go in x(


  2. warduke

    warduke Member

    May 3, 2011
    Did you ever get this resolved? I am currently having the same problem. I tried reflashing my phone to stock, new sim card and it still will not register on the network

Share This Page