Root [MetroPCS & T-Mobile] please read. storage issue related


I have link2Sd set up including the key to store data as well.

I also have smanager set up to run script

I have over 1gb of free space and still cant install new apps. It says i have no space.

I can honestly say, i have done everything i could to maximize my storage.

I have partitioned sd card.

Over 1gb of free space and no way to install apps. No space!

Ive done all the cache tricks.

I have resorted to moving some apps such as busybox, and rootbrowser to system apps. I deleted all bloatware and then some.

So now im left only being able to.install apks downloaded through the web as system apps. Is this safe. Its the only way i can.currently install apps and i do it through
Lucky patcher.

I am working on moving the newly installed system apps by converting them into user apps through the help of lucky patcher.

With all these tools at my disposal and I have to still experiment and find a way to make this work.

ANy suggestions?


Android Enthusiast
So im guessing no one gives a bleep untill it happens to them.
I don't think that the lack of response to your problem is because no one here gives a damn, maxslove. More to the point, no one has an answer to it. I know I don't and I know this phone pretty good. I'd help if I could if that's what your looking for but that still doesn't fix the issue. If I come across answers to this topic in the future I will let you know. Good luck. ;)


This problem sounds like the problem I had a few days back. I used link2sd and had about 800mb free on my sd card. Also I keep my cache free and clean. The problem was that I couldn't download and install any app from the play store, nor could I install apps by downloading their apk and doing it manually. It kept saying that my storage was full all the time.

I think the problem I had was because I had installed a ROM earlier on and I didn't clear the dalvik cache, data, or anything else before doing so. I just installed the rom over the previous one and didn't fully "reset" the phone before doing so. The funny things that happened to me after this was that I could move pretty much ALL my apps to the sd card, even apps that aren't supposed to have that option in the settings. For example, I could go into my settings and click on Google Chrome and press "Move to SD Card" because that option wasn't greyed out. I think that was a sign that there was something wrong.

Later when I tried to install many different apps, it would tell me that my storage was full for each try. So I guess my only solution was to fully reset the phone and reinstall the rom. Using clockwork recovery, I deleted EVERYTHING and installed the rom fresh and new. Now everything works just fine.

I don't know if this applies to you(maxslove), but I hope it helps.