1. Are you ready for the Galaxy S20? Here is everything we know so far!

[MetroPCS & T-Mobile] [TIP] Disable OTA Update notification.

Discussion in 'Android Devices' started by unnamedny, Dec 14, 2013.

  1. unnamedny

    unnamedny Android Expert
    Thread Starter

    Root required obviously.

    Download "disable service" from Play Store
    Open it
    Go to System Apps
    Find Google Services Framework and tap it
    Uncheck "SystemUpdateService"
    Restart your device.
     


    jbserra, jerrspud, dogboy322 and 5 others like this.

    1. Download the Forums for Android™ app!


      Download

       
  2. Just installed this, looks like a very useful app. Permissions aren't too bad either.
     
  3. jjrx3

    jjrx3 Android Enthusiast

    did this and uninstalled the disable service app and it still works...

    not need to keep the app installed just for this purpose .. thanks !!
     
  4. portezbie

    portezbie Android Enthusiast

    Neat app, any other services that one might want to disable?
     
  5. Murf1

    Murf1 Android Enthusiast

    I was hoping to do this same thing in Link2SD by "freezing" it. I can find Google Services Framework, but not "SystemUpdateService". :(
     
  6. That's because Link2SD only shows apps. The Disable Service app breaks out the individual services that are associated with each app and allows them to be disabled separately.
    The update service is one of several services associated with the Services Framework. If you freeze/disable the app itself it will probably break important stuff on the phone.
     
  7. portezbie

    portezbie Android Enthusiast

    Maybe I am reading this incorrectly, but looking at betterbatterystats it seems like disabling this service increases battery life drain.

    Is anyone else experiencing this?
     
  8. That doesn't make much sense, if anything disabling services should help battery life. I can't say I've noticed any such problem since doing this.
     
  9. portezbie

    portezbie Android Enthusiast

    I thought it was odd too, and yet betterbattery stats is telling me that I am getting partial wakelocks from the systemupdateservice even though it is disabled.

    I also saw this thread, which sounds similar:

    Google Services Wakelock - xda-developers
     
    daffyducknj likes this.
  10. dogboy322

    dogboy322 Newbie

    I don't remember how long ago it was, but I know it has been several months, since the annoying update prompts starting hitting my Virgin Mobile LG LS720, and I found this page, installed the "disable service" app, disabled items exactly as per instructions, and it STOPPED. Hasn't happened since... until yesterday. I don't know what is going on, but suddenly as of yesterday, I am getting system update pushes again, as well as a persistent connection error, error 129 I think, not sure. But now today this "system update" is back to nagging the hell outta me.

    How weird. I just went back into the app, followed the inst at top of this page, and for some reason or other "system update service" had been re-enabled! Unchecking, rebooting, we will see.

    ***NOPE. REBOOTED AND DISABLED TWICE, AND FOR ONE REASON OR THE OTHER, THE "SystemUpdateService" KEEPS RE-ENABLING ITSELF! I WONDER WHY??? I think I am going to uninstall / reinstall the disable service app, see if that does anything.

    No, I uninstalled app, rebooted, re-installed app, disabled framework/SystemUpdateService, rebooted, RE-ENABLES ITSELF!
    This is so weird. It has worked fine for so long. No idea why now it doesn't work.
     
  11. DavidIsDead

    DavidIsDead Lurker

    Yeah, that started happening to me too since a few days ago. It's been being disabled just fine all this time, but now it keeps getting re-enabled now every time I restart my phone.
     
  12. dogboy322

    dogboy322 Newbie

    Yeah, weird. Did you get any recurring "connection error" messages around the same time? I noticed that happening, both kind of out of the blue and both around the same time frame, maybe 2 or 3 days ago. But the "Disable" has been working fine since January 20. That's the date my "thank you" is up there on original post. I emailed the developer but no reply as of yet.
     
  13. ratsflif

    ratsflif Newbie

    I just received the update notification too after it has been disabled for months...
     
  14. spocko

    spocko Well-Known Member

    Wierd, same issue here. I've had that service disabled using the instructions in the OP since January. Update notification started appearing today. Ran the Disable Service app and found that SystemUpdateService had been re-enabled. Disabled it, rebooted. Got update notification again after reboot. Ran Disable Service app and found that SystemUpdateService had been re-enabled again.

    The culprit seems to be Google Play Services. Version 4.4 has been rolling out this month. If you look at Google Play Services in the Disable Service app, you will see that it has a SystemUpdateService that wasn't there in version 4.3.

    As a test, I uninstalled Google Play Services v4.4 and rolled back to v4.3. Then I ran Disable Service and disabled SystemUpdateService in Google Services Framework. Rebooted and checked again. SystemUpdateService remained disabled, and I didn't get the update notification.

    With Google Play Services v4.4, I tried disabling SystemUpdateService within Google Play Services, and it did stay disabled, but that didn't stop the service from getting re-enabled in Google Services Framework, nor did it stop the update notification. So I while the info above is a clue, I haven't found a solution. Google automatically pushes out updates to Google Play Services, so rolling back to an older version is only temporary.

    Edit: Please don't email the developer of the Disable Services app, it's not his problem.
     
    lgoptimusv5 likes this.
  15. xploda

    xploda Lurker

    anyone found a resolution for this yet? I'm having the same issue....everytime I reinstall super user and redo all my old apps it freezes and I have to reformat again....rooted using clockwork mod. Was using titanium back up pro and now when i disable the update service in google frame work my phone just freezes and goes full ******.....not happy
     
    SNYPA007 likes this.
  16. daffyducknj

    daffyducknj Android Enthusiast

    If you don't need to use the dialer codes, and can rely on a system tweaker app to do internal tweaks, I personally suggest you update. That's really the most effective way to avoid getting the message to update the system. I am a VM guy, so I'm not sure if you can use the modded V6 update from robaho, or the stock V6. I don't see much difference in the overall operation of my F3 after the update.
     
  17. xploda

    xploda Lurker

    I really like my hot spot though....really don't wana unroot my phone just to get rid of the update prompt.
     
  18. This is working for me with Virgin Mobile.

    Use disable service to disable all:
    Connections Optimizer -> UpdaterService
    Mobile ID -> UpdaterService
    Update Device -> dmc_service

    I also disabled notifications for Google Services Framework.
     
  19. dogboy322

    dogboy322 Newbie


    Sorry, thought it might help... live and learn.
     
  20. lgoptimusv5

    lgoptimusv5 Newbie

    Thanks for that info as GooglePlayServices v4.4 does seem to be the culprit.
    Here's what I've done so far on VM Optimus F3 with Psycho Billy Cyanogen Flavored Rom 4.1.2 using 11extsd2internalsd script

    -Uninstalled GooglePlayServices Updates and rolled back to its default version (2.0.12 in my case).
    -Manually deleted the downloaded OTA update file from /cache/fota. (It was fully downloaded so the file was actually just in /cache)
    -Got rid of system/app/ LGFOTA.apk (I just renamed it to LGFOTA.BAK)
    -Manually installed 'DisableService' as a system app, went to Google Services Framework, unchecked SystemUpdateService
    -Rebooted phone

    So far so good, but Google Play Services has not updated to 4.4 yet, so results pending.

    **UPDATE*** Did not work :( 4.4 re-enabled the SystemUpdateService
    DisableService and SystemTuner no longer work to disable OTA Updates with 4.4

    Since some of the apps require update to GooglePlayServices just to work or sign in, I will try to locate PlayServices 4.3 apk and see if I can retain that for a while
     
    spocko likes this.
  21. kbania2

    kbania2 Lurker

    I've had the exact same issue. I successfully used that "Disable Service" method months ago on my VM Optimus F3, and 3 days ago I started getting the update notification once again.

    I just happened to run the "Lagfix" app that morning for the first time to speed up my phone, so I thought that must have been the cause, but seeing all the other posts here maybe it was just a really big coincidence.

    I don't know why you guys don't accept the update, but in my case, when it first came out and I did accept the update, my phone bricked. It went into an endless reboot cycle, and I had to do some intense googling to figure out how to restore it. Took about 6 hours of work just to get it back to factory default.

    I really don't want to chance going through that again. That was when my phone was unrooted so maybe it would be fine with it rooted as it is now, but I'm not sure.

    My Google Play Services is currently version 4.4.52. I'm not sure what it was a week ago, but I may give that 4.3 version trick a try.
     
  22. lgoptimusv5

    lgoptimusv5 Newbie

    @kbania2 You actually had unmodified, unrooted VM LG F3, and OTA Update bricked your phone?

    OTA update bricked the F3 in my case as well. VM F3, rooted with CWM 6.0.44.
    I was able to unbrick it, and kept the local resources to do so saved and at the ready for next time..

    I just finishing updating GooglePlayServices up to 4.4, as i needed to just to open some apps...
    I'll find out later this evening if killing the LGFOTA.apk helped at all.
     
  23. dogboy322

    dogboy322 Newbie


    Exactly the reason I don't want the update. I read too many bad things about what it does to rooted LS-720.
     

LG Optimus F3 Forum

The LG Optimus F3 release date was June 2013. Features and Specs include a 4.0" inch screen, 5MP camera, 1GB RAM, Snapdragon 400 processor, and 2460mAh battery.

June 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...