1. Are you ready for the Galaxy S20? Here is everything we know so far!

Mic works kinda

Discussion in 'Android Devices' started by jimomma, May 12, 2019.

  1. jimomma

    jimomma Lurker
    Thread Starter

    My mic works when recording video only. It isn't working for phone...speakerphone or not....or Okay Google or even recording. I have wiped and reflashed with various ROMs and still no luck. I haven't tried going back to stock yet.

    Anyone else had this issue before?

    Thanks

     


    gmfreeman1974 likes this.
  2. Best Answer:
    Post #5 by grick, May 13, 2019 (1 points)
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    so your phone is rooted? what are you wiping, if so? do you have a nandroid backup of a rom where it works?
     
  4. svim

    svim Extreme Android User

    Every phone model has its own internal hardware configuration -- different components made by different sources. Each corresponding ROM has to contain specific software to match the hardware (firmware, drivers, apps). It sounds like the ROMs you've tried were custom ROMs that might still require some more tweaking by their developers (i.e. missing or mismatched support for the microphone or other, related audio components). Are there any bug or in-progress reports on the ROMs you used that might reveal anything?
    Installing the appropriate stock ROM should fix things. If that's still a problem that's a strong indicator there's a hardware problem.
     
    Dannydet, ctk beck and ocnbrze like this.
  5. loonycgb2

    loonycgb2 Android Enthusiast

    Which roms have you tried as 99% of the roms available have been produced by me or armando, except for the very few others that have been recently available.
     
    ocnbrze likes this.
  6. grick

    grick Newbie

    Get a new charge board and make sure the coaxial cable is touching the clip that holds it to the board on the bare spot of the cord. That happen to me and I got partial sound by wiping the cash and reinstalling factory os yet it quit again and I would have to restart phone. It wouldn't even have sound or mic using headphones. I got a new board and that did it. Also I found reading other forums that the non-holis file for the modem will fix it. The only software I know of that will properly fix it is UNI. ITS $50 a year.
     
    ocnbrze likes this.
  7. loonycgb2

    loonycgb2 Android Enthusiast

    I have the modem file uploaded and can be flashed via EDL Tool
     
    ocnbrze likes this.
  8. jimomma

    jimomma Lurker
    Thread Starter

    I was flashing ROMS that had worked in the past like Discord 1.1 and Lineage 14.1 doing full wipes.
    I had done a full backup of stock in TWRP. I had heard these backups don't work if you didn't clear the cache first before creation. That's kind of true. My backup wouldn't restore so I deleted 3 cache files in my backup folder and tried to restore and it worked.
    After getting back to stock I tested my mic and it is working normally again.
    I am back on Discord 1.1 and rooted and its all back to normal.
    Thanks for the input everyone!
     
  9. loonycgb2

    loonycgb2 Android Enthusiast

    The newer twrp i have released should not have any restore issues or multiple backup problems as encryption works on it.

    It may have worked again going back to stock as you might have lost some vendor files or a boot/non-hlos might have corrupted.

    The previous issue with the backups was encrypted files like fingerprint or lock files would not decrypt during restore.
     
  10. jimomma

    jimomma Lurker
    Thread Starter

    Turns out that the Discord rom was using one of the other two microphones so it seemed like it was working but in fact when I tried to call somebody on the phone it didn't work. The charging board ended up being the solution. Thanks!
     

ZTE Zmax Pro Forum

The ZTE Zmax Pro release date was July 2016. Features and Specs include a 6.0" inch screen, 13MP camera, 2GB RAM, Snapdragon 617 processor, and 3400mAh battery.

July 2016
Release Date
0
Reviews
Loading...

Share This Page

Loading...