1. Check out our companion app, Forums for Android! Download from Google Play

Root MicroMax A56 Full ROM Dump

Discussion in 'Android Devices' started by BHARDIK, Aug 19, 2012.

  1. BHARDIK

    BHARDIK Active Member
    Thread Starter
    36

    May 20, 2012
    37
    7
    36
    Male
    Computer Enginer IT (Hardware/Networking)
    India-Gujarat-Jamnagar

    Advertisement

    rahi1994 likes this.
  2. anshubham

    anshubham Active Member
    23

    Mar 25, 2012
    44
    45
    23
    first go to xda-developers and thak imetal1 because he's the one who got this. U copied his links. DONT FORGET TO THANK HIM
     
  3. anshubham

    anshubham Active Member
    23

    Mar 25, 2012
    44
    45
    23
    We are continously trying to create a CWM for this device at xda. Having patience is the only option we have.
     
    rahi1994 likes this.
  4. BHARDIK

    BHARDIK Active Member
    Thread Starter
    36

    May 20, 2012
    37
    7
    36
    Male
    Computer Enginer IT (Hardware/Networking)
    India-Gujarat-Jamnagar
    FIRST WE NEED ALL THIS FILE

    MY FIRST POST IN THIS THREAD + THIS ONE

    SYSTEM.IMG


    1 now turn off your set and remove battery

    2 insert battery and pres and hold volume down button and then power on switch

    3 now hold only vlume down button and remove power switch now you show superfone ininja logo and hang ...dont be panic your set is on download mode

    4 now open command promt ( Press and hold windows key on keyboard + R then Hit Enter button)

    5 now check this command carefully ( cd.. = back from open directory )

    here is step by step commands
    if you not find this directory you have to Download Android SDK Tools search in google and find him
    then try agian

    here is screen shot

    [​IMG]


    [​IMG]


    [​IMG]


    [​IMG]

    now copy downloaded file on

    C://Program Files/Android/anndroid-sdk/platform-tools

    which file need to be copy

    boot.img = 10 mb size

    recovery.img = 10 mb size

    system.img = 200 mb size

    then type this command on command prompt

    fastboot flash boot boot.img = for flashing boot for your set is ot start perfect means hang on power on or hang on logo

    fastboot flash recovery recovery.img = for flashing recovery if your recovery is damaged

    fastboot flash system system.img = for flashing system for restored default like purchased new

    type command as you want

    here is screen shot

    [​IMG]

    after that your set is restarted and you done your job,

    press THANKS button if you like my post
     
    rahi1994 likes this.
  5. errhunter

    errhunter New Member
    6

    Aug 26, 2012
    1
    2
    6
    Need HELP
    I have Micromax A56 Ninja2.
    I am badly stuck, my phone is almost dead(just recovery working).
    The scene is,
    Today morning i rooted my phone using Unlock Root, it was success, in first try.
    Then i was planning for installing new ROM for that, so for that i installed Rom Manager, n then CW Recovery.
    After Installation of that, my Recovery(Vol - + Power on) was not working, it was getting stucked at Micromax image.

    to get my Recovery back, i came to this page, I made Flash recovery(fastboot.exe flash recoveryrecovery.img).
    It was succeed, n i had all working, Then I done big Mistake...
    I deleted MLauncher, to Maximize Internal Space, and while uninstalling Inbuilt scrape, i also uninstalled StatusBar.apk (stock Status bar), then my cell was like hail, i was not able to Plug in USB Mode, nor i was able to receive BT Files, coz all was in notification bar, which i dont had.
    Then i re-installed it from my backup of System apps, but then i thought of that i may had removed many other, without knowing,
    So i booted to recovery, selected, Factory Reset, and...
    AS it re-booted, i got Installation Wizard err, tht it has Closed Unexp'. then i forced Close it, i was able to lock and Unlock, as i unlock, i am at Blank Screen,.
    So i thought, i should do System Flash, so i downloaded above file, and typed
    Code (Text):
    1. fastboot flash system system.img
    and here is result, (Data Transfer Failure( too many links)) MmaxA56ErrSysimgFlash.png
    So now i am stuck at just at That Ninja2 animation,
    Any help will be helpful, and if more info needed, will give.,

    Thnx..
     
    rahi1994 and BHARDIK like this.
  6. BHARDIK

    BHARDIK Active Member
    Thread Starter
    36

    May 20, 2012
    37
    7
    36
    Male
    Computer Enginer IT (Hardware/Networking)
    India-Gujarat-Jamnagar
    ok if you have team viewer then contact me on yahoo !

    hardik_karmur is my chat id


    or try this

    you are stuck in so called "dead zone". Recommended ways to do it---

    1. try using another usb port on your laptop to connect the phone.
    2. try with another USB cable (from your friends NOKIA or SAMSUNG or HTC etc which fits in A56 jack) to connect the phone.
    3. Use a different pc to do it. Or format your entire C: drive and reinstall windows again( i.e make your existing pc new one) make sure you have all drivers and windows CD.
    4. Use a windows XP/vista machine....(or if you are on vista/xp then change to win7)
    5. open fastboot and when it says "waiting for device" then connect your phone. Dont connect it before hand.

    try all of these methods one by one. I guess fifth one you can try immediately.

    many devs believe that this problem is due to faulty fastboot.exe many belive that its because of "usb cable"...well you have to try all these one by one and do inform us what worked for you. As it will help us to definitely identify the prob. I think it is because of speed of the USB port. so trying on your friends pc will help. Also if you are on desktop then try using "rear ports" than "front ones" because rear ports are more fast!!
     
    rahi1994 likes this.
  7. anshubham

    anshubham Active Member
    23

    Mar 25, 2012
    44
    45
    23
    man what are u....u copy others and dont even thank them....u just copied this from imetal1's post at xda...???
    and its no the dead zone...
    he just deleted the important apks. he just need the flash to whole system with the rom dump.
     
    rahi1994 likes this.
  8. rahi1994

    rahi1994 New Member
    5

    Aug 30, 2012
    4
    0
    5
    hello i have also this phone and as same as you , i could't open my recovery mode. BUT WHEN i tried for fastboot flash its shows "waiting for device" in my pc nothing happened what can i do , i had already put in downloading mode ie by vol- and power and when vibrate then i stop holding power button then a "SUPERFONE NINJA" SCREEN STUCK . I'm i correct or not PLEASE HELP ME
     
  9. rahi1994

    rahi1994 New Member
    5

    Aug 30, 2012
    4
    0
    5
    Please upload an image of downloading mode of a56
     
  10. rahi1994

    rahi1994 New Member
    5

    Aug 30, 2012
    4
    0
    5
    Hey did your problem solved , now i have same problem as you ie system.img failed to sending please help me
     
  11. BHARDIK

    BHARDIK Active Member
    Thread Starter
    36

    May 20, 2012
    37
    7
    36
    Male
    Computer Enginer IT (Hardware/Networking)
    India-Gujarat-Jamnagar
    dear just remove usb cable from pc also phone, then change your USB port and just plug in to direct on motherboard ports ,

    then only do this =
    put your set in download mode
    first plug in USB to pc then,
    plug usb cable on your set

    now type this on command prompt
    fastboot flash system system.img

    if not success

    try again and again , but if you fail then try by first step do again
    like remove usb from pc and set also
    then plug in again


    or try to flash recovery and boot image first then try to flash system.img your succeeded. i tested it many time on my own set , and that benefit is now your set has more free memory in phone memory , that means you install more application on your set.
     
  12. rahi1994

    rahi1994 New Member
    5

    Aug 30, 2012
    4
    0
    5
    did you tried installing system.img because boot.img and recovery.img are easily flashed but in flashing system showed error in sending
     
  13. EarlyMon

    EarlyMon The PearlyMon
    5,218

    Jun 10, 2010
    57,631
    70,396
    5,218
    New Mexico, USA
    BHARDIK likes this.
  14. RAHI18

    RAHI18 Member
    6

    Aug 12, 2012
    7
    2
    6
    Male
    JABALPUR {MP}
    MICROMAX A56 FLASHING ROM

    HEY GUYS HERE I HAVE " FACTORY UPDATE FOR A56 " , DOWNLOAD BELOW LINKS



    NOW You can repair your phone if you lost your rom data
     
  15. RAHI18

    RAHI18 Member
    6

    Aug 12, 2012
    7
    2
    6
    Male
    JABALPUR {MP}
    jhakash98 likes this.
  16. EarlyMon

    EarlyMon The PearlyMon
    5,218

    Jun 10, 2010
    57,631
    70,396
    5,218
    New Mexico, USA
    Your source for this please?
     
  17. anshubham

    anshubham Active Member
    23

    Mar 25, 2012
    44
    45
    23
    some guy at gsm forum uploaded this. It is genuine i flashed it in my phone. It can be use in case of any mis-happening.
     
  18. EarlyMon

    EarlyMon The PearlyMon
    5,218

    Jun 10, 2010
    57,631
    70,396
    5,218
    New Mexico, USA
    A link would be good. ;) :)
     
  19. suraj84

    suraj84 Member
    16

    Aug 19, 2012
    11
    1
    16
    EarlyMon likes this.
  20. gulluforever

    gulluforever New Member
    5

    Sep 5, 2012
    2
    0
    5
  21. jhakash98

    jhakash98 New Member
    5

    Sep 12, 2012
    2
    0
    5
    What happening guys
    Have the same problem like rahi1994

    i had already put in downloading mode ie by vol+ and power and when vibrate then i stop holding power button then a "SUPERFONE NINJA" SCREEN STUCK .

    Hey buddy RAHI18, can you plese give a complete guide to flash with the files with PC connected to phone.

    Any help will be appreciated.
     
  22. BHARDIK

    BHARDIK Active Member
    Thread Starter
    36

    May 20, 2012
    37
    7
    36
    Male
    Computer Enginer IT (Hardware/Networking)
    India-Gujarat-Jamnagar

    yes i can do that for you but first download this file
    LQAEB19_2012-06-11_factory_update then extract it on Desktop then give me teamviwer ID and PW i am sure i can restore it.
     
  23. anshubham

    anshubham Active Member
    23

    Mar 25, 2012
    44
    45
    23
    jyothis1990 likes this.
  24. RAHI18

    RAHI18 Member
    6

    Aug 12, 2012
    7
    2
    6
    Male
    JABALPUR {MP}
    hello jhakash98
    download this genuine file :- LQAEB19_2012-06-11_factory_update.zip
    now 100% tested A56 ROM FACTORY UPDATE
     
Tags:

Share This Page

Loading...