1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support MicroSD not reading... :(

Discussion in 'Android Devices' started by wgoas, Feb 14, 2011.

  1. wgoas

    wgoas Lurker
    Thread Starter

    Hey guys, I have a bit of a predicament here.

    I dropped my Evo 4G today on my way out to work :eek: and the battery cover fell off, but not the actual battery. Anyways, when I went to play my music from the phone in my car, it said that there was no memory card in the phone. Odd, because there was the 8GB one that came with the phone in there...

    So I turned off the phone, turned it back on with and without the memory card inside. Nothing happens. I tried going into Settings > SD and phone storage and it gives me the option to Format the card or Mount the SD card. When I click Mount SD card, it says in the notification bar, "SD Card Safe to Remove". :thinking:

    I brought it back home and plugged the phone into my PC. It's not giving me an option to mount the phone as a disk drive. I tried using a MicroSD adapter to plug into the port on my laptop (Dell Studio 17 running Vista Ultimate), but it wont recognize that anything is in the drive.

    Am I F'ed here? ALL my music and pictures were on that SD card and I haven't backed it up in a while.... :(

    ~wgoas
     

    Advertisement

  2. Sounds like it. If the card doesnt work directly into a pc with a card reader, its likely broken.
     
Loading...
Tags:

Share This Page

Loading...