1. Are you ready for the Galaxy S20? Here is everything we know so far!

microsd problem - SGS2 won't recognize it. Help!

Discussion in 'Android Devices' started by arkim, Dec 24, 2011.

  1. arkim

    arkim Newbie
    Thread Starter

    It's an 8gb Class 6 Transcend microsd card. I've used it with my Nokia E71 up until yesterday which is when I purchased the SGS2.

    I inserted it in and out of the SGS2 several times, rebooted, but the SGS2 won't recognize the card.

    The card works with the Nokia E71 without any issues.

    Is there a way to force format the card to the file system that the SGS2 uses or something?

    Any help/suggestions are appreciated.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Slug

    Slug Check six!
    VIP Member

    With the card inserted in the GS2, look in Settings/Storage. Do you have the option to "Format SD card"?
     
  3. arkim

    arkim Newbie
    Thread Starter

    No I do not. It doesn't recognize it at all there.

    I can format the card by inserting into the Nokia e71, and plugging that phone into my PC. Then from My computer, I can right click on the card and select "format". I know for sure NTFS is not the right format but I'm not sure between FAT32 and exFat?
     
  4. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    fat32
     
    Slug likes this.
  5. arkim

    arkim Newbie
    Thread Starter

    I just formatted it through the method mentioned above as FAT32 and inserted the microsd card into the SGS2 and rebooted, however it still doesn't allow me to mount/format the card in Storage settings. :(

    Not sure what else to do.
     
  6. rangerevo8

    rangerevo8 Lurker

    You shouldn't need to format it before putting in as you can do that with your phone.
    Try go to Menu > Setting > Storage.
    Under SD card, is Total and Available space show Unavailable?

    1. Format the SD card.
    It will be grey out if it was mounted. (Unmount it first in order to format)

    2. Mount the SD card.
    It is either grey out (mean your SD card is not detected)
    or it shows 'Unmount SD Card' (if its already Mounted)

    After mounted, you should see you Total space listed xx.xx GB and your SD card ready to use.
     
  7. Russell Ng

    Russell Ng Android Expert

    He already formatted it into Fat32 using the PC, or Nokia E71. Anyway, just slot the microSD card into the phone. You shouldn't need to mount or unmount. You should be able to see it. Have a look at the Task Manager and look at storage. If it reads the microSD, that should appear there as SDcard.

    After that, if you use My Files, the microSD is named as folder external_sd.

    Maybe you are just looking at the wrong place.

    Cheers
     
  8. arkim

    arkim Newbie
    Thread Starter

    I'm going to blame it on a faulty card (even though the card worked great in the Nokia E71). I tested another 2GB microSD card and the Unmount/Mount/Format options appear and so does the SD storage feature.

    I exhausted all options and no luck.

    I will have to purchase a new card, unfortunately. At least it'll be an upgrade from 8GB to 16GB.

    Thanks all for the suggestions.
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...