1. Check out our companion app, Forums for Android! Download from Google Play

Support Milestone 2 no longer connects to 3G network, impacts on 3G Mobile Hotspot

Discussion in 'Android Devices' started by ravisandhu, Jun 14, 2011.

  1. ravisandhu

    ravisandhu New Member
    Thread Starter

    Jun 14, 2011
    Hi there, I purchased a Milestone 2 about 3 weeks ago, moving from Nexus One. Using the 3G Hotspot is important to me, and I was pleased to find the Milestone 2 has a 3G hotspot app (Whereas on the Nexus One I needed to go into the settings to tether a 3G hotspot).
    For the first 2 weeks this worked perfectly, I was extremely happy.

    However, the last week I've been having problems.

    My device's status no longer show it as connecting to 3G, instead it constantly is connected to 'H', which am not sure what that is, but I guess it's HSPA?
    Although when I use the device I get a superb speed for things like downloading apps, or podcasts etc... but the 3G hotspot app no longer works. I don't get an error message, it just doesn't start up. I am guessing it's because I am not connected to 3G.

    I thought it was my network provider (Three mobile UK) and I contacted them, they tell me they have no problem with their network and suggested I try a different SIM card.

    My wife now own my Nexus One on Vodafone UK network, and her device is successfully connecting to 3G.

    I placed her SIM into my device and guess what? my device stays on 'H' network.

    So clearly it's something happening on my device, right?

    I tried a factory reset, that hasn't solved it.

    I checked through the settings for connecting to my network (Three mobile), that hasn't changed anything.

    It's a strange thing, because sometimes it does connect to 3G (but not when I need it to), for example, when I am talking on the device (i.e. making a call), and also when first starting up the device it shows as being connected to 3G... however, within seconds it kicks over to 'H'.

    I purchased an app called 'Easy tether', and this has kept me happy for a few days, by connecting using USB cable. I have been getting a good download (and upload) speed on H connection. However, today I am experiencing problems with EasyTether (where my PC is not registering a connection), but that's a separate issue that has motivated me to post into this forum.

    I hope someone can help me get my 3G working again. If not, I will be forced to sell my Milestone 2 (which I other wise love because of the physical keyboard).

    Please put hope back in my life:)

    Thank you in advanced.



  2. Szadzik

    Szadzik Well-Known Member

    Feb 15, 2010
    FAS Admin
    Your problem is really strange my friend.

    H icon means you are getting speeds 10x faster than you get on 3G.

    Basically, restoring 3G instead of H makes you go 10X SLOWER!!!

Share This Page