1. Are you ready for the Galaxy S20? Here is everything we know so far!

Minor Root Hiccup.... any ideas??

Discussion in 'Android Devices' started by jcamp37, Jun 5, 2010.

  1. jcamp37

    jcamp37 Newbie
    Thread Starter

    Okay, I'm rooting my 2.1 hero, I've been at it for about an hour, and when I get to step 9, entering the 2nd code (adb devices) it kicks back this message....

    'adb' is not recognized as an internal or external command, operable program or batch file.


    what do I do now??? I'm lost. I've tried everything I can think of, please help!! 2.1 is miserable, i NEED to root asap.


    thanks in advance
     


  2. ccapasso

    ccapasso Android Expert

    That is Windows way of telling you that you didn't follow directions properly :)...j/k.

    It means that you more than likely didn't extract the files correctly. When you do the following:

    cd C:\android-sdk-windows\tools

    Does your command prompt give you any errors ?

    There is a good chance you just didn't extract the SDK properly. The android-sdk-windows folder should be on your C drive. It should not be inside any other folder.
     
  3. oldjackbob

    oldjackbob Member

    I'm having the same problem.

    I'm thinking there's a problem in the instructions. The instructions say, In Step 1, "Download the Android SDK here", and in Step 2, "Extract the Android SDK zip. Move the contents of the extracted zip to C:\", and in Step 3, "Download HTC Sync 2.0.33 here. Run the installer, and reboot your computer when it is finished."

    That sequence of instructions appears to be telling the user, in relevant part, to run the HTC Sync 2.0.33 installer then reboot. I don't see anywhere where the user is instructed to run the SDK Setup.exe installation file.

    Btw, if the earlier instructions were followed correctly, the SDK Setup.exe file should reside at this location --

    C:\android-sdk-windows\tools\android-sdk-windows\SDK Setup.exe.

    Btw, I even see another \tools folder in that folder.

    So if someone could reply, in this thread, as to whether or not the OP, and others including myself, are following the instructions correctly, or whether we should be doing something differently, we would be very grateful ;)
     
  4. Dolza

    Dolza Lurker

    I encountered this problem as well during my rooting process. When I chose the extract all option on the zip file and then selected the folder as:

    C:\android-sdk-windows\tools\

    I didn't realize how much of a ****** I was until later (lack of sleep is gonna be my excuse)

    Doing that basically added 2 extra folders that were unnecessary. You will likely find that all the adb functions work if you go to this directory instead:

    C:\android-sdk-windows\tools\android-sdk-windows\tools

    At least that's what worked for me. Good luck!
     
  5. mysticmead

    mysticmead Android Expert


    you only need to run the SDKsetup.exe if you pan on developing apps for Android.. just follow the instructions AS written..

    if you have a second set up folders like this C:\android-sdk-windows\tools\android-sdk-windows\tools\ that means you didn't MOVE the extracted folder and instead EXTRACTED the zip file to the root of C: in hopes of skipping a step.
     
  6. jcamp37

    jcamp37 Newbie
    Thread Starter

    when I get to step 9 part 1, where you enter cd C:\android-sdk-windows\tools into the command prompt, I get the response that the step by step guide says I should get. Its when I try to put in the command adb devices that I get that message
     
  7. Dolza

    Dolza Lurker

    1. Open my computer.

    2. Open the C:\ (C drive)

    3. Open the "android-sdk-windows" folder

    4. Open the "tools" folder

    If under tools you do not have an application titled 'adb' then that may likely be why.

    Now, it's possible it's still there you just might have to dig a little further. Looking in the "tools" folder do you see another folder titled "android-sdk-windows"?

    If yes, then open it and go to the tools folder. You will find the 'adb' application there. Reason for this double set of folders is explained in my earlier post.

    If no, then you may need to re-extract or something. Cause I'm at a loss.
     
  8. oldjackbob

    oldjackbob Member

    Guess again...nothing I did was "in hopes of skipping a step".

    What I (and apparently a number of others) did wrong was to mis-interpret the instructions...I erroneously extracted the Android SDK zipfile into the path C:\android-sdk-windows\tools\, which of course created the double-depth path C:\android-sdk-windows\tools\android-sdk-windows\tools\.

    When I realized that, I deleted that entire path and began again, this time extracting the Android SDK zipfile to the root of C:, and then resumed following the directions from Step 5.

    Everything worked fine after that. I'm rooted now.

    Kind thanks to everyone for your help! :)
     

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...