1. Download our Official Android App: Forums for Android!

Support mms problem generic network error on htc Desire

Discussion in 'Android Devices' started by jaffanz, Apr 24, 2010.

  1. jaffanz

    jaffanz Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    8
    Joined:
    Apr 24, 2010

    Apr 24, 2010
    8
    1
    6
    Wellington New Zealand
    Kia Ora

    Just received and have been setting up, htc desire. Wicked phone, can safely say the iPhone has been retired lol.

    Getting the MMS not sending generic network error messages whenever i send a PXT/MMS. Looked around, well to be honest trawled the forums all over WWW, and noted that obviously (am here in Vodafone NZ) the APN settings are abscent.

    Whacked these in and still can't send MMS. Does anybody have any thoughts?

    These are the correct settings according to Vodafone for mms.

    NZ APN2 settings
    APN 2

    Name vodafone NZ-MMS
    apn live.vodafone.com
    proxy -
    port -
    username -
    password -
    server -
    mmsc http://pxt.vodafone.net.nz/pxtsend
    mms proxy 172.30.38.3
    mms port 8080
    mcc 530
    mnc 01
    apn type mms
     

    Advertisement

  2. thorbk

    thorbk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    1
    0
    5
    I have the same problem with "generic network error" in Denmark, sending MMS....
     
  3. jaffanz

    jaffanz Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    8
    Joined:
    Apr 24, 2010

    Apr 24, 2010
    8
    1
    6
    Wellington New Zealand
    turns out, i had to literally put the word 'Default' into the first of the two APN entries, the one for web browsing. So one has apn type Default, the other is apn type mms. if the first one is missing the second won't roll.

    tricky...
     
    dan55 likes this.
  4. bullittfrank

    bullittfrank Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 3, 2010

    Sep 3, 2010
    1
    0
    5
    I have the same problem with my wildfire. I have checked the mms settings orange sent me, they restarted my sim card twice, then gave me a new sim card, I restarted the android....has it helped me any? has it f**k. After each restart it worked for one day and then didn
     
  5. clappo27

    clappo27 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Oct 26, 2010

    Oct 26, 2010
    10
    0
    15
     
  6. tetley44

    tetley44 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 27, 2010

    Oct 27, 2010
    1
    0
    5
    After a few frustrating days of seraching forums and trying various combinations and permutations I have a combination that works on my phone. Usual disclaimer applies (if it causes the phone to explode, nuclear war etc at your own risk.) I have an HTC Desire running Android 2.2. I have tested pxt and mobile broadband which works. Settings as follows:

    Name:
    Vodafone NZ
    APN
    live.vodafone.com
    Proxy
    172.030.038.003
    Port
    8080
    Username
    (blank)
    Password
    (blank)
    Server
    172.030.038.003
    MMSC
    http://pxt.vodafone.net.nz/pxtsend
    MMS Proxy
    172.030.038.003
    MMS Port
    8080
    MMS Protocol
    Wap 2.0
    MCC
    530 (default value)
    MNC
    01 (default value)
    Authentication type
    PAP
    APN type
    (blank)

    This works for VF NZ there are a couple of settings different to what was posted in the first of these threads. I am sending MMS quite easily now. Thanks
     
  7. dan55

    dan55 Android Expert
    Rank:
     #107
    Points:
    263
    Posts:
    2,947
    Joined:
    Oct 23, 2010

    Oct 23, 2010
    2,947
    292
    263
    awesome! many thanks - have been trying to get this to work for ages -and im on o2 in uk - worked a treat :)

    cheers
    dan
     
  8. rstew

    rstew Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 16, 2010

    Sep 16, 2010
    2
    0
    5
    I am now having this problem to, but I cant use any thing that go's on the internet for example facebook, tumblr and even bigpond. I cannot send pics or receive them.
    I have the HTC desire and its with telstra? anybody got any ideas?
     
  9. siamrumi

    siamrumi Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jan 11, 2011

    Jan 11, 2011
    3
    0
    5
    I am using Grameenphone Network in Bangladesh and having the same problem for MMS sending. Plz help me out..
     
  10. binho_nz

    binho_nz Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 7, 2011

    Mar 7, 2011
    1
    0
    5
    Wellington - NZ
    Hi tetley44,

    I tried your MMS settings as well as the one @ vodafone's help website and from another forum too. So far no success... But I started off my research because I wanted the internet service to work and now it does!
    Strangely enough my settings for internet are as follows:

    Name: VF Internet
    APN: internet
    MMS Protocol: WAP 2.0
    MCC: 530
    MNC: 01

    And that's it! All the other fields were left <not set> and oddly enough... it works. By the way I tried the vodafone's details from their help website and it didn't work for me.

    Now I'm stuck with the MMS and WAP services.
    I'm leaning to belive that, maybe in my case, the settings are in my SIM card and the phone only has to be "tricked" into looking for the right info from it. Other than that I don't see a reasonable explanation for the internet settings to work this way and the WAP and MMS not to, in any way I've tried so far.

    Could you post all your APNs and in wich order they appear in your APNs list? If so I will give it a shot by deleting all I have and re-adding one by one with whatever info you supply.

    Cheers mate! =)
     
  11. Xsasinator

    Xsasinator Lurker
    Rank:
    None
    Points:
    5
    Posts:
    8
    Joined:
    Aug 28, 2011

    Aug 28, 2011
    8
    0
    5
    To be able to receive MMS I take it I need the mobile network turned on?

    I have it turned off at the moment as i don't have a data plan and use free wifi everywhere, and the only APN i have set up is for MMS,
     
Tags:

Share This Page

Loading...