1. Are you ready for the Galaxy S20? Here is everything we know so far!

Mms works for our phones on cm 10

Discussion in 'Android Devices' started by wolfu, Jan 1, 2013.

  1. wolfu

    wolfu Well-Known Member
    Thread Starter

    So I was screwing around with [ROM / KERNEL] [Team D.I.R.T] [LINARO OPTIMIZED] [JB 4.1.2] UNOFFICIAL AOKP v3.5.2
    I installed the black APK to recieve mms. then for the hell of it I did their fix for boost HOW TO GET MMS GOING FOR BOOST MOBILE but did it for us

    1. Use the Voice Dailer and say "Open APNs"
    2. Click on "Open APNs"
    3. Click on the default Sprint Access Point tab
    4. Put in the following settings....

    Name: Sprint
    APN: Sprint
    Proxy: Not set
    Port: Not set
    Username: Sprint
    Password: .
    Server: .
    MMSC: http://mmsc.vmobl.com:8088/mms?
    MMS proxy: Not set
    MMS port: Not set
    MMC: 310
    MNC: 120
    Authentication type: PAP or CHAP
    APN type: Not set
    APN protocol: IPv4
    APN roaming protocol: IPv4
    APN enable/disable: APN enabled (darkened out)
    Bearer: Unspecified

    Now I can send and recieve MMS :smokingsomb:

    Here's the link to this great ROM http://forum.xda-developers.com/showthread.php?t=1831841
     


  2. Austrie

    Austrie Android Expert

    Im going to try it, when told g60 about it on Sunday he said it wouldn't work.
     
  3. wolfu

    wolfu Well-Known Member
    Thread Starter

    It works I've sent several MMS to myself But the ONLY thing I changed was the MMSC I left everything else the way it was set. it all says sprint but low and behold it still sends
     
  4. Austrie

    Austrie Android Expert

    Well I did all the listed steps for boost, but used the mmcs for virgin; my picture forever says sending when I try to send it to someone. Let me see what happens if I leave the defaults with virgin mmcs
     
  5. wolfu

    wolfu Well-Known Member
    Thread Starter



    I didn't do any steps for Boost the only thing I changed from the default state was the MMSC address. I left everything else the same as it was in the APN settings
     
  6. Prinny

    Prinny Resident Linux Nutcase

    Wolf, how long does it take you on average to send and recieve MMS now? Is it almost instant, or is it a few minutes to receive it?

    Edit: Also would you mind going to your APNS and taking a screenshot?
     
  7. MtnDew31693

    MtnDew31693 Member

    I'll have to try this on my phone soon and report back. I'm running the gangnam style CM10. MMS receiving working of course but sending still broken right now.
     
  8. wolfu

    wolfu Well-Known Member
    Thread Starter

    Less than a minute to recieve and it even sent over WIFI.
    I'm trying to take a screen shot but can't seem to figure it out on this rom.
    I'll list everything the way it is set...

    Name: Sprint
    APN: Sprint
    Proxy: Not set
    Port: Not set
    Username: Sprint
    Password: .
    Server: .
    MMSC: http://mmsc.vmobl.com:8088/mms?
    MMS proxy: Not set
    MMS port: Not set
    MMC: 310
    MNC: 120
    Authentication type: PAP or CHAP
    APN type: Not set
    APN protocol: IPv4
    APN roaming protocol: IPv4
    APN enable/disable: APN enabled (darkened out)
    Bearer: Unspecified

    I will try to take a screen shot
     
    Branhower likes this.
  9. wolfu

    wolfu Well-Known Member
    Thread Starter

    Just tried it over 3g and it took less than 10 sec
     
  10. davidmargolin

    davidmargolin Android Expert

    u mind if i add this to my mms fix post???
     
  11. Prinny

    Prinny Resident Linux Nutcase

    I'm trying everything you did. I'll post back results momentarily. This would be awesome if it worked.

    So you downloaded the black MMS from the partial fix thread, correct? That's the one I'm using.
     
  12. wolfu

    wolfu Well-Known Member
    Thread Starter

    Not at all :)
     
  13. wolfu

    wolfu Well-Known Member
    Thread Starter

    yes and i put it into the rom after installing it on my phone using root explorer
     
  14. Prinny

    Prinny Resident Linux Nutcase

    Holy picture messaging, batman! It works! Great discovery!
     
  15. wolfu

    wolfu Well-Known Member
    Thread Starter

    I hope someone else can emulate this I rebooted my phone and sent mms again still working great
     
  16. wolfu

    wolfu Well-Known Member
    Thread Starter

    I'm just happy to contribute to this awesome forum :D
     
  17. Prinny

    Prinny Resident Linux Nutcase

    well looks like aokp is now my daily :cool:
     
  18. wolfu

    wolfu Well-Known Member
    Thread Starter

    Mine too
     
  19. davidmargolin

    davidmargolin Android Expert

    so which settings should be used???
    the ones from the op

    or these
     
  20. Prinny

    Prinny Resident Linux Nutcase

    I used the second set. Works great.

    Also for those wondering, Handcent works too with this fix. I couldn't get GoSMS to work, though.
     
  21. Austrie

    Austrie Android Expert

    What's the server and password?
     
  22. Branhower

    Branhower Newbie

    OhmygodOhmygodOhmygodOhmygod it worked! Here is a pic I sent to my old Tracfone. Running HTCDEV10 and the stock-themed fixed MMS from this thread.
     

    Attached Files:

  23. Prinny

    Prinny Resident Linux Nutcase

    Hold on. I'll upload a picture of my exact settings for you folks.

    Edit: Hokay so maybe not...no idea where screenshot is in this ROM...

    Basically your password should say * by default. Leave it as is. The ONLY thing you need to touch is the MMSC. Everything else should stay defaulted to what it is.
     
  24. sikk66

    sikk66 Member

    This is GREAT! Good job guys!
     
  25. ramjet73

    ramjet73 Android Expert

    You need need to enable screenshot on the advanced power menu (APM) in the ROM Control settings and then you can take screenshots using a long press on the power button and selecting screenshot. The images will be stored in /sdcard/pictures/screenshots.

    ramjet73
     
Loading...

Share This Page

Loading...