1. Are you ready for the Galaxy S20? Here is everything we know so far!

Mobile data connection doesn't work after I unlocked my mobile

Discussion in 'Android Devices' started by paularts, Sep 25, 2010.

  1. paularts

    paularts Lurker
    Thread Starter

    Hi, I recently bought a Telstra HTC Wildfire and unlocked it by code to use my 3 SIM card on it. However, after unlocking my mobile, when I choose the option "use phone for data connection when wi-fi is unavailable" it doesn't work.
    When i go to mobile network and network operators, I select to search for networks and the phone is automatically connected to "3Telstra(3G)". They also show 3(3G) and 3 networks, but when I try to select any of them, it says that the SIM card does not allow the connection to this network. I don't know if one thing is connected to the other, but I always used my old phone for data connection with the same SIM card.
    Does anybody knows how do I solve this problem?

    1. Download the Forums for Android™ app!


  2. uzetaab

    uzetaab Android Enthusiast

    I just travelled in Europe with my Desire. In each of the countries I was in, I bought a prepaid sim card rather than paying the outrageous roaming data charges. Sorry, this is relevant because I learned the hard way that I had to manually configure the APN (Access Point Names) settings to get data working.

    to change settings, from the home screen:

    menu>settings>wireless & networks>mobile networks>access point names

    I'm sorry, but that was the easy part, the hard part is finding the proper APN settings to get it working. It's been my experience that the mobile network's tech support usually don't have a clue what your talking about, so they would be the last thing to try.

    google searches are usually not much better because you get lots of random pages with APN codes that have nothing to do with the phone or network your dealing with.

    I had the best luck by going to the support section of the mobile network's site. If your lucky, they have the settings for your specific phone listed, if your unlucky, you have to pick phones at random & try the settings for those until you get the right ones.

    some tips:
    look for same brand phones that are on android, like the HTC Desire, look for android phones of another brand rather than htc phones that use a different OS, like the Samsung Galaxy S instead of the HTC HD2.

    some networks APN codes do not work properly until you change the internet browser's default homepage to the one they want. for example, on vodafone (in Italy) it didn't work properly until I changed the homepage to mobile.vodafone.com (or something like that).

    if the only settings you can find do not work, try changing the apn code that will look something like this:
    other varients:

    good luck!

    btw, I set email notifications for this thread, so post a reply if you can't get it working & I'll see if I can help some more.
    paularts likes this.
  3. paularts

    paularts Lurker
    Thread Starter

    I just went to 3 website and got the right settings and now my mobile network is working! Thanks again for your help!!!!
  4. uzetaab

    uzetaab Android Enthusiast

    your very welcome, I'm glad I could help.
  5. htc_new

    htc_new Lurker

    I recently bought a new HTC wildfire pre-paid locked with telstra.
    I got it unlocked using a code. Now my calls and messages are working fine but mobile internet does not work. At home, even Wi-Fi connection works.
    I went to Vodafone store to ask but they told me if you buy from another vendor and get it unlocked, mobile internet will not work on your mobile.

    seeing this thread, it seems like you guys have the same issue and were able to resolve it.

    I also went to Vodafone website but count not find any APN settings. Nto sure where or what to look for. Please help !!!
  6. JamesT

    JamesT Well-Known Member

  7. uzetaab

    uzetaab Android Enthusiast

    Nope, sorry JamesT, but it probably doesn't. I don't have a vodafone sim (or a HTC Wildfire) to find out, but after finding the right place (I think) on the vf site, it seems that the codes on the ausdroid site aren't going to work. When I was overseas & trying to set up a new sim every week, I found that those independent sites just never had the right info.

    This page should bring up some drop down lists that will reveal the codes to some htc phones.

    Mobile & PDA Setup - Help & Support - Vodafone Australia

    Obviously, the wildfire wont be on there because it's not a vf model, but if you try some of the other HTC models that run android (like the Legend or Magic), hopefully those instructions will be similar enough to work.

    I know that getting this working can be hard, really hard. So if your still stuck htc_new, make another reply to this thread & we'll organise a time to meet for live chat & I'll help you get it working.

    good luck.
  8. julcsi20

    julcsi20 Lurker

  9. nicoleee

    nicoleee Lurker

    I recently got a sidekick 4G and I was really happy. For the first couple of days, it worked fine, I was able to text and call outside of wifi range. But then, out of nowhere, something changed and i wasn't able to text/call anybody and nobody was able to call/text me. I can only use my phone inside of wifi range, the second i walk out of it, the signal shuts down and my phone isn't able to do anything. Can anyone help, please?
  10. GerryF

    GerryF Lurker

    Hello everyone just joined the Forum particularly because I just stumbled upon a solution for what seems to be a same problem as one of the members was explaining on this thread.
    I bought a HTC wildfire S locked to the 3 network in Uk and had it unlocked. Everything was fine except the data gprs did not work. Meaning I could not access mobile internet connection nor get the settings sent to my phone for any other network. When I got home i connected to my wifi connection ( which worked form the word go) and about a week later stumbled upon an app. I decided to give it a try and it worked for me. Its called Tweakker. Its a free download from the andriod market. Install it and it should automatically install the GPRS settings for whatever network you have your sim with. I hope this fixes problems for you guys out there. The guy who unlocked my phone couldnt figure it out, why once unlocked it still would not take mobile internet connection from other networks, I guess it is HTC's way, you might have to manually input GPRS settings for all networks. Thanks to this little app it does the work for you. Good luck guys!
    dermotoski, JunWenTeh and jcinksh like this.
  11. GerryF

    GerryF Lurker

    PS: It might also work with other HTC models too as I found this app relevant to another HTC phone the Droid incredible 2 :)
  12. jcinksh

    jcinksh Lurker

    I have a HTC MyTouch 4G from the States using in Aust. As Gerry mentioned the Tweakker works great. I'm with Amaysim, just selected the provider & = all good.
  13. JunWenTeh

    JunWenTeh Lurker

    I had the same problem with HTC Wildfire, previously a UK O2 customer, transferring to Malaysian Maxis provider, with no data connection. Tweakker saved my day and I am enjoying my internet surfing now.
  14. utabusdriver

    utabusdriver Lurker

    Tweakker worked GREAT! I was on the phone with Consumer Cellular for almost an hour and couldn't get data service. After reading this post and downloading the app, I was getting data within just a few minutes. Thanks!
  15. Tocapet

    Tocapet Lurker

    Yes, it tells you what settings to use. But my phone won't let me change them. Everything is greyed out. :mad:

HTC Wildfire Forum

The HTC Wildfire release date was May 2010. Features and Specs include a 3.2" inch screen, 5MP camera, 384GB RAM, Snapdragon S1 processor, and 1300mAh battery.

May 2010
Release Date

Share This Page