1. Download our Official Android App: Forums for Android!

Support mobile data not working after switch?

Discussion in 'Android Devices' started by ch1k3n123, Dec 17, 2012.

  1. ch1k3n123

    ch1k3n123 Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    40
    Joined:
    May 12, 2012

    May 12, 2012
    40
    3
    16
    Hello!

    So I got myself a used HTC vivid and stuck my sim card that I had been using in my old LG thrive in the phone.

    All works as it should except for mobile data. I will turn mobile data on and it won't connect. J already have a data plan on the sim card.

    Does anyone know why this may be? Is it a problem with the phone or at&t? Do I need to contact them? Or can I fix it myself? (Preferred)

    Thanks! If you need any other info I would be glad to give it to you so long as its safe for me to do so.
     

    Advertisement

  2. olbriar

    olbriar  
    Moderator
    Rank:
     #11
    Points:
    1,973
    Posts:
    17,298
    Joined:
    Jun 19, 2010

    Jun 19, 2010
    17,298
    12,263
    1,973
    Male
    Land of Oz
    Your problem may be in the sim from your prepaid Thrive and your post pay Vivid. I'm not certain but I suspect the sim cards are different and thus your problem.
     
  3. djcmx49

    djcmx49 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Jan 24, 2013

    Jan 24, 2013
    6
    0
    5
    Male
    Canada
    Not sure if you still have this issue but I had same issue when I switched phones. I had to call my provider, Virgin Mobile, and they gave me APN settings which I had to enter into Vivid phone to set up mobile data access point network. Hope this helps...
     
Tags:

Share This Page

Loading...