1. Download our Official Android App: Forums for Android!

Support Mobile Internet/Wifi Settings issue

Discussion in 'Android Devices' started by EvilEdna, Feb 16, 2011.

  1. EvilEdna

    EvilEdna Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    5
    0
    5
    Hi all, I have been using my DHD to connect to my neighbours broadband.....with their permission.

    I do my downloading overnight and have set up my torrent scheduler to dl after everyone is in bed nextdoor.

    I switched off the mobile connection to the internet so if there was any signal dropout or any problems that i would not burn up my 2GB of allownace form three.

    I woke this morning to find that despite switching off the mobile connection that my DHD had been using the mobile data anyway and I have, ovrnight, burned 75% of my monthly allowance and the sickener is that Monday was the first day of my billing period.

    I tried using WiFi in 'Flight' mode and it did work but i don't have enough data to do another ovrnight experiment and don't know how the DHD thinks when it switches on the Mobile data rather than the WiFi despite being told not to.

    In simple terms, I want to use WiFi exclusively without mobile data switching itself on. I have not managed to do that.

    Any ideas or suggestions?

    have a good day
    Al
     

    Advertisement

  2. El Kroket

    El Kroket Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    107
    Joined:
    Jan 14, 2011

    Jan 14, 2011
    107
    13
    38
    Australia
    How did you switch off your mobile connection?? Did you use a widget? Some widgets don't work well with HTCsense... For example it might turn on your mobile connection after you have turned off your WIFI (or when it accidentally disconnected).

    go to menu=>settings=>wireless...=>and make sure you uncheck mobile network when you don't want to use it.

    cheers
     
  3. Mitchturbo

    Mitchturbo Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    162
    Joined:
    Jan 21, 2011

    Jan 21, 2011
    162
    11
    58
    Male
    Night Porter
    Lincolnshire UK
    Hi There! Easily done but i will teach you how I first discovered how to do it myself (and I found it easy):

    Go to your apps and choose setup which has a picture of a magic hat,
    You go into all the questions/options you were asked when you first use the phone.
    Skip the majority until a page comes up asking whether you would like to have WiFi only or using both WiFi and your mobile internet (2g,3g) select WiFi only. Then skip the rest of the pages and your done.

    Or you can go into settings, click on Wireless and Networks, keep WiFi ticked and un-tick Mobile Network.

    Both Easy to do :)
     
  4. Mitchturbo

    Mitchturbo Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    162
    Joined:
    Jan 21, 2011

    Jan 21, 2011
    162
    11
    58
    Male
    Night Porter
    Lincolnshire UK
    Doh! Well done El Kroket, You answered his question while I was writing my essay of a reply lol
    ;) :) Good man.
     
  5. El Kroket

    El Kroket Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    107
    Joined:
    Jan 14, 2011

    Jan 14, 2011
    107
    13
    38
    Australia
    Sorry man :)
     
  6. EvilEdna

    EvilEdna Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    5
    0
    5
    ...oh and thanks for the essay.

    I did go into settings, wireless, mobile data and unchecked the box!
    that's why i'm confussed!
    i also went through the wizards hat setup and the settingss were as confiemed. all that did was uncheck the above tick box.

    ..anything further?
     
  7. El Kroket

    El Kroket Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    107
    Joined:
    Jan 14, 2011

    Jan 14, 2011
    107
    13
    38
    Australia
    Sounds really weird if you unchecked that box it shouldn't connect... you could always install APNdroid or something similar. This widget will override your mobile connection settings.

    Cheers
     
  8. EvilEdna

    EvilEdna Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    5
    0
    5
    Cheers boys, i'll try it all.

    Simply put it appeared to dual connect! both icons appeared in the status bar at the top of the screen...

    I have changer the settings but will wait and see.

    If anyone has any additional solutions don't hesitate.

    otherwise
    have a good day
     
  9. EvilEdna

    EvilEdna Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    5
    0
    5
    OK, tried it all.

    i set it up yesterday evening and found that after aq half hour it was connected to 3G after all of the support i got from yo all the problem is still there. it simply switched itself on.

    however, when i switched off WiFi but left the mobile internet connection off the 3G stopped working.
    I know that it was connected the previous night cos my data was munched.....

    anyone else got any ideas?
     
  10. dijon

    dijon Member
    Rank:
    None
    Points:
    18
    Posts:
    65
    Joined:
    Nov 18, 2010

    Nov 18, 2010
    65
    17
    18
    Technical Manager
    UK
    you sure that an application isn't turning the mobile data on by itself? Some can and will do this without user interaction.
     
  11. EvilEdna

    EvilEdna Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    5
    0
    5

    Hey, nice idea. i can't think of any that would. i left it running last night downloading a torrent on the phone itself and it did not switch on to 3G or burn up data allownace overnight.

    my feeling is that this is specific to using the WiFi......but i just don't know enough to solve the problem
     

Share This Page

Loading...