1. Are you ready for the Galaxy S20? Here is everything we know so far!

Mobile Network Not Connecting

Discussion in 'Android Devices' started by J.R., Dec 1, 2009.

  1. J.R.

    J.R. Member
    Thread Starter

    I had installed the "quick settings" app that was mentioned in another thread. When I tried to open it this morning to turn on the mobile network (I usually keep it off at home), a message popped up saying the application was not updated properly and it needed to be removed and reinstalled. I tried to go to settings>wireless controls to turn on the mobile network but that isn't working either. When I look at the button to turn on the mobile network in the settings, it says "standby to connect to mobile network", I click it, it goes away and says "connect to internet" but when I click it again it just tries and then stops after a minute or so. I removed the quick settings app and restarted the phone, but that didn't help.

    This happened once before and I just connected to WiFi and reinstalled the quick settings app, but now I'm somewhere where I don't have WiFi access. If it matters, I also have a shortcut button installed to turn the mobile network on and off, but that isn't doing anything either. Any suggestions?

    1. Download the Forums for Android™ app!


  2. Caddyman

    Caddyman Android Expert

    have you tried turing the phone off and then back on? if yes, have you tried pulling the battery for a few seconds? (idk, i came from BB, battery pull is all i know)
  3. J.R.

    J.R. Member
    Thread Starter

    Just tried pulling the battery, didn't help. But thanks anyway!
  4. Podivin

    Podivin Android Expert

    I had the same problem with Quick Settings on Sunday. Apparently there was an update for it that managed to break something (I THINK it didn't install correctly). I tried everything you've tried so far, to no avail. I uninstalled the app, turned things on/off. Eventually I took it to Verizon to see what they could do. The only thing they could figure out was a factory reset (sigh). Before you go that route try uninstalling the app and then removing the battery. (BB guy is right :) That's the only real way to reset the phone, per the Verizon folks). Maybe that'll bring it back to life for you, and I'm not SURE that I did those exact steps in that order.
    Be sure and back up your contacts before you have do the reset, or you'll loose them. I hadn't backed mine up, but I asked the guy at Verizon to temporarily put them in one of their new phones, and he did. I wouldn't expect all stores to be that accomodating.
    I don't think I'll be installing Quick Settings again. Instead I now have the appropriate widgets (Bluetooth, GPS, WiFi, Mobile network) on my home page. I'll toggle them that way from now on.
    Just thought of this, if uninstalling Quick Settings and a reset doesn't fix the problem. Try a new download and install of Quick Settings. IF the problem was a bad update, as opposed to a defective program, then MAYBE reinstalling the program will fix the problem that the previous update broke. I know it's a stretch, but at some point you've got nothing to lose...
    Keep us posted to let us know if you find a fix other than a factory reset, I'm going to guess that others are having this same problem.
  5. alexislost

    alexislost Newbie

    I actually just joined this forum to ask a very similar question. however, i do not have quick setting installed on my Eris, and i'm having the same issue of connecting to 3g. i've tried resetting my phone and restarting it with 3g on or off. i can no longer turn it on or off, respective to which mode it is in.
  6. Podivin

    Podivin Android Expert

    Have you installed any apps that give you the ability to turn on/off the 3g network? If so, I'd first look to that app as a potential problem, and uninstall it then reset the phone (remove the battery).
  7. alexislost

    alexislost Newbie

    i haven't installed any switches to turn the 3g on or off, if that's what you mean. i do have apps that ask me to turn on the 3g if it's off. that's about it, though. i'm about to make my way to verizon to see if they know anything.
  8. J.R.

    J.R. Member
    Thread Starter

    I have uninstalled it and restarted the phone and removed the battery. The only other time I couldn't get the on/off widget to turn on the 3G was when I had no bars for reception. I'm hoping I don't have to reset the entire phone!

    This same thing happened a few days ago, I hooked into a wifi network and reinstalled the quick settings app and it solved the problem...but apparently only temporarily.
  9. Caddyman

    Caddyman Android Expert

    if it si your 3g connection just being flaky i believe this is a known issue that should be resolved in the dec 11 update.
  10. J.R.

    J.R. Member
    Thread Starter

    Nope, not just being flakey, it's not connecting at all.
  11. alexislost

    alexislost Newbie

    JR, i just went to verizon to get the issue checked out. they informed me that this issue should be resolved with the new update that's coming out this week or next week, but there is a fix for the time being.

    hit the Up arrow right above the green call button to bring up All programs. go to settings, wireless controls, and click Mobile Network to turn 3g on or off. i know it's a bit of an inconvenience, but it works no matter what, even if your widget or the power button does not work.

    i can deal with it assuming the update coming soon fixes all the issues.
  12. J.R.

    J.R. Member
    Thread Starter

    Thanks for the help, but I've been trying to turn it on in the "settings" menu and that's not working either. When I click "mobile networks" it just continues to say "turning on" for a long time but eventually the phone goes back to sleep and when I wake it, the mobile network button says "standby for connecting to mobile network" under it.
  13. J.R.

    J.R. Member
    Thread Starter

    I called 611 and they seemed to have no idea what to do besides what I already tried (pulling the battery, etc.). Guess I'm just gonna have to try a full reset if no one else has any suggestions. Which brings me to my next question, how does one do a full reset? Thanks again for all the help!
  14. Podivin

    Podivin Android Expert

    The factory reset is under settings/security.
  15. J.R.

    J.R. Member
    Thread Starter

    I hooked up to a wifi connection, reinstalled the quick settings app (again), and everything seems to be working normally again.
  16. Podivin

    Podivin Android Expert

    JR, you didn't have to do the factory reset bit?
  17. J.R.

    J.R. Member
    Thread Starter

    No, not yet. Working fine for now. I'm afraid to shut it down again, that seems to be what caused the glitch the last two times.
  18. Magnus_CA

    Magnus_CA Member

    I fixed it. I turned on wifi to reinstall Quick Settings. I turned wifi off to make sure Mobile Network was working again (it did). Then, I ended the application with a force stop (I did it with Advanced Task Manager) and uninstalled it. I can turn on my Mobile Network again without the Quick Settings App. (Whew)
  19. J.R.

    J.R. Member
    Thread Starter

    Yup, I did pretty much the same thing. Got rid of Quick Settings, and won't put it back!
  20. Zinja

    Zinja Member

    I've never installed Quick Settings. I just have WiFi Toggle, which works flawlessly.

    My Ev and 1x connections keep disappearing. I also see the "Standby for connecting to mobile network" in my network settings.

    Doing a soft reset (turning phone off and on again) ALWAYS restores the connection FOR A WHILE. Seems like Sprint terminates the connection to save cost.

    How can I keep the data connection ALIVE without having to turn my phone off and on again all day?

    Are you telling me that 3 weeks into owning this phone I need to do a hard reset?
  21. odaxium

    odaxium Member

    FWIW, I had the same problem on Saturday. And then it started working again later in the evening.
  22. LisaAnn

    LisaAnn Lurker

    I accidentally turned my mobile network off and now it wont reconnect.

    I turned my phone off and then back on and it didnt work.

    I connected to the Wi-Fi in my building and downloaded Quick Settings and it says Mobile Data is on so I turned my Wi-Fi off and now its not working again.

    Can anyone help?

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date

Share This Page