Mobile Network not working with Bell Canada

Hi There.

I recently got given a unlocked HTC Desire (from Telstra in Australia) and have just signed up on a data plan with Bell, Canada. The issue is that the mobile network won't connect. I can get internet through wi-fi but not mobile network. I've tried removing the battery and sim cards, rebooting and also done a factory restore.

The APN settings (that i got from another thread on this site) are:

Name: Bell Internet
Port: 80
MMS Proxy:
MMS Port: 80
MMS Protocol: WAP 2.0
MCC: 302
MNC: 610
Authentication Type: None
APN Type: Internet + MMS

My Network Mode is set to GSM/WCDMA auto.

when i go into "About Phone", "Network" it says:

Operator Name: Bell
Signal Strength: 101 dBm 6 asu
Mobile Network Type: HSDPA
Service State: In Service
Roaming: Not Roaming.

Please Help!!! I don't know what to do! my partner signed on for the same plan with his Samsung Entro, and he has no issue with mobile networks...


I don't know how much this matters, but the Telstra Desire (A8183 model number?) is missing the 1900MHz band, which is one of the two that Bell uses to deliver HSDPA service. It still does 850MHz, but I don't know much about Bell's infrastructure, and whether or not 850MHz is prevalent on their network.

The only model I know works for sure in Canada (because I'm using it) is the Telus A8182, which runs 850/1900 and works on Rogers and Bell, too.


The model number is on the box, if you have it. Otherwise, it's under the battery.

A8181 = 900/2100MHz
A8182 = 850/1900MHz
A8183 = 850/2100MHz

All of them are able to do quad-band (850/900/1800/1900) GSM, which means the phone would at least do EDGE on Rogers/Fido; but as far as I know, Bell doesn't have EDGE service -- just HSPA at 850/1900. Someone please correct me if I'm wrong on any of the above.

Do you know anyone with a Rogers SIM who could try it in your phone? If it still doesn't get any data at all (after adding the Rogers APN settings), it might be the phone. Otherwise, it's possible it's the network.