1. Download our Official Android App: Forums for Android!

General Mobile Network sleeping?

Discussion in 'Android Devices' started by Janney66, May 5, 2010.

  1. Janney66

    Janney66 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    4
    0
    5
    So I'm just curious if anyone else is seeing this. I understand wi-fi sleeps after 15 minutes of inactivity, but I guess I assumed mobile networking would always stay on. What I'm seeing is, if I leave my phone alone for a little while, as soon as I wake it up, the 3G symbol is not displayed. A second or two later it will show up, and then it will sync. This behavior makes it so that my Gmail push is not as instantaneous as it would be if the 3G always stayed active. I believe (although I'm not positive), that the phone must wake 3G every once in awhile to get e-mails though, although it might just wake up when i get a text or phone call.

    I don't see this as a major problem, especially if it's helping me save battery life, but I am curious if this is due to a setting, or if it's just the way the phone works.
     

    Advertisement

  2. howarmat

    howarmat Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,580
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    1,580
    229
    163
    Generation Dispatcher
    Noblesville, IN
    you need to make sure

    settings>wireless & networks>Mobile Networks>Enable Always On Mobile Data is check off

    you MIGHT have more battery drain with this though
     
    Patkid and Janney66 like this.
  3. Janney66

    Janney66 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    4
    0
    5
    Thanks....I'll have to check it out. I turned that setting off to save power but I thought it wouldn't affect the gmail push at all. I'll turn it back on and see if the 3G symbol stays on after the phone sleeps.
     
  4. jbdan

    jbdan Android Expert
    Rank:
    None
    Points:
    513
    Posts:
    7,121
    Joined:
    Jan 31, 2010

    Jan 31, 2010
    7,121
    3,187
    513
    atl ga usa
    Go to wifi settings and hit menu....there is an advanced menu in there and you can set the sleep policy to never if you would like.
     
  5. jbdan

    jbdan Android Expert
    Rank:
    None
    Points:
    513
    Posts:
    7,121
    Joined:
    Jan 31, 2010

    Jan 31, 2010
    7,121
    3,187
    513
    atl ga usa

    Isn't that just for 3G mobile data?

    EDIT: my bad I see OP's question is referring to mobile sleep....doh :)
     
  6. Janney66

    Janney66 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    4
    0
    5
    Jbdan, I saw that setting for WiFi but I assumed the 3G would not be affected by the WiFi setting.
     
  7. jbdan

    jbdan Android Expert
    Rank:
    None
    Points:
    513
    Posts:
    7,121
    Joined:
    Jan 31, 2010

    Jan 31, 2010
    7,121
    3,187
    513
    atl ga usa
    You are correct I misunderstood the orig question sorry :D
     
  8. Janney66

    Janney66 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    4
    0
    5
    Yup, so the 3G stays on when I enable the Always On Mobile Data. I get e-mails quicker too. So far it doesn't seem to be draining my battery any faster, but we'll see. Thanks for your help.
     
  9. howarmat

    howarmat Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,580
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    1,580
    229
    163
    Generation Dispatcher
    Noblesville, IN
    no problem glad its working for you :)
     

Share This Page

Loading...