1. Check out our companion app, Forums for Android! Download from Google Play

Support Mobile View-Browser question

Discussion in 'Android Devices' started by metsr1, Sep 20, 2010.

  1. metsr1

    metsr1 Member
    Thread Starter
    15

    Nov 20, 2009
    11
    0
    15
    Hello All. Does anyone know how to avoid getting mobile views (page) on web sites in the browser? I can't figure it out. My old HTC Hero had a way to not get the mobile versions. many Thanks.
     

    Advertisement

  2. Bomix

    Bomix Well-Known Member
    58

    Nov 19, 2009
    109
    14
    58
    This worked for me..

    xda-developers - View Single Post - [Q] Turn off Mobile Browsing, and download .rar files

    Type the following on the browser:
    "about:debug"
    Then hit enter/GO
    Hit Menu on your soft key,
    Nav to Settings, scroll way to the bottom select Desktop instead of android.

    Credits to Los1223 in XDA fourms.

    Bad news is I have to set this every time I reboot the phone.. So I now use Xscope browser.. way better.
     
    metsr1 likes this.
  3. metsr1

    metsr1 Member
    Thread Starter
    15

    Nov 20, 2009
    11
    0
    15
    Thank you. That worked great. You are my idol. LOL
     
  4. Bomix

    Bomix Well-Known Member
    58

    Nov 19, 2009
    109
    14
    58
    it's a shame they didn't include this in the stock browser.. sucks!
     
  5. Adlebo

    Adlebo Well-Known Member
    16

    Sep 5, 2010
    48
    5
    16
    I would appreciate if you can help me. I'm also trying to avoid the page opening in mobile format. I tried the about:debug thing, but I don't see in settings the desktop instead of android option. I do see other "debug" options, which I don't have a clue what they mean but not the one that was mentioned. The only thing I see on top of the browser it says " Show Java Script console".
    Also, if someone can explain, why is xscope better for for forcing desktop browsing?
     
  6. blueatlanta

    blueatlanta Member
    35

    Aug 24, 2010
    24
    0
    35
    and you know whats a shame? my old omnia with winmo 6.5 with opera mini had this option built in to the settings and worked great. I have opera mini on my epic and it says it has the option to turn off "mobile" browsing but it has no affect on what comes up in the browser. I also have dolphin and it doesnt appear to have a setting for this either.
     
  7. Bomix

    Bomix Well-Known Member
    58

    Nov 19, 2009
    109
    14
    58
    Yes, in the instructions I forgot you need to scroll way to the bottom click on UASTring Then choose desktop.

    Compared to Xscope, The default browser even though you change this setting to desktop.. after a reboot it gets stupid and forgets to do desktop. Have to change it every time.. That's been my experience.

    With Xscope, you can change it to desktop on the fly and the browser options are so much more easier to nav through
     
  8. youngabe

    youngabe New Member
    5

    Nov 26, 2010
    2
    0
    5
    Accountant
    Pittsburgh, PA
    Has anyone come up with a better fix for the default Browser? Maybe I'm doing something wrong, but when I do the "about:debug" suggestion, I do not have the "UASTring" at the bottom of my settings. I do in fact have additional options, but I don't have the quoted one above.

    I'm using a rooted Epic 4G with Froyo 2.2, flash, etc. I'm not real crazy about the way any of the secondary browsers handle video and whatnot, I much prefer the way the default browser does. I had an Evo prior to the Epic, so I'm speaking from that. Any thoughts?
     
  9. GUARDiAN921

    GUARDiAN921 Member
    6

    Oct 7, 2010
    6
    1
    6
    I typed that "about:debug" into my address bar of my stock browser and it didn't even take me anywhere. Didn't load or anything, just kept me on the same page I was on as if I didn't even enter an address to begin with. Am I doing something wrong?
     

Share This Page

Loading...