1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Mod][App] Swap External SD with Internal Memory

Discussion in 'Android Devices' started by Lordvincent 90, Jul 12, 2013.

  1. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓
    Thread Starter

    STANDARD DISCLAIMER. I AM NOT RESPONSIBLE FOR ANY DAMAGE TO YOUR DEVICE AS A RESULT OF USING THIS APP. AS ALWAYS MAKE A BACKUP IN CASE SOMETHING GOES WRONG.

    So I found an app that will allow you to use your external sdcard as internal memory. I've only done limited testing, but it appears to work. So I figured I'd put this out there for others to try. If you decide to give it a shot, please post your results here. :)

    (You obviously need root access for this to work)

    1. Download this app:
    https://play.google.com/store/apps/details?id=eu.codlab.int2ext

    2. Once you open the app (and grant it su permission) you will be presented with a screen that says you haven't selected a configuration (or something to the effect) select 'Go' this will bring you to the settings.
    (Alternatively, you can select 'I dont care' and then select 'settings')
    [​IMG]

    3. Once in the settings, check the box that says 'use per default'
    [​IMG]

    4. Now scroll down to the bottom and select 'view different devices'
    [​IMG]

    This will extend the menu to show the devices (mount points?)

    5. Scroll down until you see '/dev/block/vold/179:33'
    [​IMG]
    and select it.

    6 now press the down arrow to save these settings
    [​IMG]

    7. Press the icon on the top left and it will bring you back to the main screen.

    8. Press the 'external>internal' button
    [​IMG]

    Once it toasts that it was granted superuser permissions, you're all set. Just go to settings> storage and you will see that the device now shows that the internal is the size of your sdcard
    [​IMG]

    I have noticed that it does slow the device down a bit even with my class 10 sdcard. But that is to be expected, since the sdcard is always going to be a bit slower than internal memory.


    ****you will also notice that there is an option to run at boot. I recommend unchecking this until you're sure it is working correctly****

    -note i didn't create this app. I just found it while looking for ways to use the extsdcard as internal memory. I'm still going to look into a more 'formal' solution so we don't need to use an app to do this.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. K Rize

    K Rize Android Enthusiast

    Will link2sd still work?
    I'm gonna try it out, thanks
     
  3. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓
    Thread Starter

    Not sure. I don't use links2sd. Let me know if it does :)
     
  4. gurmel33

    gurmel33 Lurker

    please give any app for android v2.3.6,this app only for ics
     
  5. DaisFlaque

    DaisFlaque Android Expert

    I'm sorry but this is for the rush sph M830. If you're running 2.3.6 then you don't have that phone.
     
    Slayer72 likes this.
  6. gurmel33

    gurmel33 Lurker

    DaisFlaque likes this.
  7. SoulSmash3r

    SoulSmash3r Newbie

    "5. Scroll down until you see '/dev/block/vold/179:33'"

    Mine says 'dev/block/vold/179:65', do I still click on it?

    -edit
    I clicked on it and it seems to have worked, I now have 20+gb of "internal" storage.
    Oh and I am using Link2SD app also.
     
    Slayer72 likes this.
  8. pyro_guy0001

    pyro_guy0001 Android Enthusiast

    So link2SD still work? Even when the internal and external are successful switched.?? Just wanna make sure.
     
  9. SoulSmash3r

    SoulSmash3r Newbie

    Yes link2sd still works
     
    Slayer72 likes this.
  10. reemobeens19

    reemobeens19 Lurker

    Any reason this won't work with KKE 2.0? Tried all the settings with a number of variations with all the same results, it duplicates my emulated storage as both internal and extsd. I'm running AKernel with the updated/modified build.prop found here in the forums. Been trying to get a rather large game to install. Had to wipe individual directories in cwm recovery and reflash at one time due to the "at boot" option.... Seems to be reenabled each time the app runs. Pulled mount points from terminal emulator and manually put them in with the same results. Any suggestions?
     
  11. kskillz

    kskillz Well-Known Member

    There is an app on the market called folder mount that can do what your requesting without this mod...ijs
     
    Lordvincent 90 likes this.
  12. Gokaired69

    Gokaired69 Newbie

    Annoyingly, this doesn't work for my Rush at all. That green download/save arrow in the app is absent. And going through with the process simply does nothing. It simply flashes "Superuser granted to shell" repeatedly, and checking things out in Settings>Storage shows that they weren't switched at all. (Then again, it seems my Rush doesn't even LIKE the external SD anyway...nothing involving it seems to actually work properly, if at all.)
     
  13. kskillz

    kskillz Well-Known Member

    I never tried this as "Folder Mount" can do probably exactly what u need. If u state what your tryin to do maybe I could help u...
     
    Lordvincent 90 likes this.
  14. I just want to make u all aware that this is totally a cosmetic fix, there are no apps actually installed on the SD or any memory Increase
     
  15. xxbannamanxx

    xxbannamanxx Lurker

    This DOES NOT WORK
     
  16. Slayer72

    Slayer72 Android Expert

    Yes it DOES
     

Samsung Galaxy Rush Forum

The Samsung Galaxy Rush release date was September 2012. Features and Specs include a 3.5" inch screen, 3MP camera, 768GB RAM, Snapdragon S2 processor, and 1750mAh battery.

September 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...