1. Are you ready for the Galaxy S20? Here is everything we know so far!

MOGA controller (connection issue fix in post 5)

Discussion in 'Android Apps & Games' started by chrlswltrs, Dec 24, 2012.

  1. chrlswltrs

    chrlswltrs Extreme Android User
    Thread Starter

    I got one... Don't expect too much (like for it to work well) like I did.

    The device has A LOT of problems pairing with the phone. There are a ton of bad reviews for the pairing app about not being able to pair the device on multiple phones. I was able to pair mine and play a couple games, once I disconnected it I have been unable to pair it again. Here is the pairing app to read the reviews yourself: https://play.google.com/store/apps/details?id=com.bda.pivot.mogapgp

    If they could fix this it would be fantastic. Works really well for the games that are optimized for it (I played TDKR and PAC MAN). Hopefully they fix it soon, if not I'll be returning mine. :(

  2. breadnatty08

    breadnatty08 pain rustique

    I know I've had issues in the past with pairing my Wii remote (even with using the software in the Play Store).
    Does it clip on really well with your N4?

    Edit: Check out this video (talks about another driver to install to help for pairing)
  3. chrlswltrs

    chrlswltrs Extreme Android User
    Thread Starter

    Yeah I was going to give the other app on Google Play a shot later, but it requires root (not a problem for me)

    I haven't used a Wii remote in a long time. I've been using a PS3 controller which has always worked great.

    The clip works really nice with the N4. I really like the look and feel when it is clipped onto the controller.
  4. Robq81

    Robq81 Newbie

    i have the controller for my rezound which is not rooted and the Moga universal driver app works just fine. sometime it takes about 30-45 seconds to connect. you just have to be patient. Been playing my emulators and gta 3 with no problems.
  5. chrlswltrs

    chrlswltrs Extreme Android User
    Thread Starter

    So after reaching out on Facebook someone found a work around to get the controller to connect. It works and the controller is now working great. While not the optimal way to connect, at least it isn't too bad and it works.

    Before you turn the controller on press and hold the Sync button (the one that flashes blue, it has the A in a circle on it), and hold it while you turn the controller on. Then open the MOGA Pilot app (while still holding the sync button) and sync the controller. DO NOT LET GO OF THE SYNC BUTTON UNTIL THE CONTROLLER IS SYNCED. I have been using this method and it does work. You have to use this method every time you connect the controller.
  6. superdesi

    superdesi Android Enthusiast

    That workedbeautifully! I was pulling my hair out the past few days wondering why my moga controller would feel like connecting sometimes and at other times would force me to go thru a grueling puzzle of turning Bluetooth on/off, etc.

    I finally ended up Google searching my moga controller issue and luckily i found this thread with the solution. Thanks very much for posting that up, now i can instantly connect my moga controller instead of banging my head against the controller wondering why it isn't connecting.
  7. gwlaw99

    gwlaw99 Android Expert

    The universal driver app works much better than the official app. Just make sure to unsync the controller from the official app first.
  8. TriumphLance

    TriumphLance Android Enthusiast

    I can't get mine to connect to ANYTHING I must have a lemon?
  9. thejerwin

    thejerwin Newbie

    Even after using the thing where I hold down the button it still doesn't connect.
  10. thejerwin

    thejerwin Newbie

    Moga Universal driver also seems not to work
  11. thejerwin

    thejerwin Newbie

    Update: After turning Wifi off it seems to work
  12. maveric1

    maveric1 Lurker

    I can get my Moga Pocket to connect, but games that worked prior to Lollipop are now no longer working. In my case, I've tested GTA San Andreas and Nova 3. I connect to the pivot app, use it to select one of said 2 games, they launch but no controller support. Anybody have a fix for this? Moga support tells me to take out the batteries, wait 2 minutes and try again. WTF kind of support is that? Then they tell me if I have my receipt they'll send me a new one. Its been 2 years, of course I lost my receipt. Not cool.
  13. Ryan Ayers

    Ryan Ayers Lurker

    I can get the MOGA to connect but after about 10 mins of play it wont recoginise that it is on? no controls. lets me fall or die. help??
  14. verdagon

    verdagon Lurker

    My moga pro power was working fine at first but then I unpaired it, and I could pair it again (manually; i never could get the pivot app to pair it), but the controller wouldn't work. It would just keep blinking its blue lights, as if it didn't realize that it was paired.

    I unpaired it, completely restarted the phone, and paired it (still manually) again, and it all worked properly. So, restarting the phone seems to help for some reason.
  15. thejerwin

    thejerwin Newbie

    Actually, out only needs root for gamepad mode.
  16. Roger Moore

    Roger Moore Newbie

    I have OTG support so I just use USB game controllers which works perfectly fine.

Share This Page