1. Are you ready for the Galaxy S20? Here is everything we know so far!

Moment won't turn on after failed update

Discussion in 'Android Devices' started by randolpf, May 3, 2012.

  1. randolpf

    randolpf Lurker
    Thread Starter


    don't know if this is the right place for this.. but..

    i'm new here.. my iPhone broke, so until I get that fixed, i had to use my brothers girlfriends old old phone. Which is a Samsung moment. Well, this thing apparently hasn't been updated since she bought it.. She also forgot to mention it had a charging problem. So, when I went to update this, the phone fell out of debug mode during the update.. now it won't turn on. i've tried to get it in to recovery and download mode without success? Do I have a paperweight?

  2. brotherswing

    brotherswing Android Expert

    Some phones will refuse to power up if the battery drains too much. Something you could try is pull the battery while it's plugged in, then put the battery back in. Once it starts charging, leave it alone for at least an hour. Then see if you can boot into recovery.
  3. randolpf

    randolpf Lurker
    Thread Starter

    Thanks for the reply.. But the phone won't do anything. It had a full battery when I did it because I know that these things can be draining. I've fooled with a lot of phones over the years, and so far, this is the dumbest problem I've ever encountered. Never had this problem on iPhone that I couldn't fix...
  4. brotherswing

    brotherswing Android Expert

    Do you mind if I move this to the All Things Root sub forum? Even though the phone wasn't rooted, it's still basically a bad flash problem and that's where you'll find members more able to get you squared away.
  5. randolpf

    randolpf Lurker
    Thread Starter

    Sure, go ahead. I just didn't know where to post it..
  6. HeadlessPonch

    HeadlessPonch Android Enthusiast

    I haven't heard of a bad flash bricking a phone; the phone's always been able to get back into download mode. You mentioned a charging problem. Is it a usb port problem? Did the cable come loose just enough to screw up the download? That can happen when the usb port's on the way out (sometimes literally).

    Gotta start with the basics:
    Recovery is Vol Down/Send/End, in that order - That doesn't work?
    Download is Vol Down/Camera/End, in that order - That doesn't work?

    When the charger's plugged in, can you press on the End button and see the charging icon? That would show there's at least "something" going on.

    A long shot if nothing else is working - The video drivers could have been screwed up during the failed download so nothing displays onscreen. Try running the software updater again and see if it recognizes the phone, even if nothing displays on the phone after holding Vol Down/Camera/End for a few seconds.
  7. jtjohnston

    jtjohnston Lurker

    I'm not the only one? But no answers here either. Mine is a LG-P500h. I tried the power-down-volume restart. It has been on the USB charging all day. My phone is still blank, dead, kaput - nothing on poer-on. My battery was already fully charged. Did you ever get your phone working?

Samsung Moment Forum

The Samsung Moment release date was November 2009. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1440mAh battery.

November 2009
Release Date

Share This Page