1. Are you ready for the Galaxy S20? Here is everything we know so far!

*MORE* Reliable root for leakers has been found

Discussion in 'Android Devices' started by hallstevenson, Jul 13, 2010.

  1. scary alien

    scary alien not really so scary
    Moderator

    ...we will meet again....(insert evil laugh here) :D:eek::)
     

    Advertisement

  2. Podivin

    Podivin Android Expert

    I do have USB debugging enabled (and the notification bar says it's working).
    I did not unzip the ROM.
    I just rebooted both the computer and the phone. I NOW have the phone set to 'charge only' (previously it was set to 'disk drive').
    Gave the command adb push EvilEris3.0.zip /sdcard, it tells me the daemon was started successfully and is now just sitting there (going on 5 minutes now).
    I KNOW I'm missing something simple...
     
  3. xx_bishop_xx

    xx_bishop_xx Android Expert

    It takes some time, that file is 111Mb I think. Later when you execute the runindos.bat it even takes longer. Just when you think it's taken too long, it reboots your phone the second time....and you are in recovery.

    *EDIT* Did you download the zip file from XDA where it reads "updated files to hack-v3.zip"and unzip that one into your c:\android-sdk-windows\tools directory?
     
  4. MrDangerous

    MrDangerous Android Enthusiast

    I wouldn't think so.

    ALL: I would also recommend heading over to XDA to read the tutorial about how to flash the S-OFF bootloader on the phone to help prevent future unrooting.
     
  5. Podivin

    Podivin Android Expert

    I'd assumed (perhaps incorrectly) that it wouldn't take any longer to move the file by this method that it does to drag and drop it via windows from the computer to the SD Card.

    I have to go play husband and take my wife's car in for service, I'll start this again after lunch. Thanks for your help (and you too Scary).
     
  6. Jcase has posted a simplified guide to this same root technique on XDA as well.
     
  7. xx_bishop_xx

    xx_bishop_xx Android Expert


    "Patience young mhotovec..yeeees"

    [​IMG]
     
  8. bjanow

    bjanow Android Expert

    Finally got an Eris back. Still on 1.5 hboot 1.46. Now what? :) I read all that stuff on rooting weeks ago and sure enough forgot everything. But I do have all the files on the computer. Don't tell me I have to read that stuff all over again.
     
  9. scary alien

    scary alien not really so scary
    Moderator

    bjanow,

    You should be able to follow the http://androidforums.com/all-things-root-eris/53963-guide-stock-1-5-latest-root-2-1-a.html since you have one of the "golden" :)D) HBOOT versions.
     
  10. bjanow

    bjanow Android Expert

    Ok, slow day at the office so here goes. I have a few questions but let me get rooted first. If you know of a thread that goes something like: now that I'm rooted what the heck do I do.. let me know. One question is what is nand backup and another is what's with all the ROMs, how do I install them? Seems like Frisco is having a ball loading 4 or 5 roms / day at times. :eek:

    I was actually thinking of encasing this Eris in lucite since it is the golden version but I think I'll just take joy in the fact I never leaked it and it was never updated.
     
  11. MrDangerous

    MrDangerous Android Enthusiast

    Once you are rooted and have the Amon Ra recovery partition you can run a backup.
     
    bjanow likes this.
  12. scary alien

    scary alien not really so scary
    Moderator

    How about this one?: http://androidforums.com/all-things-root-eris/116574-root-best-practices.html

    ...it doesn't hit all of you questions, but its a good start.
     
    bjanow likes this.
  13. ACD168

    ACD168 Android Expert

    This is great news!,

    Here's my wacky story,

    I got a 3rd Eris refurb replacement, and the second day I had it, hadn't even installed a single app yet, and boom, silent issue, normally I let it go until it happens more and more, but it was an important phone call, and it was the 2nd day!
    So I called big red and was very polite to them. Explained whats up. I was offered the moto droid. explained why I didn't want that, and that I had problems with an HTC phone, why not replace it with an HTC phone? - so,
    Long story short, they canceled my old contract(free) and opened a new two year, giving me the dInc at the online two year price ($199 after the mail in rebate).
    So, I was given the price of the Eris which to them is $199.
    Not only did I get an Incredible for basically free, had to front $100, but then get the $100 mail in rebate back so tech. free. AND I got to keep the Eris that produced the silent bug after the day.
    SO finally getting to how this befits me.
    I was told that I would be receiving the DInc this week. I placed the Eris on Craigslist and ended up selling it that day (yesterday) for $150.
    I called big red today to get the FedEx tracking number, just to be told that the CSR was wrong and that it will be shipped by 8/2.
    umm, I already sold my Eris.
    As a result, they are going to overnight me ANOTHER Eris, will be here tomorrow, to use until I get the DInc, and then send them back this Eris.
    So I will be able to root this Eris until I have to send it back to them.
    Sorry for the long story, I thought it was interesting.
    I basically made $150 to get a DInc lol.
    and a free Eris to use until it comes.
    - politeness will bring you far in life. Lesson Learned.
     
  14. jcase

    jcase Android Enthusiast

    Tutorial is here, and it doesnt prevent future unrooting.
     
  15. mortymouse

    mortymouse Well-Known Member

    This does work and works very quickly. Pretty much everyone is getting root based off this on the first or second try. Maybe 15 mins total to get it done, mine took 4
     
  16. Densefire

    Densefire Lurker

    Im rooted!!!!! yay that was hella easy!!! ive been waiting since christmas! (didnt know about root till after I leaked... Congrats this is so awesome.
     
  17. Papadroid

    Papadroid Android Expert

    I believe your command should be this:

    adb push EvilEris3.0.zip /sdcard/
     
  18. ppbb

    ppbb Well-Known Member

    +1 i got it on the 2nd try. i am now running evil eris 3.0. wireless tethering is the best.
     
  19. bjanow

    bjanow Android Expert

  20. xx_bishop_xx

    xx_bishop_xx Android Expert

    Agreed. I wasn't speaking in terms of days, but it took about 3-5 minutes to push the zip file, and another 5-7 minutes for the second reboot. Perhaps I should have phrased that differently. Sorry bout that.
     
  21. SyDTRaKKeD

    SyDTRaKKeD Android Enthusiast

    for some it could take a while.... it does take longer to push things/transfer things to the phone than from it or from one folder to another in windows....

    mine was pretty quick.... i went to bed with a smile and woke up feeling good that I have root!
     
  22. qbot

    qbot Newbie

    Perhaps someone could give me a helping hand?

    I downloaded android-sdk-windows; hack-v4.zip; and Evil Eris 3.0.
    I put the hack file contents into the SDK tools folder.

    Evil Eris is in my root directory of my SD card.

    From the command line, I run:

    C:\>cd C:\Documents and Settings\User\Desktop\android-sdk-windows\tools​

    which gets me here:

    C:\Documents and Settings\User\Desktop\android-sdk-windows\tools>​

    Since my rom is already on my SD card, I skip the "adb push" step.

    I then execute the runindos.bat command and get this:

    C:\Documents and Settings\User\Desktop\android-sdk-windows\tools>runindos.bat
    error: device not found
    error: device not found
    error: device not found
    error: device not found
    error: device not found
    error: device not found
    "Files copied and permissions set, rebooting HTC Andriod 2.1"
    "Your phone will now reboot into normal mode, then reboot into recovery mode. If it does not reboot the second time, wait 10 minutes and manually reboot and begin again."
    error: device not found​

    The command prompt then hangs. The phone does not reboot.

    I've tried this 5 times, both in the "Charge only" and "disk drive" mode. USB debugging is connected.

    What am I doing wrong?

    Be gentle with me...
     
  23. scary alien

    scary alien not really so scary
    Moderator

    Not a 2.1 leaker, but it sounds like you haven't yet verified that you have adb / USB connectivity between your phone and your PC?

    I.e., if you issue "adb devices" from your Window Command Prompt, do you see your phone's identification number? (don't post it here if you do, it uniquely identified you and your phone).

    There's information here http://androidforums.com/all-things...oot-troubleshooting-guide-htc-droid-eris.html about how to make sure adb will talk to your phone from your PC.

    The easiest thing will probably end-up being to install HTC Sync which does a better job than most in figuring-out and installing the proper USB drivers for your PC (there's a reference in the above link where to obtain this--just scan for "HTC_Sync_2.0.33.exe").

    Hope this helps.
     
  24. Podivin

    Podivin Android Expert

    OK, back from lunch and here's what happened (for those of you who are waiting with baited breath).

    Tried to adb push the Evil Eris zip, gave up after 10 minutes of nothing happening - said screw it and moved the file via windows.
    Issued runindos command at 12:49, at 12:54 the softkey lights flashed, at 12:59 I aborted the process.
    Rebooted the phone, convinced it to go back into USB debugging mode (it didn't want to at first). At 1:04 issued runindos command, at 1:04 the phone rebooted into recovery mode with all those spiffy commands - wow, root!

    Did a nand backup, tried to 'install from zip' the Evil Eris zip and it told me the file was corrupt. Not sure if that's a bad download or because I moved it via Windows (*I* wouldn't think the method of transport would make a difference..)
    So I get to mess with how to actually load a new rom, but at least I'm rooted. :)
     
  25. xx_bishop_xx

    xx_bishop_xx Android Expert


    Welcome aboard, cheif. Nice to hear.
     
Loading...
Similar Threads - *MORE* Reliable root
  1. svim
    Replies:
    0
    Views:
    164
  2. Peter22
    Replies:
    2
    Views:
    359
  3. Android News
    Replies:
    0
    Views:
    149
  4. Android News
    Replies:
    0
    Views:
    97
  5. Android News
    Replies:
    0
    Views:
    31
  6. Android News
    Replies:
    0
    Views:
    15
  7. MoodyBlues
    Replies:
    9
    Views:
    478
  8. notableuser
    Replies:
    0
    Views:
    240
  9. djarylle
    Replies:
    1
    Views:
    193
  10. sho50
    Replies:
    1
    Views:
    366

Share This Page

Loading...