1. Are you ready for the Galaxy S20? Here is everything we know so far!

Moto Droid 2.1 realese?

Discussion in 'Android Lounge' started by simp7y, May 18, 2010.

  1. simp7y

    simp7y Lurker
    Thread Starter

    So a buddy of mine showed me his phone, and apparently he is running firmware 2.1? I see that it is out if you have rooted and you can man install it, but i asked a few other people and they are all running 2.1 as well. Why did i not get a notification for this up date!!! i am running 2.0.1 and really want this update. I did the menu > system info > check for updates and it says i am up to date. Why did these people get the update early?

    Sob me :mad:

    1. Download the Forums for Android™ app!


  2. SSinisterSS

    SSinisterSS Android Enthusiast

    just manually install it, theres a sticky in the droid section.
  3. simp7y

    simp7y Lurker
    Thread Starter

    I was thinking bout it but everyone i see tells me i need to root to do it, which i dont want to do... Ill check the sticky tho tyvm:D
  4. SSinisterSS

    SSinisterSS Android Enthusiast

    nah its easy, put the 2.1 update into the root of the SD card where everything is listed and rename it to update (if on windows) or update.zip (if on a mac) unmount the phone and reboot into recovery.
  5. Isthmus

    Isthmus Android Expert

    Sounds like you missed the boat. Do the following:

    Home screen >> menu button >> settings >> about phone >>system updates.

    Go there and let the system update itself. you should get 2.1.
  6. simp7y

    simp7y Lurker
    Thread Starter

    Tried that. Said that my system is up to date. Once again running the Motorola droid. 2.1 is out for it right?

    Now i see where the issues begin. Something is deff wrong with my phone. I never rooted or "Jailbroke" my phone. i copied the 2.1 file onto my sd card and rebooted holding the X button. I get the motorola screen and then it restarts again and again and again untill i let go of the X button in wich case it will then boot up as normal. I tried to reset via the privacy settings and the phone resets but doesn't actually restore factory settings? I took it to Verizon and the people there (as usual) were of no help, telling me to drive 2 + hours to a corporate store for a new phone or something of that sort. I plan on driving up there in the... well later am seeing it is 4:51 am for me and i have yet to sleep :p . Maybe they will be able to fix it, but if anyone knows a way of fixing this please let me know.

    I tried the Holding X button as well as safe mode, Safe mode worked x button cycled the Motorola screen. I tried the X button with and without the SD card, both the same and i even uninstalled all of the third party apps and still nothing....

    Again no root or mod of any sort. Only Third party program that i have ever used that messes with some stuff is astro file manager, but realized it wasn't for me and uninstalled. The phone works fine when on, no issues that i have noticed yet, accept no factory reset.

    Any help is much appreciated, but hey if worst comes to worst maybe ill get a new phone outa this. Gotta love that new droid smell.:D

    Thanks everyone!!

    I am so lost
    /face ~> desk
  7. mrmojoz

    mrmojoz Android Enthusiast

    This is the craziest thing I've ever heard. Thats like being iffy on the My Computer icon in Windows. Thanks!

Share This Page