1. Are you ready for the Galaxy S20? Here is everything we know so far!

Moto G (3rd gen) won't allow me to access files

Discussion in 'Android Devices' started by samthebigkid, Feb 27, 2016.

  1. samthebigkid

    samthebigkid Lurker
    Thread Starter

    SO I bought my wife a Moto G 3rd gen to replace her iPhone 4. I set up the new phone using her old SIM card. The phone works just fine as far as calls, network, texting, etc. However, I can't access the files of the phone via USB. The Moto G device is detected, but it says "0 items". I'm using a Windows 10 computer. I installed the Motorala Device Manager on my PC, and it says I need to "unlock phone". I have even tried emailing her files, downloading them on the phone, and using ES File Manager to move them and it still doesn't work (I was trying to give her a ringtone she wanted, but it kept saying Copy Failed when I would attempt to move the MP3 into her Ringtones folder). She currently doesn't have an SD card of any sort in the phone.

    Any ideas? We've had this phone for only a few days
     


  2. kate

    kate Dreaming of Bugdroid.
    Moderator

    Hi samthebigkid, welcome to the site!

    I moved your thread to the Moto G 3rd gen forum :)

    Did you enable USB Debugging so the computer can see it?
    1. Go to Settings -> About Phone and tap on "Build Number" until it says you are in Developer Mode (~10 times)
    2. Go back one menu, and right above About Phone tap Developer Options.
    3. Turn on USB Debugging.
    4. Connect the phone to your computer

    There are two ringtone folders, try:
    /sdcard/media/audio/ringtones/

    The /sdcard/ folder will be there even though you don't have an SD card.
     
  3. samthebigkid

    samthebigkid Lurker
    Thread Starter

    I have tried all of that and I still can't access the files. I've tried it on multiple PC's. Nobody seems to know why
     
  4. acejavelin

    acejavelin Android Expert

    You didn't mention if you were on Marshmallow or Lollipop, and if on Marshmallow if you were using the SD card as adopted (internal) storage or portable (external) storage.

    Assuming you are on Marshmallow, this is quite common...

    1) Disconnect USB cable from device
    2) Go to Settings - Apps
    3) Tap the 3-dot menu at the top-right and select "Show system"
    4) Scroll down and locate External Storage and open it
    5) Tap Storage
    6) Tap Clear Data (may take moment to finish)
    7) Go back to the App list and find Media Storage
    8) Tap Storage
    9) Tap Clear Data (may take moment to finish)
    10) Exit back to home and Shutdown then power back on
    11) After the device is fully booted, wait 5 minuted for media & storage databases to rebuild
    12) Connect USB cable and pull down the notification shade and select MTP for the USB connection (You must do this every time you connect to USB in Marshmallow, it isn't a "sticky" setting)

    Should take care of it.
     
  5. samthebigkid

    samthebigkid Lurker
    Thread Starter

    Thank you. That finally worked. I had tried that before, but the previous instructions failed to mention changing from charging to MTP
     
  6. acejavelin

    acejavelin Android Expert

    Glad it worked... Remember in Marshmallow you must select MTP every time you connect via USB, it will not remember and will always use Charge Only mode when connected.
     

Motorola Moto G (3rd Gen) Forum

The Motorola Moto G (3rd Gen) release date is unknown..Features and specs are not yet known.

unknown.
Release Date
0
Reviews
Loading...

Share This Page

Loading...