1. Are you ready for the Galaxy S20? Here is everything we know so far!

Moto G5s plus won't turn on

Discussion in 'Android Devices' started by queso00, Mar 13, 2021.

  1. queso00

    queso00 Lurker
    Thread Starter

    A few days ago I was using the phone normally and suddenly it turned off even with the battery level charged at 80%, when I tried to turn it on it only worked until the motorola logo and it turned off again


    Whenever it turns off, the lightning battery appears as if the battery were at 0% and then the real battery level appears


    I only managed to turn it on by plugging it into the charger, but if I disconnected the usb cable the phone shuts down immediately, for some reason it gradually deteriorated to the point that it did not turn on even with the charger plugged in, and I only got it to turn on in factory mode from the bootloader and plugged into the PC.


    Then I tried using LMSA, I only got the problem to be solved temporarily, when I installed the firmware that LMSA indicated to me, the phone returned to work normally even without being plugged in, until I downloaded an app and it turned off again, i tried to reinstall the firmware with LMSA several more times but it didn't work anymore

    I also tried unlocking the bootloader and flashing the phone on my own, but that didn't fix the problem either, the only thing I solved is that now it starts up without using the factory mode, but if it is not plugged in, it turns off.

    I already took it to an official motorola technician, they didn't want to take it because according to them my phone is assembled in China and they don't have the tools to fix that model

    I don't know what else I can do, does someone have a solution?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Dannydet

    Dannydet Extreme Android User

    Bad battery and bad phone.
    Buy a new one and no more issues.
    And don't buy another one made in China
     
    ocnbrze likes this.
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    if a factory reset or flashing firmware does not fix the issue, we can rule out that software is the cause which means that this is a hardware issue. so you can try to get it fixed or buy a new phone as @Dannydet suggested.
     
    Dannydet likes this.

Motorola Moto G5 Plus Forum

The Motorola Moto G5 Plus release date was April 2017. Features and Specs include a 5.2" inch screen, 12MP camera, 2-4GB RAM, Snapdragon 625 processor, and 3000mAh battery.

April 2017
Release Date
0
Reviews
Loading...

Share This Page

Loading...