Help Moto X Won't Sleep - Idle Battery Drain

strausd

Well-Known Member
I recently got my Moto X and for the most part I like it. However, idle battery drain is not what I would like it to be. For whatever reason, my Moto X does not like going to sleep and prefers staying in the lowest clock speed.

I have disabled touchless control, active display, Google Now, location reporting, location history, NFC, bluetooth, and probably a few more that I missed. And I uninstalled the Facebook app as well. But I don't know what is causing it. And everywhere I look online people say to download a specific battery stats app, but on 4.4 they all require root to be useful.

I don't want to root my phone at the moment, I just want it to stop sucking battery all the time. Anybody know what could be causing this or have suggestions on what to try to pinpoint the issue?

Thanks in advance!

38tn.png
 

boathead

Android Enthusiast
well, you are getting some deep sleep. were it me, i'd get wakelock detector from the play store, and it'll show you what is going on. then i guess you have the option of disabling the offending apps.

instead of that, i use ds battery saver, i think it is called. on slumberer mode, any time the screen is off the phone goes into deep sleep. i only today got a moto x so i'm not sure how it will work on it, what with the voice activation stuff that is always running.
 

strausd

Well-Known Member
Thread starter
well, you are getting some deep sleep. were it me, i'd get wakelock detector from the play store, and it'll show you what is going on. then i guess you have the option of disabling the offending apps.

instead of that, i use ds battery saver, i think it is called. on slumberer mode, any time the screen is off the phone goes into deep sleep. i only today got a moto x so i'm not sure how it will work on it, what with the voice activation stuff that is always running.

Thanks for the advice. I actually ended up sending back the Moto X a couple days ago. I am back on my Nexus 5 now. Since it was so easy to root, I installed GSam batter stats, better battery stats, and a couple others. I was able to make some adjustments to improve battery life.

When making these adjustments, I still had my Moto X so I duplicated it on the Moto X. After installing a custom Kernel, my Nexus 5 gets better battery life than the Moto X. And since battery life was my main concern, that is why I sent it back. Other than that, I loved the phone. The feel of it, curvature, screen size, and bezel placement in relation to the screen was perfect.
 

krouget

Android Enthusiast
Sadly, you've already sent back the device.

If I were in a similar situation, I'd first ensure the device itself was sound, before trying to diagnose anything else. Starting it in safe mode and letting it sit for a while would have determined this.

From there, you could restart the device, and depending on the amount of apps you have, disable them in groups to narrow it down and isolate your issue. It's certainly possible an app could have received an update, which now doesn't let it play nice.

I highly doubt it was either the touchless control or active display, since I believe those have their own dedicated CPU. IIRC, in battery tests I've seen, neither substantially contributed to drain, on or off.

Either way, hope you enjoy your Nexus 5!
 

strausd

Well-Known Member
Thread starter
Sadly, you've already sent back the device.

If I were in a similar situation, I'd first ensure the device itself was sound, before trying to diagnose anything else. Starting it in safe mode and letting it sit for a while would have determined this.

From there, you could restart the device, and depending on the amount of apps you have, disable them in groups to narrow it down and isolate your issue. It's certainly possible an app could have received an update, which now doesn't let it play nice.

I highly doubt it was either the touchless control or active display, since I believe those have their own dedicated CPU. IIRC, in battery tests I've seen, neither substantially contributed to drain, on or off.

Either way, hope you enjoy your Nexus 5!

I had the exact same apps and settings on my Motorola X as I did the Nexus 5. So safe mode wouldn't have really helped as regardless, it didn't get as good of battery as the Nexus 5 with everything else being the exact same.
 

krouget

Android Enthusiast
I had the exact same apps and settings on my Motorola X as I did the Nexus 5. So safe mode wouldn't have really helped as regardless, it didn't get as good of battery as the Nexus 5 with everything else being the exact same.
I get what you're saying, but the Moto X can be an odd beast, at times.

For example, the always listening feature of the device can conflict with apps in ways we don't consider. I had a situation where a telephony app was causing the camera to act up, because the former was trying to use the same audio API, which got blocked by the Moto X. After contacting the dev, they found it was an isolated problem with this device and a few others, so users on other phones would be none the wiser, despite running the same app and version (and possibly settings). This has happened twice to me, now.

To note, I'm also adding this information for anyone else who may be reading/searching, so they can be made aware of possible issues like this in the future. The arduous process of diagnosis can be minimized with a few simple checks.:smokingsomb:
 

DarkJedi

Android Enthusiast
Moto Assist can prevent the Moto X from staying in deep sleep for long periods. Launch it and go to settings and uncheck all the boxes. Those boxes are for services that keep your phone busy trying to figure out what you are doing (driving or not, in a meeting based on your calendar or not, is it human sleeping hours or not).

For Republic Wireless users, you also have to launch the Republic Wireless app, go to settings, and uncheck the Activity Recognition box. It does the same thing... constantly tries to figure out if you are still, walking, biking, or driving to determine whether or not to route your calls over WiFi or Cell.
 

strausd

Well-Known Member
Thread starter
Moto Assist can prevent the Moto X from staying in deep sleep for long periods. Launch it and go to settings and uncheck all the boxes. Those boxes are for services that keep your phone busy trying to figure out what you are doing (driving or not, in a meeting based on your calendar or not, is it human sleeping hours or not).

For Republic Wireless users, you also have to launch the Republic Wireless app, go to settings, and uncheck the Activity Recognition box. It does the same thing... constantly tries to figure out if you are still, walking, biking, or driving to determine whether or not to route your calls over WiFi or Cell.

I turned Moto assist off on day one.
 
Top