1. Check out our companion app, Forums for Android! Download from Google Play

Support Motorola Photon only charges with computer

Discussion in 'Android Devices' started by charliechan85, Dec 9, 2012.

  1. charliechan85

    charliechan85 New Member
    Thread Starter

    Dec 3, 2012
    My photon all of a sudden stopped charging with wall charger / outlet the only way it will charge now is if it connected to a computer with the usb data cable .I tried different wall outlet, new wall charger and new cables new battery, I did a factory reset on the phone , usb debugging toggle and battery pulls as well. Of course sprint just wants to charge me for a new one, but it seems to me that there might be an easy fix that I may have over looked. Some of the other posts about this same issue went cold . I am just wondering if anyone was able to solve this problem or may have some new info. Thanks in advance.


  2. El Presidente

    El Presidente Beware The Milky Pirate!

    Jan 3, 2011
    Given all you've tried hardware wise, and it's still an issue after a factory reset, a call to Sprint unfortunately.

    As a last resort, you could see if there's anything obstructing the charging port? Is there dust/diry or anything like that?
  3. Citizen Coyote

    Citizen Coyote Well-Known Member

    Aug 12, 2011
    Austin, TX
    It will charge through the computer but not via the wall charger? Seems like some voltage regulator or something got fried, and it can now only safely handle the lower charge from a computer USB port. If you still don't want to deal with paying to replace it (and there's nothing blocking it), it sounds like charging through your computer is your only option. Does your computer have an "always on" charging USB port? That would at least make it more convenient than having to leave the computer on.

    Another question: will it charge using a car charger?
  4. samchungasun

    samchungasun New Member

    Jul 9, 2013
    I have exact same problem and I think I know how the a/c charging was fried. I plugged into usb the other day and the connection is loose and chime kept ringing as if connect disconnect. I was messing around with my printer for about 20 seconds while this happen. I then moved the evo cable slightly and charged. Later that night plugged phone into a/c charger and seemed to be charging except when I awoke it was still at 30%. Went to work disassemble battery 5 times later on usb it worked. Later went to sprint got new battery same issue. Another phone enroute in few days...this really sucks but after fooling around with this phone via usb right now has 70% charge and rising. Slow trickle charge is all she can do. Yup its temperamental pos. Most post I read I have had exact same issues. This is photon number 3 and massive amounts of info I'm going to lose. The first one dropped on its side from about 3 feet and shatter screen. I later learned that 2 months after purchase it was discontinue and obsolete as no screen protectors can be found. I only bought after reviews being "good" "fast" etc. Turn off 4g unless you know its really 4g. 4g lte, plus will save battery as phone always search.

Share This Page