1. Are you ready for the Galaxy S20? Here is everything we know so far!

Motorola update -> Photon stuck in boot loop

Discussion in 'Android Devices' started by crosspatch, Aug 24, 2012.

  1. crosspatch

    crosspatch Member
    Thread Starter

    My Photon is rooted. I was shocked to find an official Motorola update available the other day (after checking under Menu > About phone > System updates > Update Motorola software). I can't remember what version the update was, and right now I have no reliable way to check. In any case, I made the mistake of trying to install that update.

    Hey, it's an official release, what could go wrong? Famous last thought!

    After an eon passed and the update was downloaded, my phone rebooted. And it gave this error:

    Failed to boot 2
    Starting RSD mode


    I've seen this exact message before--after I installed ROM Manager, tried installing CWM from that app, and rebooted. The difference with CWM was that after doing a battery pull, I was able to boot and use my phone normally. Now, however, a battery pull lets me boot into my phone, at which point I have ~15-25 seconds before the phone automatically reboots, only to give the aforementioned error again.

    I have searched for this error and potential resolutions. I've tried:

    * Clearing all app caches. (Probably idiotic, but desperation does that to me.)

    * Clearing the Dalvik cache with this app. That only reboots my phone and makes it take much longer to boot. Once it's done booting, the boot loop recurs.

    * Doing a factory reset using "external keys" via some forum posts I found, and also Motorola's instructions.

    - After I carry out step 1 of Motorola's instructions, my screen shows:

    Android Recovery

    After step 2 (i.e. after Android Recovery is shown and I press Volume up), my screen shows:

    Android Recovery
    Failed to boot 2


    - If I press Volume up a second time at that point, my screen shows:

    Android Recovery
    Failed to boot 2
    Starting RSD protocol support


    - The same things happen if I press and hold Volume up (rather than pressing it twice quickly). At this point, no key presses seem to do anything. The only apparent choice is another battery pull. Lather, rinse, repeat.

    I can't help think that my CWM install attempt has something to do with this issue. Can CWM be uninstalled? I don't see any way to do so from within ROM Manager.

    I am at my wit's end here!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    Do you have a nandroid backup in CWM? If so, you may want to restore that and see if there is a guide in the All Things Root section for installing the update on a rooted device. If you do not have a nandroid backup, I will find a guide for doing an RSD Lite install which will unbrick nearly anything that goes wrong with a Moto device.

    Good luck
     
    crosspatch likes this.
  3. crosspatch

    crosspatch Member
    Thread Starter

    No Nandroid backup; I was never able to boot into CWM. When I tried, I got the "Failed to boot 2" error. :(
     
  4. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    I'm tied up a bit at work, but I'll be able to try and walk you through an SBF restore. Start by checking out this thread. There are various options.

    http://androidforums.com/photon-4g-...compendium-k-all-things-mopho-06-11-12-a.html

    Oh, BTW, an SBF is a way to restore factory firmware on your device. I didn't notice any software links for RSD Lite, but if you google it, just follow a link to Moto's site and download it from there. You should also be able to get drivers for your device there as well.

    If you get confused by anything in that guide, just ask me, and I'll try to explain it. Any you can call me Pup, it's shorter to type.
     
  5. crosspatch

    crosspatch Member
    Thread Starter

    I have solved the problem. In hopes of saving someone else from this nightmarish hassle, here's what I did. Basically, I cleared the cache partition using ADB.exe and fastboot.exe (both part of the official Android SDK).

    1. To get the latest version of ADB and fastboot installed, I downloaded the Android SDK from Android.com. You can get them a lot quicker and easier than that, but I wanted to get them from an official source.

    2. But wait--ADB and fastboot aren't installed by default with the Android SDK. (Strange but true.) I needed to run the "SDK Manager" from the "Android SDK Tools" Start menu folder to open the Android SDK Manager. From there, under Tools (under the list of Packages), I selected "Android SDK Platform-tools", then clicked "Install 1 package..." below. After what seemed like an hour, ADB and fastboot were installed.

    3. To get the latest Motorola USB drivers installed, I downloaded Motorola Device Manager. Again, there are sources for just the USB drivers, but I wanted the latest and greatest, bloat and all.

    3. I started my phone, and with the short amount of time I had, I enabled "USB Debugging" under Menu > Applications > Development.

    4. With my phone plugged into my PC's USB port, I started my phone again (after a battery pull, of course), selected the USB entry from the notification area drop-down, and ensured that "Charge Only" mode was selected. (Incidentally, I was using the original Motorola USB cable, which I have heard makes a difference. That sounds odd to me and I don't know if it's true or if any similar USB cable would work, but I wasn't taking chances.)

    5. I opened a Windows command prompt window, and navigated to the directory where ADB.exe and fastboot.exe are located. I installed the Android SDK to "C:\Program Files\Android SDK Tools", so ADB.exe and fastboot.exe were located in "C:\Program Files\Android SDK Tools\platform-tools" on my PC (because the platform-tools directory is added when you install ADB and fastboot).

    So, run CMD to open a command prompt window. Then, use the "change directory" (CD) command to navigate to the platform-tools directory, wherever that is. For example:

    cd "C:\Program Files\Android SDK Tools\platform-tools"

    You can type adb and hit Enter to see if you have it right. If so, a listing of valid ADB commands will appear (but nothing else will happen).

    6. Yet another battery pull and phone restart. This time, as soon as my phone started, I entered the command:

    adb reboot bootloader


    My phone restarted automatically, and it stuck on the red Motorola logo screen, which normally appears briefly before the regular boot animation. I didn't know if this was right, but apparently it was. No errors appeared, and the Motorola logo remained.

    7. I entered the command:

    fastboot erase cache

    And a message was returned stating how long it took to erase the cache.

    I'll be honest; I'm not clear on this. If you run the command "fastboot erase cache" from the command prompt before your phone is even connected, you'll receive the message "< waiting for device >". It may be true that you don't need ADB.exe at all, and that you can simply run the "fastboot erase cache" command. I don't know, and I'm sorry about that.

    8. I unplugged my phone and did a final battery pull and boot. No more boot loops! When Android was done starting, rather than another mind-blowingly aggravating reboot, I received this rather entertaining message:

    Info
    Failed to update. An unspecified error has occurred.
    Please try again later.


    In my case, "later" means "when you've moved on to another phone, and don't care at all about this one anymore"!

    I may have some details incorrect, or I may have forgotten something. I tried. My life is on my phone, and this was a pretty stressful and confusing ordeal, but I did my best to explain how I fixed it.

    Ugh... I need a drink. Or four!

    Thanks to Pup (Unforgiven) for your help, and for anyone who even read this and gave it a moment's thought.
     
    rukmalfernando and Unforgiven like this.
  6. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    you rock crosspatch:thrasher:
     
  7. Greetings from Sri Lanka! I too thought "what could go wrong" after getting the update prompt, and got in to the same reboot loop. I was about to download the SDK and follow your steps when I noticed a sneaky little menu item in the update screen that said "Wipe cache" or something similar. Since that's what you did, I did the same, and that fixed it! :)

    So, thanks a lot for figuring out that the cache needed to be wiped, and I think this shortcut might work too.

    FWIW, my update screen mentioned CWM, but I bought this used and rooted, so I'm not sure if it's installed or not.
     
  8. JeDiPhoton

    JeDiPhoton Lurker

    After reading through the thread and thinking crosspatch may have found the solution to my problems... And, as I was waiting for the Android SDK package to install, I thought I'd try one more thing.

    I went to an android app that I recently downloaded, ROM Toolbox Lite... You can find it in Google Play store.

    Go to the Management section of the app, and under EXTRA TOOLS, select Wipe Options. Select Wipe cache and push OK. It will say Error! but Try Anyway, and it will reboot... This will boot you straight into recovery after pushing...

    And, your
    Failed to boot 2
    Starting RSD mode


    will be gone... Hope this works for all of you... It worked for me!
     

Motorola Photon 4G Forum

The Motorola Photon 4G release date was August 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Nvidia Tegra 2 AP20H processor, and 1700mAh battery.

August 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...