1. Are you ready for the Galaxy S20? Here is everything we know so far!

Mounting /system as read/write

Discussion in 'Android Development' started by stoned frog, Mar 23, 2020.

  1. stoned frog

    stoned frog Lurker
    Thread Starter

    I've got a rooted Pixel 2XL running Android 10 (no custom ROM installed or anything like that, not sure if having one would impact the effectiveness of my attempts), and I'm trying to mount the /system partition as read/write. I'm using a terminal emulator on my phone to do this.
    I've searched through several forums and have gathered that the most used command seems to be "mount -o rw,remount rw /system", but every time I input this into the terminal I get a message saying "mount: '/system' not in /proc/mounts"
    As someone who is absolutely not a developer and has zero experience in the field of Android development, I have to rely on forum answers online. Problem is, most of those answers seem to be only relevant/applicable to Android devices running operating software from many years ago. I can't find any recent answers dealing with Android 10 or my specific device model, so I'm at a loss about what to do. Please help!
    For reference, below are screenshots of what happens when I run the command "cat /proc/mounts"
    /system doesn't appear to be in there, but I might just be blind.
    If it doesn't exist as a mount, however, is there any other command I can use to set the /system partition to read/write instead of read-only?
    Thanks in advance!
    Screenshot_20200323-195824.png Screenshot_20200323-195840.png
     



    1. Download the Forums for Android™ app!


      Download

       
  2. MrJavi

    MrJavi Android Expert

    mount -o rw,remount /system

    and not

    mount -o rw,remount rw /system

    This worked for me on a lower OS. Good luck
     
  3. codesplice

    codesplice Elite Recognized Moderator
    Moderator

    What about targeting / since that's where the partition is actually mounted? Admittedly, I haven't rooted in years and I'm not sure if there's some glaringly-obvious reason why that wouldn't work but I figure it's worth a try. :)
     
Loading...

Share This Page

Loading...