1. Are you ready for the Galaxy S20? Here is everything we know so far!

Movie goes screwy 3/4 of the way through

Discussion in 'Music & Media' started by Phastor, Oct 22, 2010.

  1. Phastor

    Phastor Newbie
    Thread Starter

    First off, I have an HTC Eris running KaosFroyo v36

    So I decided I was going to encode a movie to Mp4 (from a DVD I own) to put on my phone so I have something to watch at work. To do my encoding, I used Any Video Converter with the following parameters.

    Picture size: 480x208
    Codec: x264
    FPS: 24
    Bitrate: 380

    Codec: AAC
    Sample: 44.1
    Bitrate: 160

    This was my first time playing any video on my phone, and when I got the movie on there, I was very happy to see how well the Eris played. The sound stayed in sync even after navigating and there were no hiccups or delays in playback at all.

    And then I got about 3/4 of the way through the movie. At around this time, the video freezes on one frame, but the audio continues to play. The phone wasn't locked up or anything, the video just stopped. The navigation bar also moved all the way to the beginning. I've seen this happen before in some movies on other players/software (minus the navbar moving back) and found that navigating just ahead of the offending point will usually allow me to get through the rest of the movie.

    Now here's where it gets interesting.

    After trying to navigate just passed the bad point, sure enough the video plays just fine, however now the audio that is playing is sound from the beginning of the movie.

    The first thing I thought was that Any Video Converter encoded a bad movie. I tried encoding again, this time in HandBrake, with the exact same parameters. The movie had the exact same hitch in the same spot with identical behavior. I tried playing the movie again in different media apps with the same result. However, the movie plays with no problems at all when I run the same Mp4 on my PC. So it's now narrowed down to the phone. Any ideas on what could be causing this behavior?

    1. Download the Forums for Android™ app!


  2. Phastor

    Phastor Newbie
    Thread Starter

    Well I tried it again with a different movie this time. Same exact behavior. The video in both movies freeze at the exact same time. 01: 11: 34.

    And same last time, the new movie plays just fine on the PC.
  3. Member243850

    Member243850 Guest

    Howzit Phastor buddy!

    Hmm... let me think now,

    It cud be the onboard player that Eris uses... try another media player maybe? I dunno actually, damn...

    All-in-One Media Player for Android | RealPlayer

    Hmm, it cud also be that the sd card might be corrupted at that exact point on the sd card.... hmm...damn

    Sorry i don't know :(
  4. Phastor

    Phastor Newbie
    Thread Starter

    I gave RealPlayer a try and had no luck. The same thing happened. I've also tried Rockplayer and a couple others. The video on both movies locks up at the exact same place at 01:11:34 and behaves in the same way as described above when I try to navigate around that point.
  5. Member243850

    Member243850 Guest


    maybe try another sd card in the phone perhaps dude?
    Or check the sd card for errors / maybe formtat the sd card and try again maybe?

    Damn i am out of options here sorry buddy :(
  6. Phastor

    Phastor Newbie
    Thread Starter

    Well I gave yxplayer a try and it doesn't have the locking up issue, but for some reason, yxplayer's video playback is very grainy and laggy to boot. I gain one thing and lose another. At this point the only thing I can think of doing is break up my movies in sections that are no longer than the 01:11:34 mark.
  7. Phastor

    Phastor Newbie
    Thread Starter

    A little update on this. I recently flashed to GSB CM7 due to unrelated issues. I thought I would give the movies a try again and see how it would do under a new ROM. No luck. Same behavior.
  8. Try using Handbrake to convert it
  9. Phastor

    Phastor Newbie
    Thread Starter

    I tried it in Handbrake using the same parameters. I got the identical behavior at the very same spot. This happens with any movie I encode at 01hr:11min:34sec.
  10. Usta

    Usta Android Expert

    So, you have tried different videos, converters and players.
    I suppose you could try another SD card in the phone to exclude card errors.
    Or try to convert again a video, but this time with other parameters, like using Divx codec (some converters use a name MPEG4 - SP), and wrap it in avi container. Now try to play it with RockPlayer. This would exclude video parameter specific errors.

Share This Page