1. Download our Official Android App: Forums for Android!

MP4 stream not playing

Discussion in 'Music & Media' started by mikaelus, Apr 9, 2010.

  1. mikaelus

    mikaelus Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 9, 2010

    Apr 9, 2010
    1
    0
    5
    Hello,

    We're currently launching a site with live (TV) and non-live streaming of video material.

    The RTSP live feeds play fine on Android (.sdp extension) however other videos published on the side in MP4 format - don't. Neither the browser nor the Meridian player recognise the files and play them.

    Any ideas where we went wrong?

    PS. I'm not the guy in charge of the video encoding etc. but I'm looking for some tips and information for our team. Any info highly appreciated.
     

    Advertisement

  2. bbrosen

    bbrosen Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    314
    Joined:
    Dec 3, 2009

    Dec 3, 2009
    314
    31
    43
    I dunno either but my htc hero cannot play mp4 videos either
     
  3. infuggincredible

    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    May 6, 2010

    May 6, 2010
    4
    0
    5
    Mobile Video Production
    Overland Park, KS
    I am able to play mp4 files on Android handsets. I have had success streaming them via RTSP, and even using http. My problem is that it isn't always RELIABLE. Sometimes I get a file that will play through QT on my Mac, but the same file won't play in my application.

    I recently asked my partner, who does the application coding, to give me some details around the issue. He said that these are the error messages he sees:

    05-05 00:54:36.366: ERROR/(35): Dynamically Loading the library : libOmxH264Dec.so
    05-05 00:54:36.436: ERROR/QCvdec(35): get_parameter: unknown param 0ff7a347
    05-05 00:54:36.436: ERROR/PlayerDriver(35): Command PLAYER_PREPARE completed with an error or info PVMFErrNoResources
    05-05 00:54:36.436: ERROR/MediaPlayer(4632): error (1, -15)
    05-05 00:54:36.436: ERROR/MediaPlayer(4632): Error (1,-15)

    It is weird that other files using the same encoding parameters, coming from the same server, just won't play.

    Any help is appreciated.
     
  4. sitlet

    Rank:
    None
    Points:
    213
    Posts:
    5,867
    Joined:
    Apr 11, 2010

    Apr 11, 2010
    5,867
    633
    213
    what codec are you using for the mp4 files?
     
  5. infuggincredible

    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    May 6, 2010

    May 6, 2010
    4
    0
    5
    Mobile Video Production
    Overland Park, KS
    I'm using h.264 with aac for audio.
     
  6. rushme1986

    rushme1986 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 27, 2011

    Dec 27, 2011
    3
    0
    5
    did u get this to work? I am stuck in a similar issue. My client is sending me live stream ip camera feed in the form of h.264 and am not able to view it in my phone having 2.2 Os. Since it is a continuous stream and not a file, i am not able to view. It works well in VLC player.
     

Share This Page

Loading...