1. Download our Official Android App: Forums for Android!

mt3gs adfree

Discussion in 'Android Devices' started by boshk, Feb 21, 2011.

  1. boshk

    boshk Newbie
    Thread Starter
    Rank:
     #889
    Points:
    16
    Posts:
    16
    Joined:
    Feb 15, 2011

    Feb 15, 2011
    16
    1
    16
    i'm having problems with adfree on mt3gs rooted cm7. i've installed it, reverted, redownloaded hosts, uninstalled, reinstalled, reverted, re downloaded, reverted, etc (also never received any errors.) and it still shows ads. what am i missing? i've searched around, and cant seem to find if i am missing a step that i was supposed to do.

    additional thoughts:
    does it matter if it is installed on simcard or phone? i had originally installed it on the simcard and then moved it to the phone, but it doesnt seem to make a difference anyways.

    also i've reverted and reinstalled with "symlink" checked and unchecked a few times, and it didnt seem to make a difference.
     

    Advertisement

  2. boshk

    boshk Newbie
    Thread Starter
    Rank:
     #889
    Points:
    16
    Posts:
    16
    Joined:
    Feb 15, 2011

    Feb 15, 2011
    16
    1
    16
  3. gtmaster303

    gtmaster303 Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Oct 25, 2010

    Oct 25, 2010
    6
    1
    6
    you need the s-off hack on your phone. otherwise you have to push files manually in order for it to work...
     
  4. boshk

    boshk Newbie
    Thread Starter
    Rank:
     #889
    Points:
    16
    Posts:
    16
    Joined:
    Feb 15, 2011

    Feb 15, 2011
    16
    1
    16
    well, i've read that the files supposedly go to your SD card. but they never showed up there. and i have no idea how to "s-off" no one ever seems to want to explain that anywhere.

    ok, well i did another round of searching the interwebs and tried this:

    put hosts file to the tools folder of your sdk installation
    open terminal with android connected and adb drivers installed
    cd C:\androidsdk\tools
    adb remount
    adb push hosts /system/etc

    but i get the message:
    failed to copy 'hosts' to '/system/etc/hosts': directory not empty
     
  5. boshk

    boshk Newbie
    Thread Starter
    Rank:
     #889
    Points:
    16
    Posts:
    16
    Joined:
    Feb 15, 2011

    Feb 15, 2011
    16
    1
    16
    booted into recovery and opened CMD window:

    cd C:\androidsdk\tools
    adb shell
    # mount /system
    # exit
    adb push hosts /system/etc
    adb reboot

    now it works.
     

Share This Page

Loading...