1. Download our Official Android App: Forums for Android!

Support multiple account Gmail notification issues

Discussion in 'Android Devices' started by frayedlaces, Sep 18, 2011.

  1. frayedlaces

    frayedlaces Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Sep 18, 2011

    Sep 18, 2011
    4
    0
    5
    I have two gmail accounts on my Bionic. I'm only getting notifications for one account even though both have the same notification settings. Am I missing something?
     

    Advertisement

  2. johnlgalt

    johnlgalt Antidisestablishmentarian
    Rank:
    None
    Points:
    453
    Posts:
    9,453
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    9,453
    1,957
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Do you have new email in the inbox of the other account?

    I have 4 set up and all 4 give me notifications when something new comes into the inbox. If it gets filtered into another folder (aka label in GMail) then I don't get a notification.
     
  3. frayedlaces

    frayedlaces Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Sep 18, 2011

    Sep 18, 2011
    4
    0
    5
    Hmm. Looks like it may be so. I used the "add account" feature within the pre-installed gmail app. Is there a better way to set up multiple accounts?
     
  4. New Rising

    New Rising Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    481
    Joined:
    Jul 7, 2011

    Jul 7, 2011
    481
    71
    53
    Make sure it's synced properly. Open your Gmail hit your account name in the upper right, then hit menu then account settings. Click on the account that's not getting notifications and make sure all the boxes are checked then sync them all again.
     
    frayedlaces likes this.
  5. johnlgalt

    johnlgalt Antidisestablishmentarian
    Rank:
    None
    Points:
    453
    Posts:
    9,453
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    9,453
    1,957
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Make sure the checkboxes for the services you want synced are enabled. In this case, email for the second account, plus anything else you want synced on the second account.
     
    frayedlaces likes this.
  6. BenDroid

    BenDroid Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    200
    Joined:
    Jan 8, 2010

    Jan 8, 2010
    200
    13
    58
    I second this comment. I was having the same problem and it was just a matter of me not checking the second account to be synced.
     
  7. frayedlaces

    frayedlaces Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Sep 18, 2011

    Sep 18, 2011
    4
    0
    5
    Alright, both inboxes have exactly the same settings, including all the checkboxes selected for both labels (sync all). Still nothing. I've sent test emails to both accounts and only get a notification for one. I'm starting to feel a little moronic. It shouldn't be this hard, right?
     
  8. BenDroid

    BenDroid Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    200
    Joined:
    Jan 8, 2010

    Jan 8, 2010
    200
    13
    58
    I just ran through my settings to make sure that there was nothing that I missed. All I did was go to Settings - accounts - add account. I added the account and then selected the account and ensured everything was checked.
     
    frayedlaces likes this.
  9. frayedlaces

    frayedlaces Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Sep 18, 2011

    Sep 18, 2011
    4
    0
    5
    When in doubt, start over. I deleted the account and then added it again. It works! Who knows what the problem was to begin with. Thanks for your help!
     
  10. johnlgalt

    johnlgalt Antidisestablishmentarian
    Rank:
    None
    Points:
    453
    Posts:
    9,453
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    9,453
    1,957
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Hmmm. Sometimes when setting up accounts it automatically starts to sync one or more of the various services, even if it is unchecked, and then when you check it it seems to go into a loop and forgets about the actual sync part (I ran into this over a year and a half ago with my OG DROD, but never since).

    Since then I made it a habit to

    • check
    • uncheck
    • recheck

    what I wanted so that the current sync gets canceled and a new sync is created when I recheck.

    My apologies for not throwing that out there - I set mine up over a week ago and promptly forgot that I actually go through this rigmarole to get it working right on both phones.
     
  11. BenDroid

    BenDroid Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    200
    Joined:
    Jan 8, 2010

    Jan 8, 2010
    200
    13
    58
    I actually went to bed last night and thought about telling you to remove them and try again. I remembered having to do that on my OG Droid after having a similar problem to yours. Glad it worked out for you.
     

Share This Page

Loading...