1. Download our Official Android App: Forums for Android!

Support Multiple numbers

Discussion in 'Android Help' started by Ratinthekitchen, Aug 30, 2016.

  1. Ratinthekitchen

    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    3
    Joined:
    Aug 30, 2016

    Aug 30, 2016
    3
    0
    15
    Male
    This is driving me mad. I've searched the forums before posting but can't find anything the same.

    I am running Kitkat 4.4 on a Nexus 4. I don't have any duplicate people showing in contacts on my phone but some people have the mobile number listed more than once. For example:

    Alan Jones (this is OK)
    07777 111111

    John Smith (this isn't)
    07777 222222
    07777 222222

    I went into contacts.google.com and merged duplicates. But whilst this now says there are no duplicates, after syncing when I look on my phone only some of the previous multiple numbers are showing as single in contacts. For others they still show the number more than once.

    I've edited the contact in contacts.google.com and removed duplicate mobile numbers but this makes no difference.

    I've noticed that for some of them if I edit on the phone they show as having a google contact and a corporate contact linked to my hotmail. If I delete the mobile number from the corporate contact then the duplicate number goes away. But I can't work out how to delete the whole corporate contact.

    But that doesn't cover everything as not all duplicates have corporate contacts. I did think it may have something to do with whatsapp as in edit mode I can also see whatsapp contacts listed as well. However, in the example above both Alan and John are showing google and whatsapp contacts but Alan doesn't have any duplicates but John does.

    I'm now totally confused......can anyone help. Thanks!
     

    Advertisement

  2. Daniel Fernandes

    Daniel Fernandes Android Enthusiast
    Rank:
     #67
    Points:
    398
    Posts:
    477
    Joined:
    Aug 20, 2016

    Aug 20, 2016
    477
    617
    398
    Male
    Student
    Goa, India
    Maybe John's contact is stored on SIM and phone
     
  3. Ratinthekitchen

    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    3
    Joined:
    Aug 30, 2016

    Aug 30, 2016
    3
    0
    15
    Male
    Thanks for reply. I don't think that's it as I can't even see how to do this on my phone. But I've sussed that I had contacts synced with outlook as well as Google so I deleted all my outlook contacts and that has helped.

    But it's still not solved as most (bizarrely not all) still show the mobile number twice if they are on WhatsApp. This is obviously the reason but I can't see how to stop it showing numbers from WhatsApp also.

    I'm running KitKat on Nexus.

    Thanks
     
  4. Hadron

    Hadron  
    VIP Member
    Rank:
     #7
    Points:
    2,218
    Posts:
    22,400
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    22,400
    15,683
    2,218
    Spacecorp Test Pilot
    Dimension Jumping
    You should be able to tell it only to display contacts from certain sources (e.g. SIM, Google, Phone contacts, so I'm assuming here WhatsApp too - I don't have that app installed so can't test).
     
    scary alien likes this.
  5. Ratinthekitchen

    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    3
    Joined:
    Aug 30, 2016

    Aug 30, 2016
    3
    0
    15
    Male
    Thanks but either I'm doing it wrong or it makes no difference. In the people app you can choose source to display but that only seems to filter the list on that app.

    If I choose Google only then when I go into the phone app or even my banking app to pay contacts the lists presented STILL show people's numbers twice.
     
  6. svim

    svim Android Expert
    Rank:
     #45
    Points:
    608
    Posts:
    3,756
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,756
    2,796
    608
    Illinois
    So it sounds like you're using your contacts in your online Google account as your 'primary' source with your other services and apps being fed from that, yes? With those duplicate numbers that continue to persist the chances are one or more of those other services is keeping its own local storage.
    -- Try going into your phone's Settings >> Accounts and temporarily disabling any 'Sync Contacts' in the various accounts (sounds like you'll have at least your Google account, WhatsApp, and Outlook).
    -- Now switch to your computer and go back into https://contacts.google.com and check all your contacts entries are there and 'clean'. As this is more or less your 'gold master' of Contacts you might also want to back it up -- in the left side column click on the 'More' link to get to the 'Export' option (which will take into a somewhat convoluted number of steps to get a simple Google Contacts csv file). Note the back up is just a precaution, also in that 'More' link is a 'Restore contacts' option so if something like a bad syncing wipes out a bunch of important entries you can go back to before the event happened.
    -- Going back to your phone, now that syncing is temporarily off, dig into the Contacts app, WhatsApp app, and whichever other apps that were linked to your Contacts and delete any of those random duplicates that were stored locally on your phone. Then when that's done, go back into your Settings >> Accounts and turn syncing back on for your Google account and tap the 'Sync Now' button at the bottom. Wait a few minutes for your contacts to re-sync and then open up the Contacts app and check to see if your contacts are showing correctly. (fingers crossed) If so, it's up to you if you want to re-enable syncing for those other apps and services. You might want to just limit adding/editing contact entries to your phone's Contacts app and through https://contacts.google.com, leaving WhatsApp and whichever other apps to just use the Contacts app database on your phone without the ability to mess with your main Contacts entries.
     
    scary alien likes this.

Share This Page

Loading...