1. Are you ready for the Galaxy S20? Here is everything we know so far!

My android does not work on home wifi, but works everywhere else

Discussion in 'Android Help' started by CursedAndroid, Nov 14, 2019.

  1. CursedAndroid

    CursedAndroid Lurker
    Thread Starter

    Android: Samsung A40
    Not rooted
    Software information: One UI version (1.1) - Android Version: 9

    For a couple of months my Android is useless on my home wifi. Cannot really stream videos, for example,as it just stops or buffers. My iPhone, Macbook, Smart TV, Sonos, two PCs (and my partner's Android) all work perfectly. My home wifi has really good speed. It's just my android.

    Oddly, my previous Android was the same (changed models in August). It just stopped working properly and then when I got a new one (same SIM card and based on back up) I had the same problem.

    However, my Android works fine on all other wifi networks I try it on. It's perfect. Just at home it doesn't work. EDIT: Most of the above devices are only connected occasionally (so it isn't like there are too many devices at once. Problem is same with most other devices offline.

    I've tried disconnecting, reconnecting, forgetting network, etc. I even changed the channel on my router, no change.

    Any ideas? When I Google it I get general advice on fixing wifi issues, but this is only specific to my home wifi. So I'm confused. Thanks in advance.
     


    #1 CursedAndroid, Nov 14, 2019
    Last edited: Nov 14, 2019
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    i would reboot your router.
     
    Dannydet likes this.
  3. CursedAndroid

    CursedAndroid Lurker
    Thread Starter

    Hi, thanks for taking an interest.

    I've turned on/off (for quite a while at times) the router to no avail. And I have changed the channel it broadcasts on too. Is there another way/more thorough way to reboot.
     
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    i unplug the router at home when one of my devices is having issues, rather than turning on or off. don't know if there is a major difference in doing so.

    so your phone connects, but it is slow? is it only when streaming videos?
     
    tube517 likes this.
  5. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™
    Moderator

    Not turning it off or on, physically unplug the power source from the router and wait 10 sec and plug back. See if that works.

    Also check in your router settings to make sure your Phone device didn't get blocked.
     
    tube517, Dannydet and ocnbrze like this.
  6. CursedAndroid

    CursedAndroid Lurker
    Thread Starter

    It's really slow even loading standard websites sometimes. And both unplugged and switched off.
     
  7. CursedAndroid

    CursedAndroid Lurker
    Thread Starter

    Thanks. It hasn't been blocked as it still works...just slooooooowly.

    Will try again to unplug...but pretty sure I tried that once already. Thanks.
     
  8. svim

    svim Extreme Android User

    https://www.gsmarena.com/samsung_galaxy_a40-9642.php
    I wouldn't dwell too much about the channel issue, if that was the problem you would be having issues with your other devices too. But there is apparently a problem with your A40 and your router.
    -- What kind of router do you have? Is it an ISP-supplied modem/router unit or do you have your own separate router?

    Try setting up a guest network, using just its default settings and see if your A40 is having the same connectivity issues when connected to it. Be sure to use both 2.4GHz and 5GHz band networks to see if one or the other works out or doesn't. Try disabling IPv6 in your router, that shouldn't be an factor at this point but for several years support for it was something of a weak point with Android.
    If you're not having issues when connected to that guest network, then it becomes a matter of comparing the configuration settings used in the guest network vs your main, default WiFi network. Given that you're not having similar issues with the other devices and things connected to your WiFi network the problem could be a really insignificant setting that's only affecting your A40.

    All that said about router issues, getting back to your phone. Try restarting it into its Safe Mode:
    https://www.hardreset.info/devices/samsung/samsung-galaxy-a40/safe-mode/
    While running in Safe Mode it's running just the base Android OS, no third-party apps and services get loaded into memory during start up. So don't be surprised that a lot of things seem sluggish when you tap on them, they're not getting pre-loaded like they usually do. But if you're not seeing those same kinds of WiFi connectivity slow-downs while in Safe Mode that's an indicator that there's some app you've installed that's creating a problem. I doubt this will reveal anything though since you're not having similar problems using other WiFi networks but it doesn't hurt anything to at least try (just in case it does).

    A somewhat drastic thing to try is look through your Settings menu for a 'Network settings reset' option. This will wipe all network related options back to their defaults. It's like a Factory Reset but limited only to network settings. But note that saved WiFi networks, Bluetooth pairings, and any manual changes you've made to any cellular service options will be deleted so do this only when nothing else is working out.
     
    ocnbrze likes this.
  9. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    Some devices have a hard time when encountering a router with the SSID for 2.4GHz and 5GHz set to the same thing (e.g. both set to MyNetwork). I ran into this some time in the past (maybe a doorbell I was testing) and simply renamed my 5Ghz network MyNetwork5G and all was good.

    I'm not a huge network guru, so I don't remember or understand the particulars, but it worked for me.
     
    ocnbrze, tube517 and svim like this.
  10. CursedAndroid

    CursedAndroid Lurker
    Thread Starter

    Thanks for this, I will try it when I am back home this weekend. Really appreciate the lengthy advice. Thanks.
     
  11. CursedAndroid

    CursedAndroid Lurker
    Thread Starter

    Thanks for the input. I'll check into it.
     
    Unforgiven likes this.
Loading...
Similar Threads - android does home
  1. akaskhu
    Replies:
    2
    Views:
    348
  2. angrypidgeon
    Replies:
    6
    Views:
    472
  3. chinnar
    Replies:
    0
    Views:
    484
  4. akaskhu
    Replies:
    4
    Views:
    477
  5. akaskhu
    Replies:
    3
    Views:
    460
  6. Stokestack
    Replies:
    6
    Views:
    639
  7. idon
    Replies:
    0
    Views:
    482
  8. idon
    Replies:
    1
    Views:
    361
  9. SanjanaAndroid
    Replies:
    1
    Views:
    618
  10. HimanshuB7
    Replies:
    3
    Views:
    432

Share This Page

Loading...