Support My camera works on and off. //black screen/freezing/crashing//

Discussion in 'Android Devices' started by kwicksilver, Aug 15, 2011.

  1. kwicksilver

    kwicksilver Lurker
    Thread Starter

    Hey everyone,
    I just picked up my HTC EVO 3D from rogers mobile last thursday and everything was going well until Friday night, then I went to take a picture and it was a black screen, and I could not press any buttons other than the home button. I kept trying and I could use my front camera but the rear camera just went to black, sometimes froze, and sometimes crashed.

    4 hours later it miraculously started working again! Until the next day..

    It then broke the same way all the way until sunday morning when it started working one more time, it finally stopped working 3 hours ago.

    I am wondering if anyone has had similar problems/knows how to fix it, or if I should return it for my money back.



  2. ovrrdrive

    ovrrdrive Android Expert

    Have you installed a bunch of crap from the market?

    I might try a factory reset and see if that clears it up but more than likely you got a bad unit and will need to return it.
    marctronixx and EarlyMon like this.
  3. ceabbott2

    ceabbott2 Well-Known Member

    I believe this issue is unfortunately common. My phone is rooted and I have many applications installed. The frustrating part it isn't one particular thing that triggers the "black screen of death"(XDA posts) for me. The screen goes black and the four menu keys at the bottom light up and the only cure is a battery pull. Could you reply with some particulars about your phone set up, (rooted or not, current software build number, if you are running a different kernel other than stock, number of apps, if you are using any software like apps2sd or dark tremor)? Maybe it will trigger a memory with someone else having the same problem. I was on the Synergy nightlies (8/9 build) when I had my first experience with the black screen and I switched to Viper Rom. Coincidentally I also switched recoveries from CWM to TWRP. I just downloaded Shooter Rewind and the Synergy 8/14 build to try again. I am waiting for Myn to release his ROM so until then I am flashing away. Oh haven't had the black screen since moving away from Apps2SD and Synergy but again it may have nothing to do with either pieces of software. I may try Apps2Sd again and see what happens:eek:.

  4. duratime

    duratime Android Enthusiast

    I have the same problem and only have the following apps installed:
    SwiftKey X
    Calendar Pad Pro
    AT&T Uverse
    GPS Status
    Batterey Solo Widget
    Google Voice
    Google Chrome to Phone
    Color Note
    Root Explorer (not rooted)
    and the normal Google stuff.
    I don't think it has anything to do with the apps, but if we have one in common that might be an issue, I will try to uninstall it and see if the defect is repeated.
    ceabbott2 likes this.
  5. kwicksilver

    kwicksilver Lurker
    Thread Starter

    Well this is a bummer if it'd common Haha, I'm running a non rooted phone, with android 2.3.4. I have a couple games installed and advanced task killer. The weird thing is when it occurs, I have tried a battery pull and even a factory reset nothing worked, thr only thing that seemed to fix it was waiting for a few hours. And just like ceabott said, the four icons at the bottom show up but nothing else works.

    It's very frustrating! Anyways thanks for the help so far!
  6. marctronixx


    the task killer should be uninstalled in my opinion. killing apps does more harm than good.

    if your under 30 days you can return it.

    also if a factory reset does not fix your issue, the phone may be damaged internally. take it back.
  7. madmax2k1

    madmax2k1 Newbie

    This happened to me a couple of days ago; my phone is stock with a few games and utilities installed. A restart resolved the issue.

Share This Page