1. Download our Official Android App: Forums for Android!

Support My charge is a bit laggy

Discussion in 'Android Devices' started by jpog, Jun 14, 2011.

  1. jpog

    jpog Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    46
    Joined:
    Jun 13, 2011

    Jun 13, 2011
    46
    5
    16
    Ever since I had to do a factory restore...verizon rep..said I had a memory leak on my phone..thought all internal storage was full when not..my cahrge is a bit laggy.

    It just takes a while for things to open and for the home screens to scroll..takes a while for the applications menu to come up..Is this due to EE4 or the charge itself. I only had it for a day so I didn't get to play with it much before the restore. Or did the restore screw something up.

    Would Launche Pro help with the lag.
     

    Advertisement

  2. kyler13

    kyler13 Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,638
    Joined:
    Nov 17, 2009

    Nov 17, 2009
    1,638
    284
    163
    Annapolis, MD
    Memory leak? LOL - that would be an issue that I would expect a battery pull and restart to cure, if anything. You could see if another factory reset works. But based on both those issues, you may have a bad build. Swap it for a new one.

    Edit: There shouldn't be lag as severe as you describe. That seems more extreme than anything a custom launcher would help.
     
  3. twistedlim

    twistedlim Android Expert
    Rank:
    None
    Points:
    78
    Posts:
    804
    Joined:
    Jun 9, 2010

    Jun 9, 2010
    804
    80
    78
    Michigan
    I would pick up a new micro flash card. The one that came with my phone was slow and buggy. A new card made all the difference for me.
     
    gemro311 likes this.
  4. Kelmar

    Kelmar Done by choice
    Rank:
    None
    Points:
    823
    Posts:
    11,820
    Joined:
    Nov 28, 2009

    Nov 28, 2009
    11,820
    4,751
    823
    Do you have a lot of widgets on your screens? That would create lag.
     
  5. phareous

    phareous Member
    Rank:
    None
    Points:
    16
    Posts:
    41
    Joined:
    Apr 27, 2010

    Apr 27, 2010
    41
    3
    16
    Here is what I have tried...

    I switched to a new SD card. The write time on the one that came with it was 14.3 MB/sec. I put in another one I had which was 16+ GB/sec.

    I switched the launcher to ADW. That worked for a little while but then it got to the point where it would hang if I tried to add a new app to the homescreen. Then I switched to LauncherPro. This was a little better but still randomly crashes (like it did on my Incredible). My next step is to try Go Launcher which I have heard good things about.

    I am also thinking about rooting it and going with a custom ROM which uses lagfix, EXT4, etc.

    Link to rooting:

    http://androidforums.com/samsung-droid-charge/353362-my-take-ee4.html#post2819109
     
  6. jpog

    jpog Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    46
    Joined:
    Jun 13, 2011

    Jun 13, 2011
    46
    5
    16
    I do use a lot of widgets..about 1 to 2 on every home screen. The lags I have are sometimes when I scroll through the home screens..its not very crisp. Also..when I hit add. shortcuts..applications...sometimes it takes 3 to 5 secs. for the applications screen to show up...sometimes when I unlock my phone it takes 2 to 3 secs. for the home screen to populate...

    The verizon rep said, a factory restore is not uncommon..is this true.

    Any other ideas.

    Also..I don't understand how the SD card would matter..I have nothing saved to it..all the programs are running of internal memory.
     

Share This Page

Loading...