1. Are you ready for the Galaxy S20? Here is everything we know so far!

My "data network mode" is not working....HELP!

Discussion in 'Android Devices' started by infusehelp, Dec 21, 2011.

  1. infusehelp

    infusehelp Newbie
    Thread Starter

    It says data mode is activated but the symbol doesn't show up at the top of the screen and the internet is not working. I have been trying out battery savers and etc and i think it messed it up. Now my data thing is messed up. It won't show up on my screen....maybe i hit something and didn't notice....i don't know! Please help! :eek::eek::eek:

    ETA: I had "Juice Defender" on my phone and now it's all messed up....:rolleyes:

    1. Download the Forums for Android™ app!


  2. infusehelp

    infusehelp Newbie
    Thread Starter

    Wow thanks for the help guys.....geesh tough crowd!

    Anyway i just did a factory reset and started over....so mods...you can close this thread.
  3. maztor

    maztor Lurker

    This may sound like a dumb question but what did you do exactly? I downloaded the battery saver app and now my 4G isn't working. I can't receive picture messages and I can only use the internet with WiFi. It also makes my 4G symbol disappear when I turn on WiFi
  4. cutesquirrel

    cutesquirrel Lurker

    Hi Maztor, I have the same problem (I hate that battery saver!!) and I finally found a way to restore my 4G data connection WITHOUT resetting the whole phone!!
    if you go to Setting, then Mobile networks, then choose Access Point Names.
    you should see at least the original one provided by your carrier (in my case it was Rogers Internet).
    stay in this screen and press the bottom left button, the menu key.
    then you should see a menu bar show up at the bottom of the screen, with 2 choices: "new APN" or "Reset to default".
    just hit "reset to default", then it will start running and within 5 seconds you will see the APN has changed! (mine changed from "xxx.diabled" to "xxx.apn")
    then just leave this screen and within 15 seconds you will start to see the 4G logo coming up again!!!!

    I'm so glad I insist to try everything before going to the Fatory reset route!! I really don't want to have to set up my phone again!!!!
    Hope this will help save your phone too!
  5. tmalla1

    tmalla1 Lurker

    THIS IS AWESOME! ive been frustrated by this problem all day and now fixed it! Thanks a bunch
  6. gyan2011

    gyan2011 Lurker

    I am also facing the same problem . can you help me out too?

  7. gyan2011

    gyan2011 Lurker

    my problem has been solved too guys thanks
  8. alc2189

    alc2189 Lurker

    thank you what you said worked and was so helpful thank you from alc2189
  9. Ryanscool

    Ryanscool Android Enthusiast

    Lol guys i just had this happen to me (im on froyo right now, i have a fried usb connecter thing so not going to try roms until i get a new one) anyway i just turned airplane mod on and off, then it fixed itself ha.
  10. Ganesh9

    Ganesh9 Lurker

    I arrive at the Access Point Names and choose it. Then you said to choose menu button and you will see reset to default or new APN. I don't see 'reset...".

    Please help. I have samsung infuse with latest SW.
  11. lilsteph210

    lilsteph210 Lurker

    well it did change my APN back to normal by doing what you said, and i read that my APN was disabled or something. I tried to get on the internet after restoring it to default but my 3g icon still hasn't showed up. my data is enabled. I tried restarting my phone but it still isn't working :thinking:
  12. rmc2139

    rmc2139 Lurker

    Same for me. Data not working, tried all the steps above, nothing. It already had factory settings, I just bought it...guess will be returning.
  13. alabelle612

    alabelle612 Lurker

    Thank you for the tip, I switched my service from a Canadian provider to a German provider and I was tearing my hair out trying to figure out why my data was not working. I created the new APN and everything works great!
  14. is247

    is247 Lurker

    AT&T Settings.
  15. is247

    is247 Lurker

    AT&T Settings.

    Sorry guys, but the most accurate way to fix the issue with not being able to send pictures through your text or data network will not show can be resolved by following these steps.

    1. Press the settings/menu button (far left button)
    2. Press Settings (bottom, middle)
    3. Press Wireless and network (typically at the top)
    4. Press Mobile networks (typically at the bottom)
    5. Press Access Point Names
    6. Press settings/menu button (far left button)
    7. Press New APN
    Type the following Setting:

    Name: ATT WAP
    APN: wap.cingular
    Proxy: wireless.cingular.com
    Port: 80
    Password: CINGULAR1
    Server: Not Set
    MMSC: http://mmsc.cingular.com
    MMS Proxy: wireless.cingular.com
    MMS Port: 80
    MCC: 310
    MNC: 410
    Authentication type: None
    APN type: internet + mms + supl

    Note: I advise restarting phone only after saving setting: Press settings/menu button (far left button) Click/Press SAVE on the screen

    You can also email me if any complications: info@is247answers.com
  16. pollypickle

    pollypickle Lurker

    YES THIS WORKED FOR ME! THANKS SO MUCH!!!! I have a Samsung Infuse and suddenly today with no warning whatsoever I lost Network connection. I could connect on Wi-Fi no problem, but anything on the 4G network was gone. When I looked in phone info under Status the phone said "Network State: disconnected"

    I had tried toggling Airplane mode, rebooting + still no go.

    I tried a few other things I found on this site and then I found the below and it worked!

    Now, my question is this: What is the deal with this problem and do I have to use this new APN all the time now?

  17. is247

    is247 Lurker

    I'm Happy it worked for you!!!

    The issue whit Samsung Infuse data network setting APN resetting has to do with but varies; sometimes the Samsung Infuse just resets on it's own or whenever you take the SIM card out, taking out the battery, and i also found out WiFi resets if from time to time.

    For the most part, you will not have to worry about putting APN setting all the time, whoever, make sure you have the list of settings on hand.

    Imani Smith
  18. Debs76

    Debs76 Lurker

    Cutesquirrel you are an absolute star!!!!! This has been 'doing my head in' for two days. Thanks so much x
  19. biffiewand

    biffiewand Lurker

    I'm having problems connecting to 4G. It's been a few weeks and I haven't really noticed until today, since I'm usually connected through wifi.

    For me, it says "APN Empty". I tried entering all the information below then hit save and it reverted back to the "APN Empty/Add an APN?" page. When typing all the info. in, it already had MCC & MNC numbers. Those were:
    MCC: 310
    MNC 260
    I changed the numbers to the ones below when trying to add the APN. (Could this be because I have a different phone?? I'm phone illiterate..sorry!)

    Help! I have a Sidekick 4G.

  20. biffiewand

    biffiewand Lurker

    Just realized what I tried was for AT&T. I have T-Mobile. :smokingsomb: Below is straight from the web and helped me out:

    Per T-Mobile:
    Resolution Steps
    Check settings and reset APN
    Checking mobile network settings and resetting the APN resolves the majority of issues, and is much faster than verifying all settings.

    If you have a battery saver app, check its settings. Some battery saver apps disable the APNs or data connection when the battery level gets low. You need to adjust these settings or uninstall the app to keep the data connection working
    From the Home screen, press the Menu key.
    Touch Settings.
    Touch Wireless & networks. Depends on software version
    Note: This varies on different software versions.
    Android 1.6: Wireless Controls.
    Garminfone: Wireless Manager.
    Behold II: Phone Information.

    Verify that the Airplane Mode or Flight Mode check box is cleared.
    If you see a Mobile Network check box, verify it is selected.
    Touch Mobile Networks.
    If you see the following check boxes, verify they are selected:
    Data Enabled
    Use Packet Data
    Data Roaming This will incur charges if you roam internationally, but it is required to receive data when roaming domestically.
    Touch Access Point Names or APNs.
    Press the Menu key.
    Touch Reset to default.

    From the Home screen, press the Menu key.
    Touch Settings.
    Touch Wireless & networks. Depends on software version
    Note: This varies on different software versions.
    Android 1.6: Wireless Controls.
    Garminfone: Wireless Manager.
    Behold II: Phone Information.

    Touch Mobile Networks.
    Touch Access Point Names or APNs.
    If there is a T-Mobile APN, touch it. If not, press the Menu key, and touch New APN.
    Verify and update the following settings for the Data APN:
    Name: T-Mobile
    APN: epc.tmobile.com
    Proxy: <Not set>
    Port: <Not set>
    Username: <Not set>
    Password: <Not set>
    Server: <Not set>
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS proxy: <Not set>
    MMS port: <Not set>
    MMS protocol: WAP 2.0
    MCC: 310
    MNC: 260
    Authentication type: <Not set>
    APN type: <Not Set> OR Internet+MMS (depending on software version)
    Press the Menu key.
    Touch Save.
    In the list of APNs, delete all others that may appear. If there is a FOTA APN, you may leave that one. To do this:
    Touch the APN you want to delete.
    Press the Menu key.
    Touch Delete APN.
    Verify that there is a circle next to the one remaining APN to show it is activated.
    Perform a soft reset.
    Test your data connection, by accessing a web page or sending a picture message (MMS).

  21. lasherman

    lasherman Lurker

    I cant seem to get a mobile network for ATT so I cant make calls. I tried adding the ATT settings you posted but I get nothing. Can you help me please? I dont know what else to try.

    THANKYOU Lurker


    I made a profile just so I could say that cause I dealt with the issue for like 6 months and att didn't know Jack shit about how to fix it

    PS: if you ever see me you may have your way with me
  23. pozo

    pozo Lurker

    I was having the same problem where wifi was working, but the phone would not connect to the internet via 3G. I tried everything in this thread, but then I came across another solution that fixed my problem:

    I held down the button on the right side of the phone until the power off screen came up. Then I just chose the "Data Network Mode" option.

    Problem instantly solved.

    Apparently this option turns the 3G off and on. I must have previously hit it accidentally.

    Hope this helps.
  24. ifixairplanes

    ifixairplanes Lurker

    Thanks from me too.....this place is an INCREDIBLE resourse!!!!!!!!!
  25. dickeos

    dickeos Lurker

    I have done a APN reset;removed Juice defender app;swithced flight mode on and off ;activated mobile data and while this results in data being restored it only stays on for about a hour or so and i then have to do the hole process again for it to come on again -any other suggestions would be appreciated

Samsung Infuse 4G Forum

Features and specs are not yet known.

Release Date
Similar Threads - data network mode
  1. Sajivjess
  2. rshimizu12
  3. ezio aulditore
  4. svim
  5. King Mustard
  6. Michavz05
  7. SavageRobot
  8. bwallx
  9. rockie12_us
  10. Jehantqs

Share This Page