1. Are you ready for the Galaxy S20? Here is everything we know so far!

my GALAXY S3 not detected on PC

Discussion in 'Android Devices' started by jhilke, Jan 8, 2013.

  1. jhilke

    jhilke Lurker
    Thread Starter

    it did worked when i connected my s3 for the first time with out installing any softwares. it did installed some drivers itlesf i guess. but after few day my pc doesnt detects it. may be after i installed kies ??? i uninstalled kies and tried too. i downloaded latest driver from samsung site as well. all of my attempts were useless. help me :(

    1. Download the Forums for Android™ app!


  2. Jeepmaster

    Jeepmaster Well-Known Member

    Did you try a different USB jack, and not in a USB hub? Mine seems to work only in certain USB connector on my machine.
  3. Eldarwen

    Eldarwen Lurker

    I have the same problem and my laptop makes a funny noise when I dock it, instead of dum dum it says dddduumdumdum and really soft. I tried all ports and The cable is active since it does charge my phone when plugged into laptop. my phone does need an update but it doesnt have enough space so it can't update..so maybe that is the solution...
  4. bobbybules

    bobbybules Lurker

    plz let me know how do i sync galaxy s3 with my pc
  5. I have spent considerable time on this. Finally this worked for me. :D

    Note: For all the devs around, Kies does not work with USB Debugging enabled.

    If you check and find that in your case its already disabled, do not be alarmed. In some cases the issue remains even when its disabled. Try this.

    1. Unplug the USB cable from the Galaxy S3
    2. On the Phone go to "Settings" > "Developer Options" > Enable "USB Debugging"
    3. Connect the USB cable from the Galaxy S3 to the PC
    4. The PC will install some drivers, wait for it.
    5. When the drivers are installed, unplug the USB cable from the Galaxy S3
    6. Go to "Settings" > "Developer options" > Disable "USB Debugging"
    7. Connect the USB cable from the PC to the Galaxy S3
    8. Run Kies.

    Let me know how it goes. You can also reply back on Facebook - Rooting for Android page :beer:
    Jeepmaster likes this.
  6. aditya17

    aditya17 Lurker

    Worked like charm! Thanks man!
  7. LaraR

    LaraR Lurker

    I am also facing same issue and I checked the suggested solution will not be fruitful to me as the option of Enabling USB Debugging is already checked on my device.
    I'll appreciate if you could guide any other solution.

  8. Theonesalmon

    Theonesalmon Well-Known Member

    I had the same problem, battery pull worked for me. I know, weird. Shot in the dark
  9. MercilessLTD

    MercilessLTD Member

    I'd make sure the cable and the port on your phone aren't the problem. Since micro USB has become a bit of a standard for charging, some USB cables are not viable for data transfer and only the power lines work. Also, sometimes the pins may not exactly line up between the phone and the cable and cause issues.
  10. Deleted User

    Deleted User Guest

  11. Galaxy Tab2 47

    Galaxy Tab2 47 Android Enthusiast

    Some times I have to reboot my computer to get it to notice my G3.:rolleyes:
  12. nytmare

    nytmare Well-Known Member

    I've tried virtually everything to get my S3 to connect to my laptop and have not been successful. The funny thing is, it use to connect to my old laptop that ran Windows XP and had 2.0 USB ports (its motherboard fried a few weeks ago unfortunately). It didn't do it consistently, but after playing with it, I could eventually get it to connect as an MTP device (I never had Kies loaded on my old laptop). My new laptop is running Windows 8 and has 3.0 USB ports. I've used the most up to date driver and I've used the previous driver with no luck. I also can't get Kies to find it. It simply tries to connect, but never does. I know my laptop knows the S3 exists 'cause I can see it in my Device Manager. It even says the device is working properly. Still can get to it via Windows Explorer or Kies.

    I'd like to root my phone, but can't if the laptop won't connect to it. This sucks... :thinking:
  13. philayl

    philayl Android Expert

    Hi, I had the same problem, I used these drivers and every thing works ok now. Phil
    Download and install the top driver on the right Version
    nytmare likes this.
  14. nytmare

    nytmare Well-Known Member

    Thanks for the suggestion. Do I have to do anything with the file once it's extracted? I ask 'cause after I downloaded and extracted it, my S3 still isn't recognized by my laptop. I restarted as well, just in case and still can't connect.

    Also, for anyone who may ask... I've tried three different types of micro USB data cables and none of them worked. I thought for sure that would have been it.
  15. philayl

    philayl Android Expert

    Hi, I assume you opened the folder and installed the drivers, or go to "Control Panel", "Device Manager" scroll down to the USB ports, usually the first two are the 3.0 ones, right click, select "Properties" and then "Drivers", select "Update Drivers", then "Browse my computer for driver software", then use the Browse to point it to where you have unzipped the drivers to, I usually put them on the Desktop, they are easier to find. Phil
    nytmare and Arphilj like this.
  16. nytmare

    nytmare Well-Known Member

    Hmmm... I'm going to Device Manager > Universal Serial Bus Controllers > Generic USB Hub (that's what the first two are called). I right click on the first and there's an option to update the driver. I navigate to the folder where I saved the extracted file and it will only allow me to select the folder where I've saved it (it won't display the actual extracted .exe file). Thinking it'll find the file, I simply select the folder and select "Next". When I do that, I get a message indicating that my drivers are up to date and that no action is necessary. So, it doesn't seem as though Windows 8 will let me purposely update the driver using the file you pointed me to.

    Thanks for the assistance (greatly appreciated), but this seems to be a never ending rabbit hole.
  17. nigsy

    nigsy Android Enthusiast

    Try unistalling the existing drivers. Then install the new ones.
  18. lasanthapw

    lasanthapw Lurker

    I got same problem. The reason was i plugged external hard disk and some drivers missing required to galaxy. Go to device manage and check.

  19. philayl

    philayl Android Expert

    Hi, will get back to you when I am in front of my computer, can't remember the name of the USB ports off hand. Phil
    nytmare likes this.
  20. philayl

    philayl Android Expert

    Hi, the USB 3.0 ports should have a specific ID, such as XHCI, or should specifically state USB 3.0, can you post a screenshot of your device manager USB ports, do you have USB 2.0 and 3.0 ports? Is your motherboard Intel or AMD? Phil
    nytmare likes this.
  21. nytmare

    nytmare Well-Known Member

    My motherboard's an Intel and I have two 3.0 USB ports (no 2.0 ports).

    Here's a screenshot of my Device Manager (I hope it shows up):


  22. philayl

    philayl Android Expert

    Hi, check you have the latest Intel drivers first, if you go to the screen shot you posted using Control Panel, right click on the "Intel 7 Series xxxx USB Enhanced Controller" and select "Properties", click on the "Driver" heading and you will see the "Driver Version", it should be, if it isn't, follow this link and at the bottom of the page you will see the relevant download for them, https://downloadcenter.intel.com/De....0+eXtensible+Host+Controller+Driver&lang=eng
    Download these and install them, then reboot your computer, go back to the screen shot using "Control Panel" and check that they have been updated. If not get back to me, sorry if this seems long winded, but it is so much more difficult if I am not in front of the problem computer. Phil
    nytmare likes this.
  23. Quoros

    Quoros Member

    I found this on XDA and it worked like a charm. Copied from xda all credit goes to impact215

    I fixed this by removing the Upperfilters setting in the following registry key (ALWAYS MAKE A BACKUP OF THE REGISTRY BEFORE MAKING CHANGES):

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{EEC5AD98-8080-425F-922A-DABF3DE3F69A}

    nytmare likes this.
  24. nytmare

    nytmare Well-Known Member

    You're spending a lot of time and patience helping me out with this and I appreciate it. Ok... I checked the current Driver Version for my Intel(R) 7 Series/C216 USD Enhanced Controller and each one is I downloaded the drivers you recommended above and unzipped the file. I ran the setup.exe file and I get a message saying my computer doesn't meet the minimum requirements to run the software. :thinking: Thoughts?
  25. nytmare

    nytmare Well-Known Member


Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date

Share This Page