Help My Galaxy Tab 2 Bricked and now shows Firmware error screen.


Alright, so I was given a used Galaxy Tab 2 10.1'' Model GT-P5113, it was working just fine the other day. Then the next day, I went to go use it and it wouldn't bricked and then would only turn on to the first Samsung boot screen. At the time I could only boot into Download Mode. I could NOT access Recovery mode for whatever reason. So, since I had next to nothing on it aside from Fallout Shelter and a few other misc apps, decided to try Download mode and re-flash it.

So, I then Downloaded Odin to my PC and then I found the stock Samsung Firmware to re-install/re-flash to my Tab 2. I booted into Download Mode and it began to reflash. Then..for whatever reason I accidentally unplugged the USB cable while Odin was doing it's job...Which I think is what screwed me. Now all I get is this screen.

I tried Kies, but all I ever get in Kies is a constant "connecting..." screen as seen below.


Even when I click tools and the recovery option, Kies says my device doesn't support initializing.

I've scoured Google for the past 2-3 days for a solution. all of them needing to boot into download mode....which is something I can't do on this device currently..I can't go into recovery either. It will only ever show the above screen...Even after holding the power button it'll flash off then on again.

Hence, my posting this. Any help is greatly appreciated. I'm getting a bit frustrated with this...


Extreme Android User
Any time you are reprogramming a computer, and you interrupt the process before it has completed, you have pretty much destroyed the ability of that computer to reboot and perform anything useful.

Somehow, the eprom will need to be reprogrammed or replaced.
I doubt seriously at this point you will be able to do anything thru the USB cable process.

I have been where you are now.... and my Word of Warning is simple.
Do not, under any circumstances be messing with anything near, or around the devices being programmed.

get away from the table/device and just leave it alone until it comes to the desired result.

I think your device is hosed....


Well-Known Member
Not much help I know but I had the same thing.
PC re started (fekin windoze) halfway tough a keis update and bricked my tab 2.
Tried everything but had to admit defeat in the end and bought a new one.