1. Download our Official Android App: Forums for Android!

My Gmail Inbox is a Nightmare

Discussion in 'Android Apps & Games' started by andrew_wiggin, Jan 6, 2010.

  1. andrew_wiggin

    andrew_wiggin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jan 6, 2010

    Jan 6, 2010
    5
    0
    5
    I hoard emails, because I first got gmail when I had a mac which uses the mail client, so I just never deleted them.

    Anyway, this means that when I first synced my phone, I ended up with nearly 14,000 emails. They are all unread. Any ideas on how to fix this? I know you can adjust the gmail settings to only forward new emails to pop but I can't take off and re-sync my account.

    I'm on a motorola droid, in case that's necessary info.

    First time posting, thanks for your help!
     

    Advertisement

  2. Chexmix

    Chexmix Lurker
    Rank:
    None
    Points:
    25
    Posts:
    7
    Joined:
    Dec 13, 2009

    Dec 13, 2009
    7
    0
    25
    the chi
    You could always try logging into your Gmail account via your browser (on the computer, not the phone) and deleting everything from there? Of course, archive any that are necessary or you want to keep, especially if they're not already saved in Mail. You could also "Mark all as read" or "Archive all" or whatever instead.

    So yeah, try logging into Gmail via your Mac's browser and deleting all the unwanted messages there! Since the phone syncs with your Google account, it'll get rid of the messages you deleted.

    Edit: You might need to manually refresh Gmail on your phone after doing this.
     
  3. mylinuxbox

    mylinuxbox Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    117
    Joined:
    Nov 26, 2009

    Nov 26, 2009
    117
    2
    36
    Why not reset the phone but next time before allowing the sync put in the settings to only get new mail?
     
  4. dodald

    dodald Newbie
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Nov 8, 2009

    Nov 8, 2009
    18
    4
    16
    I had the same problem, and decided that I would just mark everything as read. (Click Select all, you'll see a box that says "All 100 conversations on this page are selected. Select all ##### conversations in..." click it, and select "Mark as read.")

    When you have a subscription (e.g. I have like 50 Google Alerts) that you don't want to be notified about create a Filter that applies a label, and have it "skip the inbox" and you won't be notified. (Click the "create filter" link next to the search button, follow the instructions)
     
  5. andrew_wiggin

    andrew_wiggin Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jan 6, 2010

    Jan 6, 2010
    5
    0
    5
    Brilliant! I feel like a moron now since that was an easy, easy fix.

    Thanks!
     

Share This Page

Loading...