1. Are you ready for the Galaxy S20? Here is everything we know so far!

My phone does not run MMI codes, it makes a call instead!

Discussion in 'Android Help' started by Kharl, Jan 28, 2017.

  1. Kharl

    Kharl Well-Known Member
    Thread Starter

    Hi!

    i have a Kyocera DuraForce E6560
    Great phone, but for now i am unable to run the MMI codes

    for exaple, to consult balance i need to dial #111# then send
    in ll my other sons it starts the mmi equence and thet shortly i receive a SMS mesage telling me the balace

    but in this phone when i do that and then i click send it tryes to call instead and then i reeve the message "this call can not be completed..."

    i need help
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Kharl

    Kharl Well-Known Member
    Thread Starter

    So, nobody knows what can i do witha phone that does not run or does nt support" short codes? an alternative?
     
  3. mikedt

    mikedt 你好

    A Kyocera phone. Did you import this from Japan, and I presume your carrier isn't NTT DoCoMo or SoftBank? Could be a compatibility issue.

    What country are you in and who's your carrier?
     
    #3 mikedt, Jan 29, 2017
    Last edited: Jan 30, 2017
  4. Kharl

    Kharl Well-Known Member
    Thread Starter

    Thank you for your time

    I did import it from USA, i am in Dominican Republic, using a carrier called VIVA.
    two years ago i imported another phone form ATT, from USA and it worked, all other phones, the same scenario and they worked
     
  5. tommo47

    tommo47 On Yer Bike, In Yer Chair
    VIP Member

    Are you sure it's #111# and not *111#?

    Balance enquiry MMI codes that I know are all *xxx# format.

    I could be wrong but I'm sure that most codes requiring a response begin with *.
     
    #5 tommo47, Jan 30, 2017
    Last edited: Jan 30, 2017
  6. Kharl

    Kharl Well-Known Member
    Thread Starter

    Hi!
    yes, i am sure, in the other phones it works like that, but anyway i tried the one you mentioned and the same result.
    i will upload a video of what is happening
     
  7. Kharl

    Kharl Well-Known Member
    Thread Starter

     
    mikedt likes this.
  8. mikedt

    mikedt 你好

    For information, I just tried #111# on my Oppo R9 Plus, and it does go through as an MMI code, and not a call like in the OP YouTube video. Gives an error of course because that MMI code is invalid for China Unicom.

    I think it's possibly an issue with the phone itself, US version device? Because AFAIK usually things prefixed and suffixed with # or * should be MMI codes sent to the network, or codes for the phone itself, like show IMEI, etc.
     
    #8 mikedt, Jan 30, 2017
    Last edited: Jan 30, 2017
  9. Kharl

    Kharl Well-Known Member
    Thread Starter

    it IS a issue with the phone
     
  10. mikedt

    mikedt 你好

    OK, but what you can do to fix or work around the problem, I have no ideas. Frankly I thought Kyocera phones were only available in Japan, their home market.
     
  11. Kharl

    Kharl Well-Known Member
    Thread Starter

    its not a Japan issue, it is ATT who block it

    there is a function in the phone the SIM tool kits i know they have fixed all the others mmi codes, there and they work but tru that interface but the one i need does not,i mean i am sure that with a coma or a period or a plus sym,bol, there is something missing

    also the hotspot is also blocked as all att mobile phone

    but for now i am more urgent with the mmi
     
  12. mikedt

    mikedt 你好

    Is it an AT&T customized version? Don't know much about that. I'm much more familiar with phones in China, and Asia generally, and why I thought Kyocera was Japan only. One thing, hotspot functions are just not blocked or disabled here, and we never have to pay extra fees to enable tethering.

    @kate might know something. :)
     
    #12 mikedt, Jan 31, 2017
    Last edited: Jan 31, 2017
    Kharl likes this.
  13. Kharl

    Kharl Well-Known Member
    Thread Starter

    hahha
    ok

    yes it is a AT&T customized version
     
    mikedt likes this.
  14. kate

    kate Dreaming of Bugdroid.
    Moderator

    I would guess that AT&T removed the option from their ROM, the only solution I know is to root and put a custom ROM that supports it. Hopefully there's an easier solution, but I don't know it. :(

    Mike - Kyocera sells a number of phones in the US, but they're not as popular as other manufacturers. Mostly in the prepaid market.
     
    mikedt likes this.
  15. Kharl

    Kharl Well-Known Member
    Thread Starter

    i really would like to root it
     
  16. kate

    kate Dreaming of Bugdroid.
    Moderator

    Looks like our Kyocera Duraforce forum isn't very active, XDA might have rooting methods for your phone.


    The two main advantages of rooting a phone are being able to put a custom ROM on the phone and the ability to install apps that require root.

    Two downsides - there is a small chance you can brick the phone, and if it's newer you may void the warranty.

    The root process is different for every phone, so follow instructions for your specific device. Here is more information about rooting:
    http://androidforums.com/threads/rooting-best-practices.450904/
    http://androidforums.com/threads/root-terminology.443075/
    http://androidforums.com/threads/youve-went-and-rooted-the-phone-now-what.617220/

     
  17. tommo47

    tommo47 On Yer Bike, In Yer Chair
    VIP Member

    Hi, you mention a comma and/or + symbol and a Google search brought up the following :-

    "Add a comma at the end of the Prefix code or you can use the + symbol after *
    For example, if your Prefix code is *2904*7# use
    *2904*7#, or *+2904*7#
    By adding the comma it forces the operation to execute and overlook any error that’s in the way."

    Reading your post I'm not sure whether you have actually tried inserting them in your #111# code.......

    I have a feeling that you have already tried it, or it's not going to be the answer anyway........

    :rolleyes::)
     
    #17 tommo47, Jan 31, 2017
    Last edited: Jan 31, 2017
  18. Kharl

    Kharl Well-Known Member
    Thread Starter

    hahah!
    i tried that!

    no luck
     
    tommo47 likes this.
  19. Kharl

    Kharl Well-Known Member
    Thread Starter

    i wi
    ll go to the carrier today they told me many phones form att habve that issue and they fix it, they do not guarantee e to do it but they wwat to try it

    in the other hand, i really love this phone, it goes with my lfiestyle, and i see no better option, the downsides of rooting youmention.. the warranty is not a concer, but the chance to bick it it is, but i think i am willing to take the risk, its just a matter to choose wich is the best ROM, the most reliable i could install, alli want is reliability then functionality.
     
  20. tommo47

    tommo47 On Yer Bike, In Yer Chair
    VIP Member

    Good luck!

    :)
     
  21. Kharl

    Kharl Well-Known Member
    Thread Starter

    i went to the #$%$#% carrier and then they told me theres is nothing they can do an dit is a phone issue.. but those #$#% told me by phone thay coul probably fix it...


    ok, thats how thinks work over here...
    back to the line

    i still have the problem
     
  22. Kharl

    Kharl Well-Known Member
    Thread Starter

    Ok, decision token
    i want to root this phone and to install a custom reliable ROM
    i need assistance
     
Loading...
Similar Threads - phone does run
  1. Cotzie
    Replies:
    3
    Views:
    470
  2. sonicbluemustang
    Replies:
    4
    Views:
    633
  3. germandowski
    Replies:
    3
    Views:
    7,380
  4. Cinque8
    Replies:
    8
    Views:
    1,273
  5. ApeironVpn
    Replies:
    0
    Views:
    523
  6. Papamalo
    Replies:
    3
    Views:
    900
  7. MoodyBlues
    Replies:
    38
    Views:
    2,910
  8. MartinW12
    Replies:
    6
    Views:
    640
  9. Nacole Amethyst
    Replies:
    5
    Views:
    1,140
  10. Uboatfreak
    Replies:
    3
    Views:
    4,225

Share This Page

Loading...