1. Are you ready for the Galaxy S20? Here is everything we know so far!

My SG2 has lost 3G connectivity, but no idea why

Discussion in 'Android Devices' started by Jozudave, May 23, 2011.

  1. Jozudave

    Jozudave Newbie
    Thread Starter

    Yesterday I noticed that when I went out (i.e. away from my home wifi network) my SG2 didn't seem to pick up any 3G and as such wouldn't connect to the net. The actual phone signal is fine and it reconnects to wifi automatically if I come back within range of that, but the 3G has disappeared despite me trying to get it to come back by turning it off and on and so on.

    Has this happened to anyone else? Does anyone know what I could try to fix it?

    My friend who has an iPhone says if he ever has connectivity problems then he perform a connections hard reset (i.e. completely reset all connections, not the phone itself) and then it will usually pick up what it's supposed to once he's done that. I can't see how to do that on SG2. Any ideas?

    EDIT: Found solution here about 2mins after posting - I must have turned off the connection without realising it: Samsung Galaxy S II - Disable Internet (3g/Edge/GPRS)

  2. XplosiV

    XplosiV Master X is Watching You

    Only thing that comes to mind is the wifi may be turning off your 3g ability. Try walking down the street with wifi off, and 3g on and see if your 3g data comes back.
  3. lotus49

    lotus49 Android Expert

    It happened to me for a few hours about a week ago.

    If I remember correctly, I rebooted the phone, which made no difference and then just didn't use it for a couple of hours. After that, it magically started working again and the problem has not repeated itself.

    I was somewhat dismayed at the time but since it hasn't happened again, I hadn't worried about it...

    ...until now (cue dramatic music)

    Perhaps there's a minor bug that surfaces very rarely, in which case it's no big deal. If it happened often, I would not be happy. I'll wait and see.
  4. Jozudave

    Jozudave Newbie
    Thread Starter

    I found out why. I accidentally switched off mobile internet.

    Hold the power button on the right side of the handset and it will bring up the list of four options (including the turn off phone as one option). The second option on the list is "Data Network Mode" - Hit that and it'll turn off mobile internet. And naturally it'll turn it back on again if you hit it again!
    dvdlesher and kenmines like this.
  5. madapaka2310

    madapaka2310 Lurker

    hi, im having same problem here, i have Samsung SG2 white, version 2.3.4, Im with att and its not connecting to the internet at all, i have signal and able to connect in wifi, but mobile internet isnt working. ive already check the settings such as the mobile package data. all sorts. still doesnt work...pls help i just bought this phone, and actually my 2nd SG2 i have the original black one which works perfectly with version 2.3.3, but this new one doesnt pls help
  6. tylerhalifax

    tylerhalifax Lurker

    I had exactly same thing. My SG2 3G internet just slowed down and stopped working. I worried all morning and then it occurred to me to just reset the thing - I did this and it worked a treat.
    If that doesn't work for you then hold the button on right side down until the Phone Options appear and make sure Data Network Mode is 'activated'.
  7. ajay.acharyakv

    ajay.acharyakv Well-Known Member

    Easier way to manage this is:
    Home Screen > Settings > Wireless and Network > Mobile Networks > Use Packet Data (enable it). If your SIM is 3G/Edge Data enabled, it will connect. If this still does not connect, the only issue would be with the network: call them and enable Data on your SIM.
  8. alaneg

    alaneg Lurker

    I have a similar problem after upgrading to Android 2.3.4. Have lost all signal and am unable to make or receive calls. Strength indicator shows 3 or 4 bars but every 15 seconds this changes to a with a line through. If I try to make a call phone locks and attempted call cannot be ended. Only option appears to be to turn off phone. Any suggestions?
  9. kenmines

    kenmines Lurker

    Brilliant! I've been in touch with vodafone and Samsung with this, and neither suggested this as the possible problem. It was, I did and it works again. I wasted hours trying out their suggestions - a pity nobody knew about this. Thanks again.
  10. fragglerock

    fragglerock Lurker

    I tried this and I do not have the "Data Network Mode" option, I only have silent mode, flight mode and power off and I still have not connectivity.
  11. Vlaaaad

    Vlaaaad Lurker

    how about you tell us please because i still cant get it to work :'\
  12. santiago4000

    santiago4000 Lurker

    I also struggle for a long time...here how I got it to work again.

    I am with Telus in Canada... mine also says silent mode, flight mode and power off when you hold the power botton.
    what I did to get it going again was:
    Press go to Settings >Wireless and network > Mobile networks > Access Point Names. Here it should should (in my case) Telus SP.
    Make sure it is not disabled.
    mine read sp telus-disable.(not sure why)
    So I selected it and deleted the "disable" now it reads sp telus

    Now it works
  13. numptyfish

    numptyfish Lurker

    This maybe goes without saying but this does seem to work, I'm in the UK on O2, had a problem where 3G disappeared, restarted phone and it come back but then disappeared again after using wi-fi.

    Tried this method by going to Settings>Wireless and network>Mobile networks>Access Point Names. However mine had 'O2 PREPAY' selected for some reason, even though I'm on contract.. Changed it to 'O2 Mobile Web' and now it seems to be working fine again.. Thanks Santiago!
  14. schneid200

    schneid200 Lurker

    Yeah. My 3G connection dissapeared suddenly. Solution is restablish vpn access point from Access Point Names and then activate your mobile connection. It'll work.
  15. Topper44530

    Topper44530 Lurker

    I have a Samsung Galaxy Y and my phone lost its 3G yesterday, so i switched it off then back on and it was fine, for a bit, but today it has lost it again so i switched it off/on again but it hasn't worked this time. I've tried all the things suggested on here because they're a similar phone, the only one i haven't tried is just waiting for a few hours, but is that reliable enough? :/
  16. s1ni5t3r

    s1ni5t3r Lurker

    I just solved this on my phone.

    Goto Settings -> more... -> Mobile Networks -> Access Point Names.

    Press the menu key and select reset to default. A list of network providers/types will come up. Select your provider and then select the correct radio button and you should be back in business.:)
  17. mikelufc

    mikelufc Lurker

    I have had a problem resetting my 3G connection to enable me to watch Skygo, i tried all the suggestions listed here but was still getting a 3G reset message from skygo when trying to access it, just by chance i went to the settings menu of skygo when i tried to switch it on, it came up with 2 boxs relating to switching on 3G, and letting me know when 3G is available, i turned them both on and what do you know, it works perfectly......so if you have tried all the solutions and still have problems, it may the app you are trying to use.......
    hope this helps!!!.....
  18. Random Kiwi

    Random Kiwi Newbie

    Any other suggestions peeps?

    Tired going into settings and the Packet Data option, it was on, but turned it off and back on again...nothing

    Data Network Mode is activated, tried turning it off and back on again...nothing

    Tried hard reset on the phone...nothing

    Was working perfectly fine, connected, playing some online poker, then just disconnected and now haven't had 3g connection for over an hour

  19. Russell Ng

    Russell Ng Android Expert

    Check with service provider if network is down. Try moving to another location and see if 3G can be re-activated. Might have to restart the phone to force a refresh of the connection.

    Other than that, see if you can find some wifi to connect to.
  20. Random Kiwi

    Random Kiwi Newbie

    It finally came back about an hour ago, connected to a wifi network and then once I switched the wifi off, up it popped...go figure, eh?
  21. Russell Ng

    Russell Ng Android Expert

    I think it was your service provider that was having a network problem.
  22. Argjent

    Argjent Newbie

    I am experiencing a similar problem now, my operator only uses EDGE, while I was toggling the Use packet data, the "E" sign disappeared, this never happened before. I have been struggling to get it back with Factory reset, removing PIN request, but no result at all, the bad thing is that I even tried using a different SIM card different operator, but the problem persists, Juice Defender still reports that I have a data connection (blue icon), but no connection.
    I don't think that it is a operator problem, because I tried another operator and friends reported that theirs were working fine :mad:

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date

Share This Page