1. Download our Official Android App: Forums for Android!

Support My wifi keeps disconnecting. .how do i fix this

Discussion in 'Android Devices' started by jonr991, Jan 15, 2014.

  1. jonr991

    jonr991 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    29
    Joined:
    Jan 15, 2014

    Jan 15, 2014
    29
    0
    15
    I have a galaxy s4, my wife keeps disconnecting because it I am being told my connection is too slow so android just disconnect s it automatically. My signal is fine when I try to reconnect (2-3bars). It will keep doing this every few minutes and is the most ANNOYING thing I think I have probably ever experienced in a phone. I am wondering if there is a way to turn off this feature of android or some app I can get that will disable it. Any help would be GREATLY appreciated
     

    Advertisement

  2. Rukbat

    Rukbat Android Expert
    Rank:
    None
    Points:
    843
    Posts:
    10,392
    Joined:
    Jan 16, 2012

    Jan 16, 2012
    10,392
    2,894
    843
    Male
    Being retired and writing Tasker tasks.
    Fayetteville, NC, USA
    Wifi or phone data? If wifi, this seems to be a "feature" of the 4.3 update. If phone data, contact the carrier's tech support number.
     
  3. jonr991

    jonr991 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    29
    Joined:
    Jan 15, 2014

    Jan 15, 2014
    29
    0
    15
    It's wifi. Is there a way to disable it?
     
  4. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,117
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,117
    24,060
    3,118
    Scotland
    If you head to Settings -> WiFi -> Advanced, is there an option to Avoid Poor Connections? Is that checked? I don't own the SGS4, but I have that option on several other Android devices.

    Also moved to the SGS4 general area :)
     
  5. jonr991

    jonr991 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    29
    Joined:
    Jan 15, 2014

    Jan 15, 2014
    29
    0
    15
    Not from what I can see. This is annoying beyond annoying. Also is there a way I can edit the title of this post? As you can tell, auto correct I'd a b***h
     
  6. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,117
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,117
    24,060
    3,118
    Scotland
    I did wonder about the title. I've sorted that for you.

    Is it all connections, or just one? Have you tried changing the channel your router broadcasts on as the current one might be a little congested. This app will tell you the best channel to use: https://play.google.com/store/apps/details?id=com.farproc.wifi.analyzer

    Also look at giving your phone a static IP, I've found that helps a number of WiFi problems.
     
  7. jonr991

    jonr991 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    29
    Joined:
    Jan 15, 2014

    Jan 15, 2014
    29
    0
    15
    How do I do that?
     
  8. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,117
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,117
    24,060
    3,118
    Scotland
    It needs to be done via your routers control panel, the method for each router will differ. If your router came with any documentation, it should give you a good idea of where to look and what to do.
     
  9. jonr991

    jonr991 Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    29
    Joined:
    Jan 15, 2014

    Jan 15, 2014
    29
    0
    15
    Sweet, that'll be fun to find haha. Also, I downloaded that ap and this is the only router with in range of me. So I really don't think that'd be the issue. I dunno what else there is that I could do to prevent this from happening.
     
  10. GunmetalX

    GunmetalX Lurker
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Feb 20, 2012

    Feb 20, 2012
    7
    2
    6
    El Presidente likes this.

Share This Page

Loading...