1. Download our Official Android App: Forums for Android!

Support my x10 keeps switching off please help

Discussion in 'Android Devices' started by MYX10ISUSELESS, Jan 3, 2012.

  1. MYX10ISUSELESS

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 3, 2012

    Jan 3, 2012
    1
    0
    5
    Hi guys,

    New to the forum and not a tech head, so any answers will have to be plain english for me please.

    My x10 keeps crashing, just switches off, it could happen 10 times a day, not on its own, i would be using at the time. I thought it was a RAM thing so i DL android booster, and it doesnt seem to be a battery low problem.

    I have taken out the battery and put it back in and I could of had a full battery and when put back in it would say 10 % and take it out again and put back in and it would be back to full.

    Is it a memory problem, does it overload, is it over heating ? Could it be a virus ? I regularly run the antivirus and nothing has ever shown up.The phone isnt rooted and I dont have a million apps either . . .

    Help, im close to hopping it off the wall. . .
     

    Advertisement

  2. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    My suggestion would be 1 of two things.

    One is to back everything up, and do a factory reset. This is 99 percent guaranteed to work the first time.

    The second option is to delete apps one at a time until you find the one's causing the problem. I would first suggest any android booster (which are garbage) and also any antivirus app.

    Or maybe install an app like Task Manager and open the task manager to see what apps are running. Kill all apps, wait 2 min, and open Task Manager again and take a look at what apps reappear on their own.

    Then post a list of those apps that reappeared.
     
  3. Panhead99

    Panhead99 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    13
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    13
    0
    15
    I posted on this subject last week in another thread. Mine did exactly the same thing so I put the battery from my wifes X10 in mine and mine stopped doing it but my wifes started shutting down. I have now fitted a new battery and the problem has gone. If you know someone with an X10 just swap the batteries and see if it makes a difference!
     

Share This Page

Loading...