1. Are you ready for the Galaxy S20? Here is everything we know so far!

MyTouch 3G Not Ringing

Discussion in 'Android Devices' started by StarMenace, Feb 7, 2011.

  1. StarMenace

    StarMenace Android Enthusiast
    Thread Starter

    I have a MyTouch 3G, or rather my wife does, that suddenly has stopped making any sound for incoming calls and the alarm. The vibrate works fine, it's only the sound that is not working.

    It has been working fine until last Thursday, since then, nothing. I've tried battery, SIM, SD pulls and even a factory reset but nothing is working.

    Anyone have any ideas on what it could possibly be? Other than it not making and sound the phone works perfectly.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. StarMenace

    StarMenace Android Enthusiast
    Thread Starter

    By the way it's on 2.2.1 = FRG83D and is the original MyTouch without the 3.5mm audio jack.
     
  3. StarMenace

    StarMenace Android Enthusiast
    Thread Starter

    I've narrowed it down to a faulty speaker since the speakerphone doesn't work either. Is that an easy repair?
     
  4. tukatz

    tukatz Android Enthusiast

    You should also be able to verify that diagnosis by trying to play music. If it were me, I would look for someone doing cell phone repair. I'm sure I've seen that sort of listing on Craig's List.
     
  5. MyNamesTooLong

    MyNamesTooLong Android Expert

    Blown speaker...or perhaps some other speaker malfunction
     
  6. StarMenace

    StarMenace Android Enthusiast
    Thread Starter

    It's definitely the speaker. I'll try someone on Craigslist to see what they say. Thanks!
     
  7. jeffster1967

    jeffster1967 Lurker

    I've tried taking the battery and SIM card out for 10 minutes and putting them back in. Sometimes it helps briefly and sometimes not at all. I've ordered a new battery from an Amazon.com Marketplace Seller and I'm going to try that. I must also mention that I am not using the phone with T-Mobile service...I had it unlocked to use with a Simple Mobile SIM card. The vibrate feature doesn't work either when it's supposed to ring, but my text/e-mail notification sound still works.
     
Loading...

Share This Page

Loading...