1. Download our Official Android App: Forums for Android!

Root Nand backup problems

Discussion in 'Android Devices' started by cableguynoe, May 26, 2010.

  1. cableguynoe

    cableguynoe Android Expert
    Thread Starter
    163

    Mar 30, 2010
    2,030
    264
    163
    I'm a cableguy....really
    Monterey, CA
    Trying to do a restore of a backup I made earlier today.

    It starts restoring then I get this error

    Error: run 'nandroid-mobile.sh restore' via adb!

    What the heck does that mean?
     

    Advertisement

  2. MJL

    MJL Android Enthusiast
    43

    Dec 13, 2009
    252
    27
    43
    Your battery is probably too low and its a fail safe so that your phone doesn't die and brick itself in the middle of an important flash. Usually if you just plug it in to the charger it will work fine.

    Sent from my HERO200 using Tapatalk
     
  3. wildtouch83

    wildtouch83 Android Enthusiast
    58

    Mar 5, 2010
    405
    24
    58
    yeah, plug it in and try to flash, that is usually the cause of that error.

    I ran into a problem one time where I renamed my nand backups and it did not like it at all. So, now I avoid putting spaces in my backup names. :)
     
  4. cableguynoe

    cableguynoe Android Expert
    Thread Starter
    163

    Mar 30, 2010
    2,030
    264
    163
    I'm a cableguy....really
    Monterey, CA
    Thanks guys. I actually think it was probably the spaces, since my battery was well over 50%. I had just renamed the backup...

    Anyhow... ended up not needing it.
     
  5. magicelf

    magicelf Well-Known Member
    16

    Dec 13, 2009
    86
    2
    16
    I just had the same problem, except I'm trying to MAKE a nand backup. I plugged the phone in and still getting error. I'm running Evil Eris 2.0.1. Any help?
     
  6. erisuser1

    erisuser1 Android Expert
    223

    Nov 11, 2009
    1,644
    759
    223
    There is a menu item in Amon_RA's recovery which is something like "copy recovery.log to SD". (It might be under the "Other" menu - I can't remember at the moment)

    Go ahead and do that, and then open up that text file (from your PC if you like), and look at the recovery log. Chances are the error which caused the problem will be immediately apparent - it will be towards the end of the file.

    If you are using adb with the Amon_RA recovery console running, rather than copying the log file to the SD card, you could just look at it this way:

    $ adb shell
    # more /cache/recovery/log


    eu1
     
  7. hitman_dreams

    hitman_dreams Newbie
    16

    Feb 9, 2010
    16
    1
    16
    Computer IT
    Holden, MA
    Check the space on your sd card and see if you have room. I had that error when I didn't have enough room for a backup. Cleared out some stuff to make room and it worked fine.
     
  8. That happened to me once running a nand back up.

    I surmised that my renaming of the back up did not include a correct character string, so I named it back to the date and time format that nand back ups use and everything went well after that.

    Now I just rename them on paper right next to the original nand back up name: ~6271437 = Evil Eris unclocked, etc.
     
  9. scary alien

    scary alien not really so scary
    Moderator
    2,138

    Mar 5, 2010
    22,122
    23,222
    2,138
    Male
    space alien ;)
    Indy
    FWIW, I did a Nandroid backup yesterday and got the same error as cableguynoe... I had full battery, plenty of space on my /sdcard. I just re-ran the backup and it worked fine.

    I did not check the recovery log though, so I don't really know what happened.

    I did check what (first/failed) Nandroid did create in its backup directory and noticed that the only file it did not create was the nandroid.md5 file.
     
  10. ACD168

    ACD168 Android Expert
    143

    Apr 30, 2010
    1,885
    162
    143
    I am having a different problem with restoring a nand, everything goes fine, but when it boots up it is the nand that I saved?
     
  11. If you get familiar with your files in the device, you'll learn a lot, my friend.

    Connect your usb cable to the computer and device and set it to "disc drive," then scroll around in there.

    In the "nandroid" folder you'll see your backup files. The number designation of them is a date and time of creating them (utc time I believe.. it is about 6 hours ahead of U.S. Central time, so I surmise it is utc.. could be mistaken).

    Anyway, the latest one obviously has the most recent date and time; that's very likely the one you're running as long as you rebooted at the prompt to do so right after creating the nand back up.
     
  12. ACD168

    ACD168 Android Expert
    143

    Apr 30, 2010
    1,885
    162
    143

    I think you misinterpreted me. thanks tho
     
  13. Darn, I apologize. What did you mean in your question?
     
  14. ACD168

    ACD168 Android Expert
    143

    Apr 30, 2010
    1,885
    162
    143

    Actually I just went back and looked at my post and I mis typed. Sorry about that:cool:

    my problem is this.
    I have a bunch of NAND back-ups I slimmed it down to 10 right now.
    I name that right after doing a back-up So I know what one it is and not to get things messed up.
    I did a fresh nand for Eris Official just set up no apps just a fresh nand. renamed it, then continued working on the ROM getting my apps and everything set up, and then made a new NAND of this one set up to my liking.
    I then switched to the new froyo to check that out.
    and here now lies my problem, after all this I went to NAND back to the back-up I did earlier of Eris Official with everything set up.
    problem being, it was the nand of the one I did of the fresh set up.
    And I know i didnt mess up renaming them because I do it right after doing a nand so its impossible because I tried the other one just to make sure i didnt mess up and it was the same thing,(well this one is actually correct)
     
  15. I don't think the nand bu system is perfect. I've seen remnants of deleted back ups show up both on boot up screens and on the home screen, especially with two different launchers involved.
     
  16. dirtmouth

    dirtmouth Android Enthusiast
    36

    Feb 14, 2010
    361
    6
    36
    Corpus Christi , Texas
    how do you do a back up?
     
  17. ACD168

    ACD168 Android Expert
    143

    Apr 30, 2010
    1,885
    162
    143
    reboot into recovery (turn off phone, turn back on by holding vol down and power at same time)
    go to Backup/Restore(choose this by pressing in the trackball)
    then choose Nandroid backup(this backs up your current ROM set-up-this does everything, even txt msgs, applications, every set up.
    nand restore will restore the back up
     
  18. dirtmouth

    dirtmouth Android Enthusiast
    36

    Feb 14, 2010
    361
    6
    36
    Corpus Christi , Texas
    its not vol up and pwr?
     
  19. cableguynoe

    cableguynoe Android Expert
    Thread Starter
    163

    Mar 30, 2010
    2,030
    264
    163
    I'm a cableguy....really
    Monterey, CA
    It is :D
    Htbd is just trying to throw you off:D
     
    dirtmouth likes this.
  20. dirtmouth

    dirtmouth Android Enthusiast
    36

    Feb 14, 2010
    361
    6
    36
    Corpus Christi , Texas
    and ya wonder why a float a question, thx cable noe , if i may.
     
  21. ACD168

    ACD168 Android Expert
    143

    Apr 30, 2010
    1,885
    162
    143
    crap, sorry man, wasn't intentional.
     

Share This Page

Loading...