1. Check out our companion app, Forums for Android! Download from Google Play

Natwest banking app incompatible with MIUI?

Discussion in 'Android Devices' started by cdl, Nov 24, 2011.

  1. cdl

    cdl Well-Known Member
    Thread Starter

    Feb 4, 2010
    I have a Samsung Galaxy S2 (UK version, bought unlocked) running MIUI 1.11.11. I tried to download the official banking app made by my bank (Natwest):

    https://market.android.com/details?id=com.rbs.mobile.android.natwest&rdid=com .rbs.mobile.android.natwest&rdot=1

    but if I access the market from the web, it tells me the app is not compatible with my device. If I access it from my phone, the app doesn't show up at all. :mad:

    This guy:
    xda-developers - View Single Post - Natwest App now available but I can't download it

    fixed the problem on his HTC phone changing the ro.build.fingerprint line in the build.prop file. (To access the file, you need an app like 'root explorer': you'll find the file in /system.)

    My question is: if any of you has managed to run this app, could you please post your build.prop on this forum? I'd like to try changing the ro.build.fingerprint and/or some other parameters but I don't know what values will make the phone compatible with the app.

    Alternatively, even if you don't have the app but are running a stock rom or a non-Cyanogen based rom, could you please post your build.prop so I can experiment a bit?

    I know I could flash a stock rom but if you could post your file it would be much easier! Hopefully there is no sensitive information there, and, if there is you can always take it out as I certainly don't need it.



  2. Slug

    Slug Check six!

    Aug 1, 2009
    Mobile phone retail
    Inverness, UK
    Here's mine from DlevROM v3.1 (Samsung KI4-based). Android Market says that the NatWest app is compatible and lets me download it.

    Code (Text):
    1. # begin build properties
    2. # autogenerated by buildinfo.sh
    3. ro.build.id=GINGERBREAD
    4. ro.build.display.id=DlevROM2 3.1 KI4 Edition
    5. ro.build.version.incremental=XXKI4
    6. ro.build.version.sdk=10
    7. ro.build.version.codename=REL
    8. ro.build.version.release=2.3.5
    9. ro.build.date=Tue Sep 27 16:33:36 KST 2011
    10. ro.build.date.utc=1317108816
    11. ro.build.type=user
    12. ro.build.user=se.infra
    13. ro.build.host=SEP-62
    14. ro.build.tags=release-keys
    15. ro.product.model=GT-I9100
    16. ro.product.brand=samsung
    17. ro.product.name=GT-I9100
    18. ro.product.device=GT-I9100
    19. ro.product.board=GT-I9100
    20. ro.product.cpu.abi=armeabi-v7a
    21. # Samsung Specific Properties
    22. ro.build.PDA=I9100XXKI4
    23. ro.build.hidden_ver=I9100XXKI4
    24. ro.build.changelist=611039
    25. ro.product.cpu.abi2=armeabi
    26. ro.product.manufacturer=samsung
    27. ro.product.locale.language=en
    28. ro.product.locale.region=GB
    29. ro.wifi.channels=
    30. ro.board.platform=s5pc210
    31. # ro.build.product is obsolete; use ro.product.device
    32. ro.build.product=GT-I9100
    33. # Do not try to parse ro.build.description or .fingerprint
    34. ro.build.description=GT-I9100-user 2.3.5 GINGERBREAD XXKI4 release-keys
    35. ro.build.fingerprint=samsung/GT-I9100/GT-I9100:2.3.5/GINGERBREAD/XXKI4:user/release-keys
    36. # Samsung Specific Properties
    37. ro.build.PDA=I9100XXKI4
    38. ro.build.hidden_ver=I9100XXKI4
    39. ro.build.changelist=611039
    40. ro.tether.denied=false
    41. ro.flash.resolution=1080
    42. # end build properties
    43. #
    44. # system.prop for asop5000
    45. #
    47. rild.libpath=/system/lib/libsec-ril.so
    48. rild.libargs=-d /dev/ttyS0
    49. ro.sf.lcd_density=240
    50. dalvik.vm.heapsize=64m
    52. # Samsung USB default mode
    53. persist.service.usb.setting=0
    54. dev.powersave_fps=0
    56. #
    58. #
    59. ro.url.legal=http://www.google.com/intl/%s/mobile/android/basic/phone-legal.html
    60. ro.url.legal.android_privacy=http://www.google.com/intl/%s/mobile/android/basic/privacy.html
    61. ro.com.google.locationfeatures=1
    62. ro.setupwizard.mode=OPTIONAL
    63. ro.com.google.gmsversion=2.3_r7
    64. media.stagefright.enable-player=false
    65. media.stagefright.enable-meta=false
    66. media.stagefright.enable-scan=false
    67. media.stagefright.enable-http=true
    68. media.stagefright.enable-rtsp=false
    69. dev.sfbootcomplete=0
    70. ro.com.google.clientidbase=android-samsung
    71. ro.url.legal=http://www.google.com/intl/%s/mobile/android/basic/phone-legal.html
    72. ro.url.legal.android_privacy=http://www.google.com/intl/%s/mobile/android/basic/privacy.html
    73. ro.com.google.locationfeatures=1
    74. keyguard.no_require_sim=true
    75. ro.config.ringtone=S_Over_the_horizon.ogg
    76. ro.config.notification_sound=01_Sherbet.ogg
    77. ro.config.alarm_alert=Good_Morning.ogg
    78. ro.config.media_sound=Media_preview_Touch_the_light.ogg
    79. ro.opengles.version=131072
    80. ro.secdevenc=true
    81. ro.wtldatapassword=true
    82. net.bt.name=Android
    83. dalvik.vm.stack-trace-file=/data/anr/traces.txt
    85. persist.adb.notify=1
    cdl likes this.
  3. cdl

    cdl Well-Known Member
    Thread Starter

    Feb 4, 2010
    Thanks. I tried your parameters, and those posted here:
    SGS2 build.prop - xda-developers
    but to no avail.

    I downloaded the app on another phone (a Motorola), extracted the apk from /data/app-private as explained here:
    NatWest banking app - Page 2 - xda-developers

    sent it to my SGS2, but when I try to install it I get the error: "there is a problem parsing the package".
    I tried installing it with the built-in MIUI file explorer and with AndroExplorer.

    Just to be sure, I verified that on my Motorola I can reinstall the app from the apk file, after uninstalling it of course, using AndroExplorer.

    Maybe this app is simply not compatible with MIUI?
    This would be in line with what's explained here:
    UK Banking Apps not Compatible? - Android @ MoDaCo

    BankControl.co.uk is another banking app which is incompatible with my SGS2 running MIUI. According to the post above,
    The same might be true of the Natwest / RBS banking app. I am just guessing, of course.

    If any one can shed any light on this, it would be appreciated!
  4. cdl

    cdl Well-Known Member
    Thread Starter

    Feb 4, 2010
    Quick update: the apk got corrupted because I emailed it from one phone to the other and a slightly smaller file was received; a few KBs must have got lost along the way... :thinking:

    I transferred from the Motorola to my PC and from there to my SGS2, and this time the app worked perfectly! :)

    So, to recap, both MIUI and the SGS2 are perfectly capable of running the app :cool: , but, for some reason beyond my understanding, if you're running MIUI the market will flag the SGS2 as incompatible with the app. :(
  5. Slug

    Slug Check six!

    Aug 1, 2009
    Mobile phone retail
    Inverness, UK
    I've removed the post with the attached APK, not because it contravened any AF rule, but simply because NatWest might freak out, go into full-on "security breach mode" if they discovered the app posted on a web forum, and do something silly like lock it out.

    Anyone running into the same issue can always PM you for details of the workaround. I also hope you've flagged the issue up with the ROM developers? Something they've done must be causing the handset to be misidentified by the Market API.
  6. cdl

    cdl Well-Known Member
    Thread Starter

    Feb 4, 2010
    I see. Makes sense. And yes, of course, if anyone wants details they can always pm me.

    I installed 'a track dog' and will report on whether it manages to keep track of the Natwest app and download updates.

    I made a post on the miuiandroid.com forum and will probably do one on the Cyanogen forum, as MIUI is Cyanogen-based.

    A weird thing, though: if I search the market for 'natwest' on my Samsung, it says '3 results', which I suppose should be the same I see when accessing the market from my pc: the official Natwest app, Money toolkit, and Bank Control (www.bankcontrol.co.uk). Anyway, it says 3 results but it only shows one: Money toolkit.

    I did the same for bankcontrol which I did on the Natwest app (installed on another phone, extracted the apk, and installed manually) and that app works fine, too. I then contacted the developers who said they didn't put any restrictions on compatibility, so that their app should be flagged as compatible with the MIUI rom, too, but clearly it isn't.

    Now, I understand that Natwest may not want its app to run on non-official roms (even if some official roms may well have more spyware than non-official ones: Developer Hit with Cease and Desist Order for CarrierIQ Investigations ) but it's puzzling that BankControl is flagged as incompatible even though its developers are saying it shouldn't... :thinking:
  7. cdl

    cdl Well-Known Member
    Thread Starter

    Feb 4, 2010
    I contacted Natwest on the number which is supposed to be their
  8. mekhas

    mekhas New Member

    Aug 15, 2011
    Apparently, this issue has been sorted and the Bank Control UK app is visible on the Market from Cyanogen.
  9. qwerty0000

    qwerty0000 New Member

    Mar 4, 2012
    Hi Guys, I have been reading this post and am having a similar issue in that I have a sgs2 running cm9 but since doing so rbs app is now say incompatible. Please help with a workaround it be appreciated.

    Thanks for anyones help.
  10. dwb790

    dwb790 New Member

    Aug 10, 2010
    I simply found an apk elsewhere on my PC. Copied it to SD card. Run apk using root explorer. installed. bingo, working.
  11. bonsc

    bonsc Member

    Dec 10, 2011
    Is it the latest apk

Share This Page