1. Are you ready for the Galaxy S20? Here is everything we know so far!

Navigation and Froyo ROMS

Discussion in 'Android Devices' started by Maxwell, Feb 14, 2011.

  1. Maxwell

    Maxwell Member
    Thread Starter

    I noticed that whenever I run a Froyo ROM, navigation loses the GPS signal and spends a long time trying to reacquire the signal whereas when I run xtrROM or any other 2.1 ROM, navigation works great. Anyone know of a fix for this on the Froyo ROMs?

    Thanks in advance.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. doogald

    doogald Extreme Android User

    This seems to be an issue with all of the CyanogenMod ROMs, including the Cyanogen ELB 2.8 ROM that is Android 2.1 and the early Gingerbread ROMs.

    See [Q] GPS signal lost on multiple roms - xda-developers for a lot more information.

    As I understand it, the CyanogenMod team knows of this, however - the Eris is not an official CyanogenMod build, so who knows if it will ever get fixed for this device?

    I think that if Navigation is an important use of your phone, I'd stick with the HTC-based 2.1 ROMs - xtrSENSE, xtrROM, xtrRCMix, TaintedTenzo, PlainJane, etc. If you prefer vanilla Android, you can try Vanilla 2.0.4, which I understand is pure Android Open Source Project based, rather than from CyanogenMod source. It may be better.

    [edit]

    Some people in that thread report better results from KaosFroyo. That may be worth a try, if you want to stay with Froyo. It makes some sense that KF may be different, as KF is the least CyanogenMod build of the Froyo ROMs - as I understand it, KF is a mix of CyanogenMod and AOSP.
     
  3. Maxwell

    Maxwell Member
    Thread Starter

    Hi dg, thanks for the quick and thorough response. Yes,navigation is important to me so I guess I will stick with xtrROM until I get a chance to try Kaos.

    I know I used an app called GPS Status to fix the problem in the past and it worked but I can't remember if I used it on a 2.1 or 2.2 ROM. I know it didn't work on the current froyo rom I am running.

    Thanks again.
     
  4. erisuser1

    erisuser1 Android Expert

    There is a crude workaround - in the GPS Status app, if you perform a new Download of A-GPS assistance data (Menu->Tools->Manage A-GPS state->Download), the Nav app will recover it's connection to the GPS.

    Obviously, you would toggle between the two apps using the Home key, so that you do not need to exit the Nav application (this avoids the need to re-enter the destination).

    Not a great idea if you are driving and want to stay hands -free, though.
     
  5. Maxwell

    Maxwell Member
    Thread Starter

    I just flashed KaosfroyoV39 and it didn't come with the navigation app. Does anyone know if there is a zip that will put it and quickoffice back on the phone? Thanks in advance again.
     
  6. Maxwell

    Maxwell Member
    Thread Starter

    Thanks for your earlier post EU. I tried GPS Status with VanillaTazz and the results weren't as good as my previous experience under a different ROM. Just flashed Kaos and no navigation app. Guess I have to go back to xtrROM for now.
     
  7. doogald

    doogald Extreme Android User

    The Navigation app is part of Google Maps. If you install Google Maps from the market, it should add icons for Navigation, Places, Latitude, and perhaps others.

    At the very least, you can use Google Maps to search for an address and then there should be an option to navigate to it.
     
  8. Maxwell

    Maxwell Member
    Thread Starter

    Hey dg, thanks for your response again. When I flashed kaos, google maps did an update on its own. After the update, besides maps, I found places and latitude and nothing else related. I did try, with the limited time I had at the moment, to use maps for navigation and was only able to get listed directions as oppose to turn by turn voice navigation. And as EU said in a previous post, I didn't want to fumble around looking for any options that may lead to navigation while I was on the road. Gonna explore Maps more later and will keep you up to date on my progress.
     
  9. scotty85

    scotty85 Extreme Android User

    i have never had this issue. have you tried navigating from inside of maps? usually after you navigate once from inside maps once,the navigation will work correctly when accesed directly,from maps,or from car home. that is the usual fix for froyo gps issues and has worked for me.

    while i cannont claim i could drive from ohio to florida without losing siginal,the froyo roms ive tried has worked wonderfully to navigate for shorter periods(up to an hour or so).

    it is in fact smarter than my magellan dash mounted gps,wich still thinks i am driving across a field when i cut across a new cross street :D my phone navigation is aware of this street,and doesnt seem to take me in nearly as goofy of a route as the magellan sometimes does(one time it had me pass my destination,drive around the block,and then come back to get to it :eek: )
     
  10. doogald

    doogald Extreme Android User

    Actually, to me the best thing about Android's Nav, compared with a typical dash mounted unit from Garmin/TomTom, etc., is that when you miss a turn, rather than the silly "recalculating", Google Nav doesn't do anything to tell you you've missed a turn - it just tells you where to make your next turn to get you back on track.
     
  11. Maxwell

    Maxwell Member
    Thread Starter

    Thanks to all that responded to my problem. I am happy to say that problem seem to have been rectified. I wasn't able to find turn-by-turn voice navigation within Maps (I am sure it was right in front of me...lol) so I restored Vanilla Tazz and tried EU1's method involving GPS Status. This worked perfectly. I was able to test it out on a 10 mile (20 minute drive) and not once did I lose the signal. The method I used in the past with GPS Status involved force stopping the navigation app, clearing its cache before downloading A-GPS. EU1's advice worked like a charm.

    Again, thanks to all!
     

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...